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TankMaster

NOTICE
Read this manual before working with the product. For personal and system safety, and for optimum product
performance, ensure you thoroughly understand the contents before installing, using, or maintaining this product.
For equipment service or support needs, contact your local Emerson representative.

Version

This manual is based on the functionality of TankMaster version 6.G1.
For older TankMaster versions all functionality described in this manual may not be available and the Graphical User
Interface (GUI) may look different.

Safety messages

 WARNING
Physical access
Unauthorized personnel may potentially cause significant damage to and/or misconfiguration of end users’
equipment. This could be intentional or unintentional and needs to be protected against.
Physical security is an important part of any security program and fundamental in protecting your system. Restrict
physical access by unauthorized personnel to protect end users’ assets. This is true for all systems used within the
facility.
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1  Introduction
Rosemount TankMaster WinOpi provides operator overview for Rosemount Tank Gauging
systems.
TankMaster WinOpi is a complete custody transfer and inventory software package. All
calculations are based on current API and ISO standards.
This reference manual covers the functionality of the TankMaster WinOpi software.
Descriptions and examples are based on the WinOpi software user interface.

1.1  What is Rosemount TankMaster™?
The TankMaster software suite provides you with the tools that you need to configure
and operate the Rosemount Tank Gauging system. The Rosemount Tank Gauging product
portfolio includes a wide range of components for small and large customized tank
gauging systems. The system includes various field devices, such as radar level gauges,
temperature transmitters, and pressure transmitters for complete inventory control. For
detailed descriptions of how to setup various devices refer to the respective reference
manuals.
TankMaster is an Emerson inventory management software package for installation and
configuration of level gauging equipment. It is a complete custody transfer and inventory
software package that provides operator overview for Rosemount Tank Gauging systems.
All calculations are based on current API and ISO standards.
TankMaster provides you with powerful and easy-to-use tools for installation and
configuration of level gauging devices such as radar transmitter gauges (RTGs). The
settings for protocols, devices and tanks can be changed in real time.
The graphical interface gives you a clear overview of installed devices and tanks. For each
tank you can easily see the associated transmitters in the WinSetup application.

1.1.1  Key features
• Monitoring of measured data
• Clear overview of installed tanks and devices (using WinSetup)
• Simple installation using wizards (using WinSetup)
• Open connectivity
• Object-oriented, user-friendly Graphical User Interface (GUI)
TankMaster is designed to be used in a Microsoft® Windows environment, providing easy
access to measurement data from any PC in your network. Measurements and data are
presented in realtime and you can customize views to suit your needs.
Rosemount TankMaster lets you connect via the Ethernet TCP/IP interface. You may also
use TRL2, RS232, or RS485 interfaces if needed. Other communication interfaces, such
as Enraf BPM, are also supported. Rosemount TankMaster is based on the open OPC
standard, allowing you to import data into other systems such as DCS:s, PLC:s, Scada
systems and Microsoft Office programs.
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1.1.2  Intended use of product
Rosemount TankMaster serves as a monitoring interface that provides the user with tank
data such as level, temperature, pressure, volume etc. It is a custody transfer and inventory
software package that supports calculations based on current API and ISO standards. See
End User License Agreement for complete terms and conditions for using the Rosemount
TankMaster software package

1.2  Manual overview
The Rosemount TankMaster WinOpi Reference Manual provides descriptions of the
TankMaster WinOpi operator's interface and instructions for operating the Rosemount
Tank Gauging system. The manual includes the following sections:
Chapter Introduction provides a short introduction to Rosemount TankMaster.
Chapter The main window provides an introduction to the basic features of the WinOpi
operator’s interface. It describes the workspace, menus, and various toolbars.
Chapter Viewing tank data provides a description of various functions for viewing tank data
and inventory data.
Chapter Installing a tank measurement system provides a description of how to setup an
inventory system in TankMaster WinOpi.
Chapter Alarm handling describes how to setup alarm limits, alarm groups, and how to
view and accept current alarms.
Chapter Reports provides a description of how to create and distribute reports with
inventory information.
Chapter Audit log provides a description of how to enable recording of operations and
actions performed by a TankMaster user.
Chapter Tank calculators provides a description of how to use calculators for Density, Tank
inventory, transfer, and settling.
Chapter Customizing the layout describes how to create customized menus, windows, and
toolbars in TankMaster.
Chapter Servo commands describes how to send commands to servo gauges.
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1.3  Technical documentation
The Rosemount Tank Gauging System includes a wide portfolio of user documentation. For
a complete list, see product pages on Emerson.com/Rosemount.
Reference manuals
• Rosemount Tank Gauging System Configuration Manual (00809-0300-5100)
• Rosemount 2460 System Hub (00809-0100-2460)
• Rosemount 2410 Tank Hub (00809-0100-2410)
• Rosemount 5900S Radar Level Gauge (00809-0100-5900)
• Rosemount 5900C Radar Level Gauge (00809-0100-5901)
• Rosemount 2240S Multi-Input Temperature Transmitter (00809-0100-2240)
• Rosemount 2230 Graphical Field Display (00809-0100-2230)
• Rosemount 5300 Guided Wave Radar (00809-0100-4530)
• Rosemount 5408 Radar Level Transmitter (00809-0300-4408)
• Rosemount 3308 Series Wireless Guided Wave Radar (00809-0100-4308)
• Rosemount Tank Gauging Wireless System (00809-0100-5200)
• Rosemount TankMaster Software Installation Manual (00809-0400-5110)
• Rosemount TankMaster WinOpi (00809-0200-5110)
• Rosemount TankMaster WinSetup (00809-0100-5110)
• Rosemount TankMaster WinView (00809-0300-5110)
• Rosemount 5900 Proof Test with Reference Reflector (00809-0200-5900)
• Rosemount TankMaster Floating Roof Monitoring (00809-0500-5100)
• Rosemount TankMaster Full containment tanks (00809-0500-5110)
• Rosemount 5900 Radar Level Gauge and Rosemount 2410 Tank Hub Safety Manual

Option S (00809-0400-5100)
• Rosemount 5900 Radar Level Gauge and Rosemount 2410 Tank Hub Safety Manual SIL3

(00809-0200-5100)
• Rosemount TankMaster Mobile User Guide (00809-0100-5120)
• Rosemount TankMaster Mobile Installation Manual (00809-0200-5120)
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Product data sheets
• Rosemount Tank Gauging System (00813-0100-5100)
• Rosemount TankMaster Inventory Management Software (00813-0100-5110)
• Rosemount TankMaster Mobile Inventory Management Software (00813-0100-5120)
• Rosemount 2460 System Hub (00813-0100-2460)
• Rosemount 2410 Tank Hub (00813-0100-2410)
• Rosemount 5900S Radar Level Gauge (00813-0100-5900)
• Rosemount 5900C Radar Level Gauge (00813-0100-5901)
• Rosemount 2240S Multi-input Temperature Transmitter (00813-0100-2240)
• Rosemount 565/566/765/614 Temperature and Water Level Sensors (00813-0100-5565)
• Rosemount 2230 Graphical Field Display (00813-0100-2230)
• Rosemount 5300 Level Transmitter (00813-0100-4530)
• Rosemount 5408 Level Transmitter (00813-0100-4408)
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1.3.1  System and user documentation structure
Figure 1-1: Rosemount Tank Gauging System and User Documentation Structure

Rosemount 2240S Reference Manual 
(Document No. 00809-0100-2240)

Rosemount 2230 Reference Manual 
(Document No. 00809-0100-2230)

Rosemount Tank Gauging System Configuration Manual 
(Document No. 00809-0300-5100)

Rosemount TankMaster WinSetup Reference Manual 
(Document No. 00809-0100-5110)
Rosemount TankMaster WinOpi Reference Manual 
(Document No. 00809-0200-5110)

Rosemount TankMaster WinView Reference Manual 
(Document No. 00809-0300-5110)
Rosemount TankMaster Software Installation Manual  
(Document No. 00809-0400-5110)

Rosemount 2460 Reference Manual 
(Document No. 00809-0100-2460)

Rosemount 2410 Reference Manual 
(Document No. 00809-0100-2410)

Rosemount 5900S Reference Manual 
(Document No. 00809-0100-5900)
Rosemount 5900C Reference Manual 
(Document No. 00809-0100-5901)
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1.4  TankMaster software package
The TankMaster software package comprises the following software modules:
• WinOpi
• WinSetup
• WinView
• Batch server
• Tank server
• Master Protocol servers
• Slave Protocol servers

Figure 1-2: Software Modules

WinOpi
WinOpi is the operator interface to the tank gauging system. It communicates with the
Tank Server and various protocol servers to let the user monitor measured tank data.
WinOpi also provides:
• alarm handling
• automatic report distribution
• historical data sampling
• inventory calculations for volume, observed density and other parameters.
WinSetup
The WinSetup program is a graphical user interface (GUI) for installation, configuration and
maintenance of level gauging devices.
WinView
WinView is a software package with basic inventory capabilities. It communicates with the
Tank Server and the different protocol servers to let the user monitor measured tank data.
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Tank server
The Tank Server communicates with devices via the Master Protocol Server and handles
configuration data for all installed tanks and devices. Parameters stored by the Tank Server
include:
• device names
• configuration data, such as antenna type
• number of connected temperature sensors
• number of connected analog inputs
The Tank Server collects data from connected devices and distributes this information to
the WinOpi and WinSetup user interface.
Master protocol server
The Master Protocol Server transfers configuration data and measured data between the
Tank Server and connected devices in the tank gauging system. The Master Protocol Server
is able to communicate with various types of devices such as FCUs, the Rosemount 2410
Tank Hub, and the Rosemount 5900S Radar Level Gauge to collect measurements for, for
example, level, temperature and pressure.
Slave protocol
The Slave Protocol Server is used to connect the TankMaster system to a host computer
(DCS system). The Slave Protocol Server exchanges tank data between the Tank Server and
the host computer.
OPC Server with browser
TankMaster uses OPC Data Access 2.0 (OLE for Process Control), an open industry
standard, which eliminates the need for costly customized software integration.
With the OPC server and the browser it is easy to import all custody transfer and inventory
data to other OPC clients such as different DCS:s, PLC:s, Scada systems, or Microsoft®

Office programs.
See the web site for the OPC Foundation for more information: www.opcfoundation.org.
Customized views
You can customize specific views and windows in TankMaster. Existing objects can be
modified, or you can build new ones. You could, for example, create a window with an
embedded image of your own plant, to give a realistic overview, and configure the window
so that when you click on a specific tank in the image you can access the corresponding
data for that tank.

1.5  Server hardware key
The Server Hardware Key Info window displays the functions enabled by the TankMaster™

hardware key. The information displayed is only valid for the selected server and cannot
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be altered. Also shown is the number of tanks that can be installed according to the
TankMaster license, and the current number of installed tanks.
Procedure

1. Open menu option Tools → View Server HW Key Info.

2. Select the desired server to view hardware key information.
3. Click Close to close the Server Hardware Key Info window.

1.5.1  System type
System Type indicates which mode TankMaster™ is running.
Inventory system
TankMaster runs as a complete custody transfer and inventory software package. All
calculations are based on current API and ISO standards.
WinView system
WinView basic inventory capabilities suitable for smaller plants and terminals.
Demo system
TankMaster is running with full functionality using simulated values.

Introduction Reference Manual
March 2024 00809-0200-5110

12 Emerson.com/Rosemount



1.5.2  Supported functions
The Supported Functions pane in the Server Hardware Key Info window shows available
TankMaster™ options. Selected options indicate that the corresponding function is enabled
with the current hardware key. The table below gives an overview of the available
functions.
Table 1-1: Supported Functions
Function Explanation
Host Access to server via OPC
and serial

Enables OPC and Modbus communications between TankMaster
and SCADA/DCS

Redundancy Enables the use of redundant servers
Network access for TM client
nodes

Enables a TankMaster client to connect to the network and read
tank and device data.

Extended Batch Function(1) Creates MS Access files. Stores closed batches for up to 365
days. Delivery tickets can be recalculated. Tank Transfer Calculator
enabled.

Custody Transfer System Setup mode for the Custody Transfer System.
Custody Transfer Seal Write-protected mode. No possibility to change configuration.
HTG calculation and Setup Hydrostatic Tank Gauging, Enables level and inventory data from

pressure.
Window Customizing Enables the creation of customized windows.
Service Key Personal key for service engineers.
Floating Roof Monitoring Enables TankMaster function for monitoring floating roof tilt and

buoyancy.

(1) For more information and instructions on Batch Handling, please refer to the
TankMaster Batch Handling User Guide

1.5.3  Tanks
The Tanks pane shows the number of licensed tanks and the number of installed tanks.
If the number of installed tanks exceeds the number of licensed tanks, the inventory
calculation option is disabled until a hardware key with a sufficient number of licensed
tanks is installed, or until tanks are uninstalled and the number of installed tanks is equal
to or less than the number of licensed tanks.

1.5.4  TankMaster Network client nodes
The TankMaster Network Client Nodes pane shows the number of licensed nodes and
the number of connected nodes for the selected server. The number of connected nodes
cannot exceed the number of licensed nodes.
If the number of connected nodes is the same as the number of licensed nodes, no more
nodes will be able to connect unless currently connected nodes are first disconnected, or
until a new license key with an increased number of licensed nodes is installed.
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1.6  Illegal characters
The following characters should not be used when naming objects in TankMaster™ as this
may cause undesirable results:
Table 1-2: Illegal Characters in TankMaster
\ Reverse solidus % Percent symbol
/ Solidus < Less-than symbol
? Question mark > Greater-than symbol
* Asterisk { Left curly bracket
[ Left square bracket } Right curly bracket
] Right square bracket ' Apostrophe
| Vertical line " Quotation mark

Introduction Reference Manual
March 2024 00809-0200-5110

14 Emerson.com/Rosemount



2  The main window
All tools and functionality can be accessed from the main menu bar at the top of the
screen. The toolbar directly below the menu contains buttons with shortcuts to the most
common operations.
The main window includes a Workspace which displays tanks, devices, alarm groups and
reports. Right-clicking on objects in the workspace gives access to associated views, tools
and functionality for that object.
A status bar at the bottom of the screen shows alarm and connectivity information.

Figure 2-1: WinOpi Workspace

A. Menu bar
B. Tool bar
C. Workspace
D. Status bar

The Workspace area can be docked on any side of the main window, or it can be moved
anywhere in the Main window when it is floating.
Docking and floating is toggled by right-clicking in the Workspace area and selecting, or
deselecting Allow Docking.
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2.1  Menus
The menu bar at the top of the main window contains the following menus: File, View,
Entry, Setup, Reports, Batches, Tools, Custom, and Help.

Figure 2-2: Menu Bar

A. Menu bar

Some menu options are available by right-clicking on an object in the Workspace window.
Available options varies depending on the type of object that is selected.
Example
The Entry → Tank Entry option in the menu bar can also be found by right-clicking on a
tank icon.

Figure 2-3: Tank Entry

Note
For more information and instructions on the functionality in the Batches menu, please
refer to the TankMaster Batch Handling User Guide.
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2.2  Toolbar
The toolbar contains buttons which act as shortcuts to various tools and functionality. The
toolbar can be toggled from the View menu.

Figure 2-4: Toolbar

A. Toolbar

The toolbar can be toggled on or off from the View menu.

Figure 2-5: Toolbar Option in View Menu

A. Toolbar option
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Toolbar options
The following items are included in the standard toolbar:

Figure 2-6: Toolbar Options

A. Log off (View Only mode)
B. Log on to TankMaster
C. Toggles the Workspace window
D. Opens the Tank View, Tank Inventory, and Extended View window for a selected tank
E. Opens the Group View, Bar Graph Group, or Tank Movement window for a group of tanks
F. Alarm Summary for a tank group, Alarm Summary for the current active alarm group,

Alarm Log, and Accept alarm
G. Program Options
H. Create a new batch
I. Density calculator
J. Realtime View window

K. Historical Table window
L. Historical Data View window

M. About WinOpi

The main window Reference Manual
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2.3  Status bar
The status bar located at the bottom of the TankMaster main window displays information
about connectivity, current alarms and the current protection level status (View Only,
Operator, Supervisor, Administrator, and ChiefAdmin).

Figure 2-7: Status Bar

A. Connection status
B. Alarm status
C. Current user
D. Current protection level
E. Operation status (green=normal operation)

2.4  Workspace views
The workspace offers an overview of all devices and tanks. To switch between the different
views, click on a tab: Groups, Plants or Batches.

Figure 2-8: Workspace Views

The workspace lets you perform a variety of tasks from these different views, including:
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• Viewing tank and inventory data.
• Viewing alarm logs and alarm summary.
• Organizing tanks in different groups.
• Monitoring alarms.
• Creating reports.
• Batch Handling
Note
For more information and instructions on working with batches, please refer to the
TankMaster Batch Handling User Guide.

2.4.1  Viewing tanks and groups
The Workspace window shows all installed tanks and groups.
Tank Groups
Tank groups can be created to organize tanks by type, location, or by product. Tanks can
also be organized in Alarm groups in order to manage alarms.

Figure 2-9: Tank Groups

A. Active alarm group "Crude"
B. Alarm group "North Area"
C. Tank group "Crude Oil"
D. Tank Group "North"
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Data
Tank group data, such as level, temperature, inventory, and alarm logs can be monitored
and displayed in the main window.

Figure 2-10: Viewing Tank Group Data

Related information
Alarm groups
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2.4.2  Setting up the workspace
The WinOpi options allow you to specify how tank names, node names, and other objects
will be displayed in the Workspace window.
Procedure

1. From the Tools menu select Options.
2. Select the General tab.
3. Change the desired settings.

Example
Groups view Tank Names settings Show plant names and Show server names.

Example
Plants view Workspace Nodes settings Show plant nodes and Show server nodes.
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4. Click Apply to save the changes.
5. Click OK to close the Operator’s Interface Options window.
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2.4.3  Create a tank group
Tank groups can be a convenient way to get a better overview of, for example:
• tanks in a specific geographical area
• tanks containing a certain product
• tanks connected to the same host
A tank may appear in more than one group and a group may contain other groups. There
is no limit on the number of groups that can be created.
Procedure

1. In the Groups view, do one of the following:
• right-click on the Groups icon and select New Group
• select menu option Entry → New Group

2. Type a name for the new tank group and click OK.

3. In the left-hand pane, select a tank or a group to add to the new group and click the
Select button.

4. Repeat for all tanks to be added to this group.
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5. Click OK when you have finished adding objects to the new group. The new tank
group will be displayed in the Workspace window.

2.4.4  Icons
In the Workspace windows various items are represented by the following icons:
Table 2-1: Icons

 Cylindrical tank  Alarm group

 Floating roof tank  Active Alarm group

 Spherical tank  Plant node

 Horizontal tank  Server node

 Tank group Report
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2.5  User management
TankMaster offers a number of protection levels for increased security. These levels are
categorized as User Access Levels and User Access Sub Levels. The User Access Levels are:
• Administrator
• Supervisor
• Operator
• View Only
• ChiefAdmin
Each User Access Level has five sub levels, giving total of 20 unique access levels. The
default user names and passwords for each user type are as follows:
Table 2-2: User Access Levels and Sub Levels
User Level Sub Level Default Password
View VIEW ONLY * view
Operator OPERATOR * oper
Supervisor SUPERVISOR * super
Administrator ADMINISTRATOR * admin
ChiefAdmin ADMINISTRATOR ***** chief

User authentication (log on) is required in order to change settings such as:
• Alarm limits
• System Setup
• Tank Setup
Note
Settings cannot be changed by a user in View mode.
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2.5.1  Log on to TankMaster
Procedure

1. Select File → Log On, or click the Log On button  in the toolbar.
2. Type your user name and password. The password is case sensitive but the user

name is not.

3. Click OK.
Note
If log on is unsuccessful after five consecutive attempts, the user account is
disabled. The user account must be enabled by an Administrator.
The user type and the protection level is displayed in the status bar as well as any
status messages in case there are any.

Figure 2-11: Status Bar

A. User name
B. Protection level
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2.5.2  Manage user accounts
You must be logged on as Administrator in order to add new user accounts, change
settings for an existing user, or to configure user levels and sub levels.
Procedure

1. Log on to TankMaster as an Administrator.
2. Open Tools → Administrative Tools → User Manager.

3. In the User Manager window select a cell in an empty row and click New.

4. Enter a user name.
5. A description of the new user profile is optional.
6. Enter and confirm a password.
7. Next, select the desired Level and Sub Level and click OK.
8. Verify that the new user is displayed in the User Manager window.
9. To make a default user name appear in the Log On dialog, check the box Use first

account with required access level as default. If not selected, the User Name field is
empty when the Log On dialog opens.

10. Click the OK button.
Related information
User management
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2.5.3  Configure a sub level description
TankMaster allows you to change the names for Sub Levels to something more descriptive
than the default settings.
Procedure

1. Open Tools → Administrative Tools → User Manager.
2. In the User Manager window, click the Config Desc button.

3. In the Config Access Sub Levels Description window enter a new description in the
desired field. In the example above, the description of item number 5 of category
Admin Sub Levels is changed from “*****” to “Sub5-admin”.

4. Click OK to close the Config Access Sub Level Description window.
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2.5.4  Policies
The Policy Management function lets you setup various constraints for access levels and
user accounts.
Procedure

1. Open Tools → Administrative Tools → User Manager.
2. In the User Manager window, click the Policies button.

3. Select Enable Policies check box to activate the Policy Management function.
4. Select the desired mode to configure; Level Policies or User Policies.

5. In the Policies Settings drop-down list, select the desired access level or user
account.

6. Select the desired Associated constraints item and select the Enable check box.
Specify the constraint by entering a number in the Value input field.

7. Click the Set button.
8. Repeat for each constraint you would like to use.
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9. Once finished, click the Apply button.
10. Click the OK button to close the Policy Management window.

Policies settings
You can specify policy password constraints for protection levels such as Operator,
Supervisor, and Administrator by selecting mode Level Policies.
WinSetup also allows you to specify constraints for specific user accounts by selecting
mode User Policies.
You may use a combination of Level Policies and User Policies. For example, you may set
certain Level policy constraints for access level Operator, and then modify one or more
constraints for a certain user account.

Policies mode
Select the desired Mode and configure the Associated constraints.
Level Policies lets you change constraints for user access levels such as Operator,
Supervisor, and Administrator.
User Policies lets you change constraints for specific user accounts.

Associated constraints
The following password constraints can be set:
Table 2-3: Password Constraints
Constraint Description
Minimum password length Minimum characters required for the password
Password rotation period The number of days that the password will be valid
Password expire notifications Number of days before the password expires that a warning

message will be shown
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2.5.5  Set required access levels
TankMaster WinOpi offers the possibility to set unique required access levels for the
following actions:
• Group handling
• Alarm group handling
• Report handling
• Accepting alarms
• Exiting WinOpi
• Adding a program to the Tools menu
• Start program
For example, if you are logged on as an Operator (* * *), you are not allowed to exit WinOpi
if the required exit level for this action is set to Operator (****) or higher.
To modify required access levels:
Procedure

1. Open Tools → Administrative Tools → Set Required Access Levels.
Note
You must be logged on as an Administrator (* * * * *) to be able to set the required
access levels.

2. Set the required access level for each action and click OK.
Related information
Manage user accounts
Add an item to the Tools menu
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2.5.6  Change protection levels for specific windows
Prerequisites
To be able to change the Protection Level, the user must be logged on as an Administrator
(* * * * *).
To set a Protection Level for a specific window, for example, Alarm Limits:
Procedure

1. Select menu option Entry → Alarm Entry → Alarm Limits to open the Alarm Limits
window.

2. Click the window icon in the upper left corner of the Alarm Limits window.

3. Click on Protection Level in the menu.

4. Select the desired Protection Level and Sub Level from the menus.
5. Click OK.

Now the user must be logged in at the specified protection level, or a higher level, in
order to make any changes to the Alarm Limits window.
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2.5.7  Change password
Procedure

1. Go to Tools → Administrative Tools  → Set Password.

2. Select the Tank Server which is valid for your user account.
If you are already logged on to TankMaster, the current server is already selected
and your user name appears in the User name field.

3. If the workspace is in View Only mode, enter your User name.
4. Enter your old password and the new password.

Note
The password is case sensitive.

5. Confirm the new password and click OK.

2.5.8  Change inactivity timeout
You can set a timeout after which the current user is automatically logged off after a period
of inactivity.
The timeout period is reset each time the user performs an activity that requires an access
level check, for example, setting a new alarm limit or logging on. You must be logged on as
an Administrator in order to change the inactivity timeout.
Procedure

1. Go to Tools → Administrative Tools  → Set Inactivity Timeout.

2. Enter the number of minutes to use for the inactivity timeout.
3. Click OK.
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2.5.9  Program security options
TankMaster offers security options which can be used to restrict user privileges to run
certain Windows programs or perform specific actions.
Table 2-4: TankMaster Operator's Interface
Security option Description
Run application maximized The program will always run with the application window

maximized. The minimize and restore buttons in the upper-right
corner of the window are disabled.

Disable possibility to switch to
other programs

Ignores keyboard commands such as Alt+Tab, Alt+Esc, Ctrl+Esc,
etc.

Table 2-5: TankMaster Administrator and Windows Security
Security option Description
Run TankMaster Administrator
as Shell

Allows the TankMaster Administrator program to run as a
Windows shell instead of the standard Windows Explorer shell.
When this option is selected, all other security options in
the TankMaster Administrator and Windows Security group are
automatically set. You may need to restart your PC.

Disable Task Manager Prevents the user from starting Task Manager (Taskmgr.exe).
Disable Lock Workstation Prevents the user from locking the system (WIN+L). When

Windows is locked, the desktop is hidden and the system cannot
be used. Only the user who locked the system or the system
administrator can unlock it.

Disable Change Password Disables the Change Password button on the Windows Security
dialog box (Ctrl+Alt+Del).

Disable Registry Editor Disables the Windows registry editors, Regedt32.exe and
Regedit.exe. If this option is selected and the user attempts to
start a registry editor, a message appears explaining that a system
policy prevents the action.

Disable Windows Shutdown/
Restart

Prevents the user from shutting down or restarting Windows. This
option removes the Shut Down option from the Start menu and
disables the Shut Down button on the Windows Security dialog
(Ctrl+Alt+Del). It does not prevent the user from running programs
that may shut down Windows.

Disable Command Prompt Prevents the user from running the interactive command prompt,
Cmd.exe. This option also determines whether batch files (.cmd
and.bat) can be run on the computer.

Disable Autorun/Autoplay Disables the Autoplay feature on all drives.
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To set program security options
Procedure

1. Open Tools → Administrative Tools → Security Options.

2. Select the desired security options and click OK to apply.
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3  Viewing tank data

3.1  Measured values
Rosemount TankMaster™ offers a number of options to view measured and calculated
inventory data for individual tanks and tank groups. Windows can be created or modified
with standard and manual parameters to show customized views.

3.1.1  Viewing single tank data
This is a description of how to view measurement data for a single tank.
Procedure

1. Select a tank in the Workspace window.
2. Right-click and select the desired view, for example View Tank → Tank View

Extended, or from the View menu select Tank → Tank View Extended.

3. Optional: Select the Tank View option if you want to exclude information about
Current Input and Relay Output data.
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Example
The Tank View Extended window shows measurement data for a single tank. For each
item the value, measurement unit, and status is displayed. For Analog inputs (AIn), Current
inputs (CIn), Relay outputs, and Digital inputs a descriptor is shown which can be specified
when the system is configured in the WinSetup program.

Figure 3-1: Tank View Extended

A bar graph shows the product level as well as the amount of free water at the bottom
of the tank. Flow rates exceeding a certain threshold are indicated by an arrow on the left
side of the bar graph.
Depending on the actual flow rate value one of two arrow types appears. The thresholds
which control the arrow indication can be changed.
Temperature sensors immersed in a product are marked with a “*” symbol. The
temperature sensors can be connected to a Rosemount 2240S Multi-input Temperature
Transmitter or other supported devices.
Analog Input shows inputs to a Rosemount 2410 Tank Hub or a radar level gauge.
Current Input shows the current status of analog inputs to an Independent Data
Acquisition Unit (IDAU).
Relay Outputs shows the current status of a relay - open or closed.
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3.1.2  Viewing tank groups
Data for a group of tanks can be viewed in various windows. The windows can display
values for Level, Level Status, Level Rate, Average Temperature and other parameters for
all tanks in a group.
Procedure

1. Select a tank group in the Workspace window.
2. Do one of the following:

• Right-click and select View Group
• Open menu option View → Group

3. Select the desired View Group option:
• View Group
• Bar graph Group
• Tank Movement

Example
A tank which is currently being filled or emptied is indicated with arrows as illustrated
in Figure 3-2. There are two different arrow sizes. By setting appropriate thresholds, the
arrows can be used to indicate level rates within different ranges according to a predefined
threshold.

Figure 3-2: Group View

To specify level rate thresholds, open Tools  → Options and select the Tank Movement tab.
Tank movements can be highlighted with different colors for flow rates and level rates.
Related information
Tank movement
Editing group view templates
Modifying group views
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3.1.3  Viewing bar graph groups
Data for a tank group can be presented in bar graph format.
Procedure

1. Select a tank group in the Workspace window.
2. Do one of the following:

• Right-click and select View Group
• Open menu option View → Group

3. Select Bar Graph Group.
Example
In the Bar Graph Group window each tank in a group is represented by a bar graph
showing Product Level and Free Water Level for each tank. It also indicates level changes
by showing an arrow next to the bar graph.

Figure 3-3: Bar Graph Group

The Bar Graph Group window can be modified in the same way as the Group View window.
Related information
Tank movement
Editing group view templates
Modifying group views
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3.1.4  Editing group view templates
To change the appearance and contents of group views, do one of the following:
• open menu option Tools → Options and select the Group Templates tab,
• from an open group view window, select Edit Group Template from the shortcut menu

to access editing options.
Tank comment
A comment can be added to a tank and made visible for group views.
Sorting
Contents in a group view can be sorted by clicking a column title cell.
Related information
Modifying group views
Shortcut menu
Tank comment
Sorting content in a product table
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3.1.5  Shortcut menu
For quick access to other groups and tank views in any group view window, right-click on a
tank for a shortcut menu.
The shortcut menu gives you quick access to other windows. For example, the Observed
Inventory window may be opened by selecting View Group → Observed Inventory.

Figure 3-4: Shortcut Menu in Group View Window

Related information
Modifying group views
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3.2  Inventory data
Product and inventory data for a tank can be conveniently viewed in one window.

3.2.1  Tank inventory
Procedure

1. In the Workspace window, select the desired tank.
2. Do one of the following:

• right-click and select View Tank → Tank Inventory
• in View menu, select Tank → Tank Inventory.

3. Optional: In case you wish to view a window with secondary units, open View → 
Tank → Tank Inventory Secondary Units.
Secondary units can be displayed for Volume, Weight, and Density.

Related information
Inventory parameters
Tank comment
System setup
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Floating roof tanks
For floating roof tanks, the roof can be floating on the actual product in the tank, or
standing on its own supports. The supports can either be in operational or maintenance
position.
For each position there are three possible states:

1. The tank roof rests on its supports and receives no buoyancy from the liquid. This is
indicated with the following symbol: (*).

2. The tank roof receives support partly from the product and partly from its own
supports. This is indicated with the following symbol: (@).

3. The tank roof is floating freely on the product. No indicator is shown.
Example floating roof state

Figure 3-5: Roof Floating Freely

Related information
Floating roof correction setup
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3.2.2  Observed inventory
The Observed Inventory window shows observed inventory values for a tank group.
For each tank in the group the following default parameters are shown:
• Product
• Free Water Volume (FWV)
• Total Observed Volume (TOV)
• Gross Observed Volume (GOV)
• Available Room (AVRM)
To view observed inventory data for a group of tanks:
Procedure

1. In the Workspace window, select the desired tank group.
2. Do one of the following:

• right-click and select View Group → Observed Inventory
• in View menu, select Group → Observed Inventory.

• The Total field shows the sum values for FWV, TOV, GOV, and AVRM.
• Measurement units are shown for each parameter.
• If a group consists of tanks using different units of volume, then the

measurement unit of the first tank in the group is displayed. A unit conversion
is performed to provide the correct total value when the volumes are added
together.

Related information
Installing a tank measurement system
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3.2.3  Net inventory
The Net Inventory window shows standard net inventory values for a tank group.
For each tank in the group the following default parameters are shown:
• Product
• Reference Density
• Volume Correction Factor
• Gross Standard Volume
• Net Standard Volume
• Weight In Air
To view net inventory data for a group of tanks:
Procedure

1. In the Workspace window, select the desired tank group.
2. Do one of the following:

• right-click and select View Group → Net Inventory
• in View menu, select Group → Net Inventory.

• The Total field shows the sum values for GSV, NSV, and WIA.
• Measurement units are shown for each parameter.

Related information
Installing a tank measurement system
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3.3  Real time view
The Real Time View window lets you view tank parameter values for up to 4 tanks
simultaneously within a specific time interval.
Procedure

1. In the View menu, select Real time view.

2. Click the Setup button to specify tanks, parameters, and scaling.
3. Use the Scroll bar on the left-hand side to find the desired view.
4. Use the Zoom handle to find the desired zoom level.
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3.3.1  Setup
Use the Setup dialog to specify tanks and tank parameters to be displayed, and X-axis and
Y-axis scaling in the Real Time View window.

Figure 3-6: Real Time View Setup

A. X-axis settings
B. Y-axis settings
C. Channel settings
D. Sample Frequency
E. Block
F. Load / Save view

X-axis settings
• Enter a value for the period that data is to be shown for
• Enter a value for the update frequency. This parameter specifies the number of seconds

between each sample
Y-axis settings
• Enter appropriate values in the Max and Min fields.
• The scroll bar and the zoom slider can be used to zoom in for more details
• From the Block drop-menu choose which parameter to be monitored in realtime
Server
• Select the server which handles the tank data to be monitored
• You can see which tanks are connected to different servers in the workspace Plants

View

Channel settings
• Select a tank to be monitored
• Choose a color to be used for that tank in the resulting graph
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View
• Click the Save View As button to store the current settings
• All settings are stored except the X-Axis settings/Time value
• Click the Load View button to use previously saved settings

3.3.2  Save to file
The current real time view data can be saved as a file in plain text format.
Procedure

1. Open the Real Time View window.
2. Make sure the Open check box is not checked.
3. Click the Save to File button.

The file is stored in folder ...Rosemount\Tankmaster\Opi\Data folder.
The file name has the following syntax:
Viewname-yyyy-mm-dd hh.mm.ss.txt
• Viewname is specified by the user
• yyyy=year
• dd=day
• hh=hour
• mm=minute
• ss=second

3.3.3  Open a real time view file
To view the contents of the current session’s log file:
Procedure

1. Select the Open check box.
2. Select the Save to File button.
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3.4  Historical view
The Historical View shows a graph with historical tank data for a specified period.
Procedure

1. In the View menu, select Historical View.

2. Perform the desired configuration of X-axis settings and parameters to sample and
view.

3.4.1  X-axis settings
Specify X-min and X-max. These values define the period to be viewed in the graph and do
not affect the actual sampling.
For example, if the Level value has been sampled for the previous two days, you can view
the Level data for the last hour by setting X-min equal to one hour ago and X-max equal to
the current time.
To automatically set the X-max to the current time, click the Set maxtime to now check
box. X-max is updated each time you click the Refresh button.

3.4.2  Refresh
Click the Refresh button to update the display with the latest sampled data.
Select the Auto Refresh check box in case you would like to automatically refresh the
display every minute.
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3.4.3  Save to file
Sampled data can be saved to a text file. The file contains time and measured data. Only
tanks displayed in the Historical View window are saved and data for each tank is stored in
a separate log file.
The file is stored in the following folder: ...\Rosemount\TankMaster\Opi\Data.
Overwrite
If the Overwrite check box is selected, the previous file is replaced by a new one each time
the Save to File button is pressed.
If the Overwrite check box is not selected, then a new file with sampled data is created
each time the Save to File is pressed.

3.4.4  Open file
Sampled data which is stored in a file can be opened for viewing.
Procedure

1. Select the Open check box.
2. Select the Save to File button.

3.4.5  Print
Sampled data which is stored in a file can be printed.
Procedure

1. Select the Print check box.
2. Select the Save to File button.

The file is printed using the default printer for the workstation.

3.4.6  Sample setup
This window lets you specify parameters for sampling. Multiple parameters may be used
for each tank, and a unique set of parameters may be specified for each tank.
The Sample Setup window is used to specify which parameters are sampled for the various
tanks. Only parameters specified in the Sample Setup window can be displayed in the
Historical View window.
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Figure 3-7: Historical View Sample Setup

Table 3-1: Sample Setup Items
Item Description
Current Server Choose a TankMaster server. Refer to the Plants view in the Workspace to

see connections to servers.
Historical Data Log To reduce the amount of data in the Historical Data log, specify either a

maximum number of files to be stored, or a maximum number of days
to be logged. If Set size of logfile by no. days is selected, the minimum
sample interval is 60 seconds.
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Table 3-1: Sample Setup Items (continued)
Item Description
All Tanks The settings outlined below apply to all tanks.

• Sample settings
Sample start:
Sampling can be postponed for up to 24 hours. If sampling is
postponed, it still needs to be activated by pressing the Start All button
Sample Interval:
Choose the sampling rate. If data log option Set size of log file by no.
days is selected, the minimum sample interval is 60 seconds.

• Select Blocks for all Tanks button
Adds selected parameters (blocks) to all tanks. Only selected
parameters will be sampled, monitored and displayed.

• Remove Blocks from all Tanks button
Removes selected blocks from all tanks. These parameters will no
longer be sampled.

• Start All button
Start sampling for all tanks.

• Stop All button
Stop sampling for all tanks.

• Use individual intervals for each tank
Click this check box to set individual start times and intervals for
sampling of each tank.

Tank Setup The settings outlined below apply to individual tanks.
• Current Tank

Select a tank to configure for historical data sampling.
• Sample settings

Sample start:
Sampling can be postponed for up to 24 hours.
Sample Interval: Choose the sampling rate.

• Avilable/Selected Blocks button.
Displays which parameters (blocks) can be sampled. A unique set of
parameters can be sampled for each tank.

• Start Tank button
Starts the sampling for the selected tank. If sampling is postponed, it
still needs to be activated by pressing the Start Tank button.

• Stop Tank button
Stops sampling of the selected tank.

Select parameters for all tanks
The Sample Setup window allows you select parameters (blocks) which can be sampled
for all tanks. This a convenient way to add similar parameters to all tanks simultaneously
instead of repeating the operation for each tank individually.
Procedure

1. Click the Select Blocks for all Tanks button.
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2. In the Multiple block selection window, select the appropriate blocks.

Multiple blocks can be selected and deselected. Scroll to view all available blocks.

3. Click OK.
Selected blocks can be viewed in the Selected blocks pane.

Remove blocks from all tanks
Procedure

1. Click the Remove Blocks from all Tanks button.
2. In the Multiple block selection window, select the parameters to be removed from

the list.
3. Click OK.

Deselected blocks are no longer visible in the Selected blocks pane.

Select parameters for the current tank
Procedure

1. In the Available Blocks pane, select the parameters to be included in the sampling
for the selected tank. Multiple blocks can be selected.

2. Click the Add  button to add the selected parameters, or click the Add All 
button to add all parameters. The blocks appear in the Selected blocks pane.

3. Repeat this procedure for all parameters to be sampled for the tank.
4. Click Close.

Start and stop data sampling
To start or stop data sampling for all tanks, click the Start All button, or the Stop All button,
respectively.
To start or stop data sampling for the current tank, click the Start Tank button, or the Stop
Tank button, respectively.
Note
If sampling is postponed, it must be activated by pressing the Start All, or Start Tank
button. It will not start automatically at the given Sample Start time.
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3.4.7  View setup
This window lets you specify how tank parameters are displayed in the Historical View
window.

Figure 3-8: View Setup

Y-axis settings
The Y-axis scaling must be wide enough to allow entire span of measured data to be
included in the display. The slider in the Historical View window allows you to scroll when
the graph is zoomed in.

Block
Choose the parameter to be displayed in the Historical View window.
Note
Only parameters already included in the Selected Blocks pane in the Sample Setup window
can be selected.

Online and offline source
Online source
Select the server for the tanks which are to be monitored. See the Plants view in the
Workspace for server details.
Offline source
Select an Offline source to view a previously saved data file in the
Historical View window. Historical View data files are stored by default in the
folder: ...\Rosemount\TankMaster\Opi\Data, with the file extension *.dbf.
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Graph settings
The Historical View window can be configured to show a single parameter for many tanks,
or to show various items for one tank.
• Choose a tank that is to be monitored and select a corresponding color that will be

displayed in the graph.
• Choose the type of field that will be displayed in the Historical View window, such as the

Current Value or an alarm limit (Hi Limit, Lo Limit).
• It is possible to show both a level value and a corresponding alarm limit as two separate

graphs in the Historical View window.
Procedure

1. Select a tank from the Tank column.
2. Select the desired Color.
3. Select the desired display option, for example Value or Hi Limit (alarm) from the

Field column.
4. Repeat for the next rows until the desired tanks and parameters are configured for

display in the Historical View window.
5. Click OK to display the current tanks and parameters in the Historical View window.

Note
Sampling must be activated for the selected tank in the Sample Setup window in
order to display results in the Historical View window.

Load and save views
The Save View button allows you to store the current settings. These settings can be
restored by pressing the Load View button.
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3.5  Historical table view
The Historical Table window lets you sample and view historical tank data in table format.
Procedure

1. In the View menu, select Historical Table.

2. Perform the desired configuration for time settings and parameters to sample and
view.

Related information
Table setup
Sample setup

3.5.1  Start stop time
Table time settings indicate the start and stop times for the period that is displayed in the
Historical Table. These settings do not affect the actual sampling.
The Set Stop time to now check box allows you to set stop time to the current time. The
stop time will be updated to the current time each time the Refresh button is selected.

3.5.2  Refresh
Click the Refresh button to update the display with the latest sampled data.
Select the Auto Refresh check box in case you would like to automatically refresh the
display every minute.
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3.5.3  Table setup
In the Historical Table window, click the Table Setup button to configure tank parameters
and tanks to be displayed.

Figure 3-9: Historical Table Setup

A. Online source
B. Offline source
C. Resolution
D. Data in Table

Online and Offline source
Online
Select the server and tank to be monitored in the Historical Table window.
Offline
The Offline Source is a previously saved Historical Table data file, stored in the
folder: ...\Rosemount\Tankmaster\ Opi\Data with file extension *.dbf.

Resolution
Set the time interval between data sampling points. Enter a number and select a unit.
Select the Use Sample Interval check box in case you would like to use the sample interval
defined in the Sample Setup window.
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Data block selection
Select the parameters to be displayed in the Historical Table window.
Procedure

1. Click the Select Blocks button.

2. Select the desired parameters in the Multiple block selection window.
3. Scroll up or down to see all blocks.
4. Click OK.

Note
For data to show up in the Historical Table window, the Sample Setup window must
be properly setup. This means that items must be included in the list of sampled
parameters in the Selected Blocks pane in the Sample Setup window.

Load and save view
The Save Setup button allows you to store the current settings. These settings can be
restored by pressing the Load Setup button.
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3.6  Tank movement
The Tank Movement window shows the direction of the current product surface
movement, including Level Rate and Flow Rate.
Procedure

1. In the Workspace window, select the desired tank.
2. Do one of the following:

• right-click a tank group and select View Group → Tank Movement
• in View menu, select Group → Tank Movement.

3.6.1  Movement indication
An arrow points in the direction of surface movement. A thick arrow indicates a high
flow rate, or level rate. A thin arrow indicates a low flow rate, or level rate. There is no
movement indication for level rates below set thresholds.

3.6.2  Limits
A limit can be set in order to exclude tanks with flow rates below a specified value. Tanks
are automatically added to and removed from the Tank Movement window depending on
flow rates.
Related information
Flow rate thresholds

3.6.3  Color highlighting
Tank movements can be highlighted using color coding to improve visibility.
Related information
Enable color highlight
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3.6.4  Custom appearance
The contents of the Tank Movement window can be modified to show specific parameters.
Procedure

1. Open the Tools menu.
2. Select Options.
3. Select the Group Template tab.

Related information
Modifying group views

3.6.5  Level rate thresholds
There are two thresholds for Level Rate, Major and Minor.
Minor Level rates above this value are indicated with a thin arrow in the Tank Movement

window.
Major Level rates above this value are indicated with a thick arrow in the Tank Movement

window.

Note
The Level Rate threshold settings apply to all windows which indicate product surface
movement, such as View Group, and Tank View.

Procedure
1. Go to Tools → Options.
2. Select the Tank Movement tab.
3. Enter values for the major and minor Level Rate Thresholds.

4. Click Apply to activate the new threshold values.
5. Click OK to close the Options window

3.6.6  Flow rate thresholds
Flow Rate Thresholds can be set individually for specific tanks, or as a common threshold
for all tanks.
Minor Flow rates above this value are indicated with a thin arrow in the Tank Movement

window.
Major Flow rates above this value are indicated with a thick arrow in the Tank Movement

window.

Note
The Flow Rate threshold settings apply to all windows which indicate product surface
movement, such as View Group, and Tank View.
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Individual flow rate thresholds
Procedure

1. Go to Tools → Options.
2. Select the Tank Movement tab.
3. Select Use individual threshold for each tank.

4. Click Apply, and OK to close the Options window.
5. Right-click on a tank in the Workspace that will use individual thresholds and select

Tank Setup → Tank Settling Calculation.

6. Enter the required values in the Open Gauge and Close Gauge input fields.
7. Press Apply and OK to close the Tank Settling Setup window.
8. Repeat this procedure for each tank that will use individual thresholds.

Common flow rate thresholds
Procedure

1. Go to Tools → Options.
2. Select the Tank Movement tab.
3. Select Use common threshold for each tank.

4. Enter the desired threshold values.
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Note
Tanks with Flow Rates below the Minor threshold value will not appear in the Tank
Movement window.

5. Click Apply, and OK to close the Options window.

3.6.7  Enable color highlight
Color coding and highlighting for tank movement can be edited.
Procedure

1. In the Tools menu, select Options.
2. Select the Group Templates tab.
3. Select the Tank Movement group template and click the Edit button.

4. Select the Highlight tanks in movement check box.

5. Click OK.
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Related information
Color settings for tank movement
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3.7  Modifying group views
The appearance of a group view can be changed by editing the appropriate template.
Procedure

1. In the Tools menu, click Options.
2. Select the Group Templates tab.

3. Select one of the following options:
• To modify an existing group template, select the view and click Edit.
• To duplicate an existing template, click the Clone button. This is a convenient

way to create a new template by simply modifying an existing one.
• To create a new group template, click the New button.
• To remove an existing template, click the Delete button.

3.7.1  Example of how to create new group views
This example illustrates how to create a new group template.
Procedure

1. Select menu option Tools → Options.

Reference Manual Viewing tank data
00809-0200-5110 March 2024

Rosemount TankMaster 65



2. Select the Group Templates tab and click the New button.

The Edit Group Template window appears which lets you specify a new group view:

3. In the Menu Item field, enter a group name as it will appear in the View → Group
menu.

4. In the View Title field, type the name that will be displayed in the title bar of the new
group view.

5. Next, select parameters in Available Parameters pane and click the Select button.
The parameters are added to the Selected Parameters pane.
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6. In the Show As column, for each parameter choose the desired format for data
presentation.
The Show As format determines how the parameter is presented in the view
window.

Selected Parameters Show As Description
MI Spot temperature in liquid
CV Current Value
VU Value Unit
AS Alarm Status

7. The parameters can also be sorted in the table view as ascending or descending
from the Sort Order column.

8. Finally, in the View Type list, select if tanks will be presented row by row, column by
column, or in both rows and columns.

9. Click the OK button.
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10. To open the new group view, do one of the following:
• Right-click a tank group and select View Group  → [Menu Item]
• Select a tank group and in the main menu, go to View → Group → [Menu Item]
In this example, [Menu Item] is View Temp Sensors.

Note
The Highlight tanks in movement option is not enabled in this example.

Related information
Enable color highlight
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3.7.2  Changing group view appearance
Font and text alignment can be modified for cells and headers in windows where data is
presented in tables.
Procedure

1. Select menu option Tools → Options and select the Group Templates tab.

2. Under Common Group View Settings, click the Change button.
The Group View Appearance window opens:

3. Select the appropriate Change font button to select desired fonts for table headers
and cells.

4. Select desired alignment.
A preview of the formatting changes is shown in the Example box.
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5. Click OK to close the Group Views Appearance window
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3.8  Color settings
Using colors can be a useful way highlight and distinguish information. Colors can be
specified for many areas, including bar graphs, backgrounds in input fields, manually
entered values, alarms, and products in the Product Table.
Procedure

1. Open the Tools menu.
2. Select Options.
3. Select the Colors tab.

4. Select an item from the list.
5. Click the Change button to open the Color palette:
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6. Choose a color from the palette, or click the Define Custom Colors button to expand
the Color window. This allows you to add a custom color:

7. Click OK when the color selection is done.
Related information
Product color
Create a product table
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3.8.1  Product color settings
In the Product Table, colors can be used to represent specific products. These colors are
then used in bar graphs to show the current product level.
There are two different options for product colors in bar graphs:
• Option 1: the same color is used for all products.
• Option 2: Each product is associated with a color according to the Product Table setup.
Procedure

1. In the Tools menu, select Options.
2. Select the Colors tab.
3. Under Items, select Bar Graph Product, and select the Use Product Color check box.

4. Scroll down the Items list and select a product to edit (Product1 in this example).
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5. Click the Change button to define a product color.

6. Select the desired color and click the OK button. Now the new product color
appears.

7. Repeat this procedure for the desired products.
8. In the Tools Options Colors window, click the OK button when you are finished.

Related information
Product color
Create a product table
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3.8.2  Color settings for tank movement
Items Major Moving Up, Major Moving Down, Minor Moving Up, and Minor Moving Down
can be modified to change the colors for highlighting tank movement.
Procedure

1. Open menu option Tools → Options and select the Color tab.
2. Select one of the following items:

• Major Moving Up
• Major Moving Down
• Minor Moving Up
• Minor Moving Down

3. Click Change to edit the color settings for the selected item.
4. Click Apply and then OK to close the Options window.

Postrequisites
Ensure that color highlighting for tank movement is enabled.
Related information
Enable color highlight
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3.9  Tank comment
A custom comment field can be added to Tank View and Group View windows for each
tank.

3.9.1  Add a tank comment
Procedure

1. Do one of the following:
• right-click a tank in the TankMaster workspace and select Tank Comment

• select a tank in the TankMaster workspace, and open Tank Comment from the
Entry menu

2. Type a comment for the selected tank and click OK.
The Tank Comment can be seen in any tank view window (except Tank Set-Point
View).
Example
Tank Inventory window with tank comment.

Note
Tank comments can also be used for group view windows.
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3.9.2  Enable tank comment in group view
Procedure

1. Select menu option Tools → Options.
2. Select the Groups Templates tab, and choose the desired group view.
3. Click the Edit button.

The Edit Group Template window opens.
4. In the Available Parameters list, choose Comment and click the Select > button.

5. Click OK to close the Edit Group Template window.
6. Click Apply and OK to close the Operator’s Interface Options window.

The comment field is now visible in any group view window.
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4  Installing a tank measurement
system

4.1  Installation procedure
Setting up a tank measurement system for level measurement and inventory calculation
includes a few basic steps.
Procedure

1. System setup.
Specify measurement units and other system parameters.

2. Set up a Tank Capacity Table.
Specify the geometry of the tank for volume calculation by setting up a tank capacity
table. This is commonly referred to as a strapping table.

3. Create a product table.
Specify the products to be used in the tank.

4. Configure tank inventory parameters.
Specify parameters for inventory calculation.

5. Configure alarm limits.
Specify alarm limits for level, volume, and data from external sensors.

Related information
System setup
Setting up a tank capacity table
Create a product table
Inventory parameters
Tank inventory configuration
Alarm handling
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4.2  System setup
Measurement units and other system parameters for tanks can be set up manually.
Procedure

1. In the TankMaster workspace, select menu option Setup → System:

2. Select the server that the system setup changes will apply for.
3. The following system settings are available:
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Table 4-1: System Setup Options
Option Description
System units Select the default measurement units to be used for data

presentation.
Note
Changing system units will not affect previously installed
tanks. It will only affect tanks installed after the changes have
been made.

Secondary units The Volume Table drop-down list lets you choose an API
table for inventory calculations.
Select measurement units to be used for data presentation in
these windows:
• Tank Inventory Secondary Units

(View → Tank → Tank Inventory Secondary Units)
• Tank Inventory Calculator

(Tools → Tank Inventory Calculator)

Volume Correction Factor
(VCF) calculation mode

• The Volume Correction Factor (VCF) is rounded to five
decimals by default.

• It is possible to configure TankMaster to round the VCF to
four decimals places. This can be useful if the calculated
VCF result will be verified against printed tables with only
four decimals.

Local gravity calculation • The local gravity calculation is used to calculate the
Observed Density for hybrid tank measuring systems.

• The local gravity constant is calculated when the check
box is not selected.

Ambient air density
calculation

There are two options for the Ambient Air Density calculation.
The Ambient Air Density can either be considered as:

a. constant, or
b. calculated, based on a manually defined base density

and ambient air temperature.
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Table 4-1: System Setup Options (continued)
Option Description
TCT Specify the default type of Tank Capacity Table (TCT) from the

TCT Type list:
• When a TCT table is created for a new tank, the type is

based on the default setting in the System Setup window
• The TCT type can be changed in the Tank Capacity Setup

window.

Products Enter the maximum number of products to be used in the
Product Table (the system limit is 500).
Note
The same maximum number of products should be used for
all servers in the network.

Reference temperature (RT) TankMaster performs inventory calculations according to the
API Manual of Petroleum Measurement Standards Chapter
12, Section 1, at the standard reference temperature 15°C
(60°F). This is the default reference temperature.
Other reference temperatures can be specified in the
Reference Temperature input field. The correct RT volume
table, for example RT 54B-2004, shall be used for a specific
product.

Related information
Setting up a tank capacity table

4.2.1  Ambient air temperature manual setup
This is a description of how to manually specify the Ambient Air Temperature.
Procedure

1. In the TankMaster workspace, select menu option Entry → System.

2. In the System Entry window, select the server that the Ambient Air Temperature will
apply for.

3. Select the Ambient Air Temperature check box and enter a value.
4. Click OK.

4.2.2  Automatic ambient air temperature measurement
This is a description of how to setup automatic Ambient Air Temperature measurement.
For automatic Ambient Air Temperature measurement, a sensor can be specified in the
WinSetup Server Preferences window.
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Procedure
1. Make sure that TankMaster WinSetup is up and running.
2. In the WinSetup workspace, select the server that the device and temperature

sensors are connected to.
3. Do one of the following:

• right-click on the server icon and select Setup
• select menu option Server → Setup

4. In the Server Preferences window, select the Ambient Air Temperature tab.

5. In the Ambient Air Temperature tab, under Ambient Air Temp Source, select the
Auto option.

6. Configure the following:
• Select the device to which the temperature sensor is connected
• Select the temperature source
• Choose the sensor to be used specifically for Ambient Air Temperature

7. Press the OK button to close the Server Preferences window.
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4.3  Setting up a tank capacity table
The geometry of a tank is defined in a strapping table called a Tank Capacity Table (TCT). It
is used to convert a product level to the corresponding volume. The values can be entered
either as absolute levels, as relative levels, or as pairs of level and volume.
There are three different types of tank capacity tables:
• Raw
• Northern (relative levels; mostly used in Sweden and Finland)
• International (absolute levels)
You can specify a default TCT type that will automatically be used for new tanks in Setup → 
System.
You can change the TCT type for a tank from the default setting in Setup → Tank Setup → 
Tank Capacity.
Note
When specifying a TCT using either the Northern or International method, it is extremely
important that the resulting level-volume curve is continuous. The calculated volume at
the top of one interval must correspond exactly to the volume at the bottom of the next
interval.
Both the relative and the absolute method of entering TCT data require four parameters
at each strapping point. The Northern and the International methods do not use the same
Base Volume and Tank Area Coefficient.
Table 4-2: Strapping Table Parameters
Parameter Description
From product level at the beginning of the interval
To product level at the end of the interval
Volume Base Volume
Area Tank Area Coefficient
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Figure 4-1: Volume Calculations Based on Strapping Table

A

B
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D

E

A. Level at end of interval
B. Measured level
C. Level at beginning of interval
D. Calculated volume
E. Base volume

4.3.1  Using the Raw method
When using the Raw method, data is entered in pairs of Level and Volume values. For each
level value the corresponding standard volume must be entered.
The following table shows an example of pairs of Level and Volume values as input for
TankMaster when using TCT type Raw.
Table 4-3: Example of TCT Type Raw Table
Level Volume
1.53 10 105
2.72 22 309
3.18 29 934
4.78 41 249
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4.3.2  Using the International method
When using the International method, the Base Volume is the volume at the beginning
of the interval. The Tank Area Coefficient describes how the volume varies with the level
within the interval.

Figure 4-2: International Method

Level

Volume

Vo

Lo
B

A

C

A. Volume at end of interval
B. Level at beginning of interval (From)
C. Level at end of interval (To)

With the International Method, the desired volume is calculated as:
Desired Volume = Vo + Area × (Level - Lo)
Table 4-4: International Method Parameters
Parameter Description
Desired Volume Volume at the measured level
Level Measured level
Lo Level at the beginning of the interval
Vo Base volume
Area Tank Area Coefficient. This is not the surface area of the product,

although the measurement unit of this parameter is the same as
for a surface area (volume/length).
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4.3.3  Using the Northern method
The Northern method is based on the fact that within an interval, there is an approximately
linear relationship between level and volume, as illustrated below.

Figure 4-3: Northern Method

Level

Volume
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A. Volume at beginning of interval
B. Level at beginning of interval (From)
C. Volume at end of interval
D. Level at end of interval (To)

The Base Volume corresponds to the volume at Level = 0, given by extrapolation of the
linear level - volume relationship.
The Tank Area Coefficient describes how the volume varies with the level within the
interval based on this Base Volume. The volume is calculated as:
Desired Volume = Vo + Area × Level
Table 4-5: Northern Method Parameters
Parameter Description
Desired Volume Volume at the measured level
Level Measured level
Vo Base volume
Area Tank Area Coefficient. This is not the surface area of the product,

although the measurement unit of this parameter is the same as
for a surface area (volume/length).

4.3.4  Create a tank capacity table
TankMaster allows you to specify a strapping table to be used for volume calculations.
• The geometry of the tank is defined in the TCT
• The TCT is used to convert a product level to the corresponding volume
• The values can be entered either as pairs of level and volume, either as absolute, or

relative levels depending on the type of TCT that is used
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• The TCT is stored as pairs of level and volume irrespective of the way the values are
entered into the system

Procedure
1. In the TankMaster workspace, right-click on the desired tank and select Tank Setup 

→ Tank Capacity, or open menu option Setup → Tank Setup → Tank Capacity.

2. To change the TCT type for the current tank, or to specify the number of strapping
points, click the Change button.

3. Click OK to close the TCT Table window and apply any changes.
Note
Changing the TCT or number of points in the TCT Table window only affects the
current tank. The default TCT type is specified in the System Setup window (Setup 
→ System) and is automatically chosen when strapping tables are created for new
tanks.

4. In the Units pane, select measurement units for Level, Volume and Temperature.
These units are also specified in the System Setup window as default for all tanks,
but can be changed here for the current tank.

5. In the Volume section, enter a Maximum Volume and a Minimum Volume for the
current tank. The Minimum Volume is equal to the volume between the outlet and
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the bottom of the tank. Tank Volume refers to the total volume of the tank. This
parameter is used for LPG tanks in order to calculate Equivalent Liquid Volume and
Vapor Mass.

6. The Sump Volume is what is left when the tank is emptied to the Zero Level. This
value may be included in the strapping table instead of the Sump Volume field. In
this case, the Base Volume at the Zero Level is equal to the Sump Volume.
Note
Ensure that the Sump Volume is not specified in both the Sump Volume parameter
and the strapping table.

A

B

C

A. Zero Level
B. Sump
C. Minimum volume

7. In the Shell pane, specify if the tank is insulated or not, enter the Base Temperature
and a Steel Expansion Coefficient:
• The Base Temperature is the temperature at which the strapping table is

specified
• Temperatures other than the Base Temperature are taken into account and

compensated for when performing volume calculations.
• If a tank is insulated the ambient temperature does not have any influence on

the inventory calculations.
• The Steel Expansion Coefficient is used in the calculations of Gross Observed

Volume (GOV) in order to correct for the thermal expansion of the tank wall. The
default value, 0.0000112/°C, is used for mild carbon steel.

8. Enter numerical values for the strapping table points.
9. Click OK to store the values and close the window.

Related information
Inventory parameters
Floating roof correction setup
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4.4  Create a product table
Product specific information is stored in a Product Table. It is possible to edit the default
selection of products and also add new products to the table.
Procedure

1. Select menu option Setup → Product Table.

2. Select a Product Table source, i.e. a server where the product table is stored.
3. The content in the product table can be sorted.
4. To edit an item In the Product Table, double-click a cell, or select a cell and click the

Edit Product button. The Edit Product No <x> window appears.
Example

5. Enter the appropriate product data in the Edit Product window.
6. Repeat the appropriate steps to add new, or edit existing products in the Product

Table.
7. If you want to save changes to all servers, select the check box Save to all servers in

the Product Table window.
8. Click OK.

Installing a tank measurement system Reference Manual
March 2024 00809-0200-5110

90 Emerson.com/Rosemount



Note
Select the Save to all servers check box if you like to save changes to the Product
Table to all connected servers. If the check box is not selected, the Product Table is
only saved to the server in the Product Table source field. If stored to all servers, the
Max no of products in the Product section of System Setup must be the same for all
servers. By selecting Save to all servers the existing data will be overwritten.

Related information
Product color settings
Color settings
Sorting content in a product table
System setup

4.4.1  Volume table
The Volume Table list lets you choose the API Table to be used for calculating the VCF.
By choosing one of the RT tables you can use a reference temperature value other than
the standard 15°C / 60°F. Reference temperature is specified in the System Setup window
(Setup → System).

CHEM
When using volume table CHEM, the Observed Density is calculated by using the Reference
Density from the Product Table.
Linear and Custom
For Volume Tables Linear and Custom.
Alcohol
Volume table ALCOHOL is valid for strengths between 50 and 100%, and a temperature
range from 10 to 40 °C (50 to 104 °F).
User 1-10
Volume Tables USER1-10 are for users who want to order custom made volume tables from
Rosemount Tank Radar AB.
Related information
Extended volume correction table setup

4.4.2  Chemical data
The Chemical Data section is only valid for the CHEM volume table, otherwise it cannot be
edited for other products.

Reference Density
The Reference Density (Ref Density) is the density of the product at a specific temperature
given by the Ref Temp value.
Reference Density in the Product Table is used to calculate the Observed Density for
volume table CHEM. For other volume tables the Reference Density is automatically
calculated or is manually entered in the Tank Entry window.
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Density change
The Density Change value specifies the rate at which the density changes per 1°C.
Corresponding density and temperature units must be selected.
Related information
Tank volume calculation setup
Product parameter setup

4.4.3  LPG data
For LPG/LNG tanks, manual values can be entered for Molecular Mass and Vapor Liquid
Ratio. These values are used to calculate the mass of gas and the liquid equivalent volume
of the vapor in the available room above the liquid surface.

4.4.4  Settling data
The Settling Factor states the level change in hours per meter. When the product level
movement has dropped below the Settling Factor, and a period of time exceeding the Max
Time has passed, the tank is considered settled.

4.4.5  HTG tank data
The Solidification Temperature is only used in Hydrostatic Tank Gauging (HTG) calculations.

4.4.6  Product color
Enter a number that corresponds to a product color. This requires that a set of product
colors has already been defined.
Related information
Product color settings
Color settings

4.4.7  Sorting content in a product table
The Product Table can be sorted for a clear overview.
Procedure

1. To sort the table rows in ascending order for a field, click the title cell for that
column.
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2. Click the cell again to sort the cells in descending order.

3. Right click on the selected column title to reset sorting.
4. Repeat this procedure until the table is sorted appropriately for your needs.
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4.5  Inventory parameters
Rosemount TankMaster ™calculates inventory parameters based on input data available for
the current tank.
The following figure illustrates how TankMaster converts a measured product level with
given tank parameters to a standardized volume:

Figure 4-4: Standard Volumes
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The following figure outlines the relationship between tank parameters and physical
quantities. The main parameters are shown on the left-hand side, and input parameters
on the right-hand side of the flow chart:

Figure 4-5: Tank Parameters Flow Chart

Table 4-6: Inventory Parameters
Parameter Description
Total Observed Volume, TOV Calculated from strapping tables. It is the total volume at

the observed temperature of the product.
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Table 4-6: Inventory Parameters (continued)
Parameter Description
Gross Observed Volume, GOV Obtained by subtracting the Free Water Volume, FWV,

from the total observed volume, TOV. The Free Water
Volume is calculated from the Free Water Level entered by
the operator or measured automatically by using a water
interface sensor.

Gross Standard Volume, GSV The GOV corrected to the reference temperature 15° C/60°
F. The correction is made using the VCF, according to API
Standard 2540.

Net Standard Volume, NSV Calculated as the GSV minus the dissolved sediment and
water. For liquid gas tanks the liquid equivalent volume of
the gas above the product surface is added.

Weight in Vacuum, WIV NSV multiplied by the Reference Density.
Weight Conversion Factor, WCF Calculated from the Reference Density.
Weight in Air, WIA NSV multiplied by the WCF.
Maximum Volume The volume that corresponds to the maximum product

level.
Available Room, AVRM Calculated by substracting the TOV from the Maximum

Volume of the tank.
Floating Roof Adjustment, FRA Floating roof volume adjustment.
Sump volume The volume that is left in a tank when emptied down to the

Zero level.
CTSh Used for correction of GOV to compensate for thermal

expansion of the tank wall.
Minimum Volume Volume between the outlet and the bottom of the tank.
Pumpable Volume TOV minus the Minimum Volume.
Flow Rate The Flow Rate is calculated using the level rate and the

strapping tables.
Reference Density The Reference Density can be automatically calculated from

the Observed Density and the Average Temperature. Use
automatic measurements in Hybrid Tank Gauging systems
with a pressure sensor connected.

Thermal Expansion Coefficient, TEC
Liquid

Used to calculate the VCF when using one of the
6C/24C/54C/60C or the RT_6C/54C volume correction tables.

Volume Correction Factor, VCF Used to convert the volume at the current temperature
to the corresponding volume at the standard reference
temperature 15 °C (60 °F). The VCF is automatically
calculated according to API standard 2540 if the Reference
Density and the Average Temperature of the product are
known. For some volume correction tables the Thermal
Expansion Coefficient (TEC Liquid) must also be entered
(see TEC Liquid).

Vapor Pressure The current vapor pressure is displayed if a pressure sensor
is available. A pressure value can also be entered manually.
The Vapor Pressure source signal, i.e. the analog input
to which the sensor is connected, can be specified in
WinSetup. Select a tank in the workspace and go to Tanks 
→ Properties → Configuration.
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Table 4-6: Inventory Parameters (continued)
Parameter Description
Liquid Pressure The current liquid pressure is displayed if a pressure sensor

is available. A pressure value can also be entered manually.
The Liquid Pressure source signal, i.e. the analog input
to which the sensor is connected, can be specified in
WinSetup. Select a tank in the workspace and go to Tanks 
→ Properties → Configuration.

Vapor Density The Vapor Density parameter is used in the calculation of
the Observed Density. Enter the Vapor Density manually in
the Tank Volume Calculation Setup window.If Vapor Density
should not affect the Observed Density calculations, set the
Vapor Density value as equal to the Ambient Air Density
(Setup → System).

S&W The percentage of sediment and water in the product.
Free Water Level, (FWL) Manually entered or measured by a water interface sensor.
Free Water Volume, (FWV) Calculated on the basis of the FWL and the TCT.
Pipeline Estimated volume in the pipeline connected to the tank.
Pumpable Weight, (PW) Calculated as Pumpable Volume (PV) multiplied by the

observed density.
Available Weight Room, (AWRM) Available Volume Room (AVRM) multiplied by the observed

density.
Relative Observed Volume, (ROV) Equal to [TOV/Max Volume] * 100

Related information
Product parameter setup
Tank inventory configuration

4.5.1  Hybrid tank measuring system
Table 4-7: Inventory parameters for liquid gas tanks
Parameter Description
Air Density Ambient air density.

Default value 1.21kg/m3.
Vapor Density Vapor density in tank.

Default value 1.21kg/m3.
Vapor Pressure, Press Vapor Vapor pressure above ambient air pressure (gauge

pressure).
If not available set P3 = 0.

Liquid Pressure, Press Liq Liquid pressure above ambient air pressure (gauge
pressure).

Press Sensor Levels Distance between pressure sensor P1 and P3 (Ht). Distance
from datum plate to mid of membrane of pressure sensor
P1(Z).

Min Level The lowest level when density calculation shall be
performed.

Level Liquid Level.
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Table 4-7: Inventory parameters for liquid gas tanks (continued)
Parameter Description
Local Grav Local gravity constant.

4.5.2  Observed density
If a pressure transducer is installed in a tank, the density of the product can be calculated.
This value is presented as the Observed Density.
In order to calculate the Observed Density, the correct local gravity constant must be given
in WinOpi.
The Observed Density can also be calculated based on a manual value for Reference
Density.
Related information
System setup

4.5.3  Reference density
The Reference Density is the density of a product at the standard reference temperature
15°C (60°F). This value can either be entered manually, or calculated automatically from
the Average Temperature and the Observed Density, if available. Reference Density is
calculated using a VCF according to API Tables 5A, 5B, 53A or 53B.
Weight calculations are performed using the calculated volumes and either a manually
entered value for density or the observed density. The WIA, is calculated as the NSV
multiplied by the WCF.
For floating roof tanks the volume calculations take into account if the roof is fully floating,
or if it is partly resting on its supports and partly receiving some buoyancy from the
product.
A Leak Alarm is available for changes to the NSV.
Related information
Alarm handling
Leak alarms
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4.5.4  Liquid gas tanks
For liquid gas tanks, the Molecular Mass, (MolMass), and the Vapour-Liquid-Volume Ratios
(VLVR), can be entered into the product table.
For tanks containing liquid gas a number of parameters are relevant. The mass of gas (Vap
Mass) in the Available Room is calculated and the corresponding liquid equivalent volume
is presented as Liq Equ in the Tank Inventory window.

Figure 4-6: Liquid Gas Tank Inventory Parameters
A

B

C

A. Maximum volume
B. AVRM - Available Room
C. TOV - Total Observed Volume

Table 4-8: Inventory parameters for liquid gas tanks
Parameter Description
MolMass Molecular mass
Vapor-Liquid-Volume Ratios, VLVR Volume ratio between vapor and liquid in the tank
Press Vapor Vapor Pressure (gauge pressure)
Temp Vapor Vapor temperature
Available Room, AVRM Calculated by substracting the TOV from the Maximum

Volume of the tank
Vapor Mass, Vap Mass Mass of the gas in the Available Room (AVRM)
Equivalent Liquid Volume, Liq Equ The corresponding liquid volume of Vap Mass and is added

to the NSV

Related information
Create a product table
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4.6  Tank inventory configuration
The following steps are included in the Tank Inventory configuration:
• Tank Volume Calculation Setup
• Product Parameter Setup
During operation, e.g. changing product in a tank, the setup is performed in the Tank
Volume Calculation Setup and Tank Entry windows assuming that the product has been
properly defined in the Product Table.

4.6.1  Tank volume calculation setup
Procedure

1. Right-click on a tank in the WinOpi workspace and select Tank Setup → Tank Volume
Calculation, or select a tank and select menu option Setup → Tank Setup → Tank
Volume Calculation.

2. Configure the appropriate parameters that apply on the current tank.

Volume correction table setup
In the Volume Table drop-down list, select the API Table to be used for VCF calculations.
RT tables allow you to use reference temperatures other than the standard 15 °C/60 °F.
You can specify reference temperature in the System Setup window (Setup → System).
It is recommended to use the volume table that is defined in the Product Table.
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For volume table CHEM, TankMaster WinOpi calculates the Observed Density by using the
Reference Density from the Product Table.
Related information
Create a product table

Product setup
The Product Setup list contains products specified in the Product Table
For product table CHEM WinOpi uses data from the Product Table for inventory data
calculations.
For LPG and Horizontal LPG tanks, the Product Table provides data to calculate vapor mass
and liquid equivalent volume of vapor above the product surface. These values can be seen
in the Vapor section in the Tank Inventory window, see menu option View → Tank → Tank
Inventory.
Select check box Use product defined Volume Table in case you want to use volume tables
specified in the Product Table. If this box is not selected, you can choose a volume table
from the Volume Table drop-down list.
Related information
Create a product table

Vapor density setup
Vapor density can either be considered constant or it can be calculated:
• If the vapor density is considered constant, check the Vapor Density box and enter a

manual value.

• If the vapor density is calculated, make sure the Vapor Density check box is unchecked
and enter a Base Density. The Base Density is used by TankMaster to calculate Vapor
Density.
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Floating roof correction setup
For floating roof tanks, a number of roof correction parameters need to be configured in
order to achieve proper volume calculations.
Open the Tank Roof Setup window

Procedure
1. Ensure that the Tank Volume Calculation Setup window is open.
2. In the Tank Volume Calculation Setup window, click the Roof Setup button.

Roof correction method
• Select the appropriate roof correction method.
• Enter the Roof Weight and the Roof Critical Zone where appropriate
• If the roof correction is calculated into the Tank Capacity Table (TCT) using a base

density, a secondary correction must be calculated for any difference between the base
density and the observed density

• If roof correction involves roof immersion, select the appropriate correction method
and click the Immersion Setup button.

Correction calculation
Enter the weight of the floating roof.
Secondary correction of TCT volume
If the roof correction is calculated into the TCT using a base density, a secondary correction
based on the Base Density and Volume Adjustment must be calculated. These parameters
can be found in the TCT (tank certificate).
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Roof critical zone
The effect of the calculated volume compensation in the Roof Correction Method depends
on the roof position. Three intervals are used:

1. Below Lower Level (below Roof Critical Zone): when the roof is resting on its legs no
compensation is made (indicated with a (*) symbol in the Tank Inventory window).

2. Above Upper Level (above Roof Critical Zone): when the roof is freely floating, full
compensation is made for the volume reduction by the weight of the roof.

3. Between Upper and Lower Level (Roof Critical Zone): when the roof is partly
floating, compensation is made through a weighted value (indicated with (@) in the
Tank Inventory window).

Immersion
Floating roof immersion calculations are required for certain correction methods in order
to achieve proper volume calculations.
Related information
Immersion setup
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Extended volume correction table setup
The Extended Volume Correction Table Setup is used only for Linear and Custom volume
tables. When these volume tables are selected, the VCF Calculation Entry button is
enabled.
The Linear Volume table is used in a similar way as the CHEM volume table except it is not
necessary to change the following parameters in the Product Table:
• Reference Density
• Density Change
• Reference Temperature
VCF calculation entry Linear

Prerequisites
Ensure that volume table Linear is used.
Procedure

1. In the Tank Volume Calculation Setup window, click the VCF Calculation Entry
button.

2. Enter appropriate values in the Linear Correction Data table.

3. Click OK.
VCF calculation entry Custom
In the Custom Volume Table, a polynomial coefficient is used to calculate the Volume
Correction Factor (VCF).
Prerequisites
Ensure that volume table Custom is used.
Procedure

1. In the Tank Volume Calculation Setup window, click the VCF Calculation Entry
button.
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2. Enter the VCF coefficients.

3. Click OK.

VLVR setup for LPG and cryogenic tanks
The Vapor Volume Liquid Ratio (VLVR) is used for calculations of Net Standard Volume
(NSV) for LPG products.
The Vapor Volume Liquid Ratio (VLVR) is one of the parameters specified in the Product
Table. You may set an individual VLVR value for the current tank by selecting the check box
and typing the desired VLVR value. When the check box is selected, this value will be used
instead of the VLVR in the Product Table.
Related information
Inventory parameters

Immersion setup
The Immersion Setup window is used for configuration of floating roof immersion. This
may be required for certain correction methods in order to achieve proper volume
calculations.
Procedure

1. Right-click the desired floating roof tank in the WinOpi workspace
2. Select Tank Setup → Tank Volume Calculation.
3. In the Tank Volume Calculation Setup window, select the Roof Setup button.
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4. In the Tank Roof Setup window, select the appropriate correction method for roof
immersion, and click the Immersion Setup button.
Enter the appropriate calibration values. The sections Calibration Values with
weighing roof and Calibration Values without weighing roof are enabled or disabled
depending on the choice of correction method in the Tank Roof Setup window.

Related information
Floating roof correction setup
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4.6.2  Product parameter setup
TankMaster uses a number of product related parameters for the inventory calculations.
To configure product parameters for a product in a specific tank.
Procedure

1. In the Workspace do one of the following:
• right-click on a tank and select Tank Entry
• select a tank, and open menu option Entry → Tank Entry

2. In the Tank Entry window you may specify a number of product parameters for
inventory calculations. TankMaster can either use automatically measured data, or
manually entered values, where possible.
The Strength parameter is used in conjunction with Volume Correction Table
ALCOHOL.
FWV at zero level lets you add an offset value to the Free Water Volume.
For LPG and cryogenic tanks you may choose a method to use for Liquid Mass
calculations.
To enter manual values select the corresponding check box and enter a value in the
input field. Manual values are indicated by a yellow color.

Related information
Tank volume calculation setup
Inventory parameters
Color settings
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4.7  Custody transfer approval
The Custody Transfer Volume Approval window gives an overview of the automatic and
manual parameters and values used to calculate the volume of the product in the selected
tank.
To open the Custody Transfer Volume Approval window, select Batches → Custody
Transfer from the main menu.

Figure 4-7: Custody Transfer Volume Approval

4.7.1  Approve volume transfer
The transfer of the product and given input values for volume calculation can be approved
by authorised personnel.
Procedure

1. In the Approval Info section, select Approved from the Approved menu. The default
value is Not Approved.

2. Enter a name of at least 4 characters.
3. Click Apply. The date and time stamp for the approval action is shown.
4. To reverse the decision:

a) In the Approval Info section, select Not Approved from the Approved menu.
b) Click Apply. The date and time stamp are removed.
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4.8  Checklist for inventory parameter setup
TankMaster presents inventory data based on measurements of a number of different
parameters. Product level, temperature, vapor pressure, reference density, and free water
level are some of the parameters included in the calculations.
If an inventory parameter is not properly presented, or if the value is outside the normal
range, it may be due to missing input, or input data outside a specified range.
This checklist is intended to be used as a troubleshooting tool when inventory parameters
are incorrect or missing.
If, for example, GSV is missing as shown in Figure 4-8, the check list suggests parameters
that should be checked. In this particular case the Reference Density is missing. As a result,
the Observed Density value is outside the approved limit for products using Product Table
54B-2004.

Figure 4-8: Example of Tank Inventory Troubleshooting

The checklist refers to the following menus in TankMaster WinOpi:
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Figure 4-9: Checklist Menu References

Table 4-9: Checklist Menu References
Menu Menu Option

Entry
Tank Entry
Sensor Value
System

Setup > Tank Setup >

Product Table
System
Tank Capacity
Tank Volume Calculation
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The checklist is based on the Tank Parameters flow chart. . For each inventory parameter
the checklist suggests which input parameters should be checked.
The checklist follows the reverse order in which parameters are calculated since this is the
order in which errors appear.

Figure 4-10: Tank Parameters Flow Chart
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4.8.1  WIA / WIV
Procedure

1. If WIA is incorrect or missing, check NSV.
2. If NSV is OK, check the following parameters:

Parameter WinOpi menu
Reference Density Entry → Tank Entry

4.8.2  NSV
Procedure

1. If NSV is incorrect or missing, check GSV.
2. If GSV is OK, check the following parameters and sensors:

Parameter WinOpi menu
Sediment & Water (S&W) Entry → Tank Entry
LPG/LNG applications
Vapor Pressure Entry → Sensor Value

WinSetup menu: Service → Devices → LPG Setup
Vapor Temperature Entry → Sensor Value

WinSetup menu: Service → Devices → LPG Setup
Product Setup → Tank Volume Calculation
Vapor Liquid Ratio (VLVR) Setup → Product Table
Mol Mass Setup → Product Table

4.8.3  GSV
Procedure

1. If GSV is incorrect or missing, check GOV.
2. If GOV is OK, check the following parameters:

Parameter WinOpi menu
Reference Density Entry → Tank Entry
TEC Liquid
(Table 6C, 24C, 54C, 60C)

Entry → Tank Entry

Volume Table Setup → Tank Volume Calculation
Volume Table Setup → Product Table
Average Temperature Entry → Sensor Value
Automatic Density Measurement
Ambient Air Density Setup → System

Installing a tank measurement system Reference Manual
March 2024 00809-0200-5110

112 Emerson.com/Rosemount



Parameter WinOpi menu
Vapor Density Setup → Tank Volume Calculation
Vapor Pressure Entry → Sensor Value
Liquid Pressure Entry → Sensor Value
Pressure sensor positions WinSetup: Service → Tanks → Tank Hybrid Calculation
Hybrid Minimum Level WinSetup: Service → Tanks → Tank Hybrid Calculation
Local Gravity Setup → System
Volume Table CHEM
Reference Density Setup → Product Table
Density Change Setup → Product Table
Reference Temperature Setup → Product Table
RT<nn> volume tables
Reference Temperature Setup → System

4.8.4  GOV
Procedure

1. If GOV is incorrect or missing, check TOV.
2. If TOV is OK, check the following parameters:

Parameter WinOpi menu
Free Water Level (FWL) Entry → Tank Entry
Average Temperature Entry → Sensor Value
TEC Tank Setup → Tank Capacity
Ambient Air Temperature Entry → System
Floating Roof
Roof Weight Setup → Tank Volume Calculation / Roof Setup
Reference Density Entry → Tank Entry
Ambient Air Density Setup → System
Base Density Setup → Tank Volume Calculation / Roof Setup
Volume Adjustment Setup → Tank Volume Calculation / Roof Setup
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4.8.5  TOV
Procedure

1. If TOV is incorrect or missing, check the measured level value.
2. If Level is OK, check the following parameters:

Parameter WinOpi menu
Tank Capacity Table Setup → Tank Capacity
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4.9  Connect WinOpi to the tank server

4.9.1  Connect WinOpi procedure
To connect TankMaster WinOpi to the Tank Server do the following:
Procedure

1. Open the WinOpi workspace on the client computer.
2. Select the Plants view.

3. Right-click the Plants icon and select New connection.
The New Connection window appears allowing you to connect to the desired Tank
Server.

4. Click Browse and select the computer where the Tank Server is located.

5. Type the desired Plant name to appear in the WinOpi workspace. Alias designates
the name that will be used for the Tank Server in the WinOpi workspace.

6. Click OK when finished.
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5  Alarm handling
Rosemount TankMaster lets you manage various types of alarms. You can set alarm levels
as well as hysteresis and delay times for various parameters, such as Level, temperatures,
and analog input signals.
An alarm status can be one of the following:
• HiHi
• High
• LoLo
• Low
• Leak Hi
• Leak Lo
• CFail (communication failure)
• Normal
• Error
The data that TankMaster receives from field devices are continuously checked against
the alarm limits. Alarm limits, delay times, hysteresis and leak alarms are defined by the
operator in the password protected Alarm Limits window.
If a value exceeds an alarm limit, the corresponding alarm will be activated after a certain
delay as given by the Delay Time setting. The alarm status will flash bright red in, for
example, the Alarm Summary window, or the Tank Inventory window until the operator
accepts the alarm.
Even if conditions have returned to normal, the alarm status is not reset until the operator
has accepted the alarm. In order to accept and disable an alarm, the parameter that
caused the alarm must pass below the alarm limit and satisfy the Alarm Hysteresis value.
When these conditions are satisfied, the alarm reset is delayed an amount of time given by
the Delay Time.
When an alarm is accepted, the alarm status turns dark red by default. Alarm colors can be
changed.
Related information
Alarm colors
Alarm status
Color settings

5.1  Leak alarms
There are two leak alarms - level leak, and volume leak.
• the level leak alarm monitors product level changes
• the volume leak alarm monitors changes in the NSV
When the Leak Limit is set, the current value for tank level, or volume, is stored. The
difference between the actual value and the stored value is monitored, and the Leak
Alarm is activated when this difference becomes greater than the leak limit defined by the
operator.
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5.2  Sensor failure
In the event of a sensor failure, for example if a temperature sensor malfunctions, then the
sensor status Error is displayed.

5.3  Communication failure
If a Rosemount 2460 System Hub, or a Rosemount 2410 Tank Hub does not respond after
three queries, the alarm status of the tank parameters are set to Communication Failure
(CFail) and the following error message displayed in the status bar: <Tank Name> CFail.
All parameters associated with a unit that do not respond inherit the CFail status in this
case. Even though the status of the alarm can be shown for a number of parameters, it is
only regarded as one alarm, and therefore only needs to be accepted once for each unit.

5.4  Alarm status priority
Each parameter status has a certain priority, as shown below. If, for example a CFail alarm
is activated for a specific tank, the alarm status Error will not be shown for that tank as long
as the CFail status is valid.
If the parameter is disconnected then Discon will replace CFail as the parameter status.
Alarms are given the following order of priority:

1. Disconnect (Discon)
2. Communication Failure (CFail)
3. Error
4. Blocked
5. HiHi, LoLo
6. Leak Alarm Hi, Leak Alarm Lo
7. High, Low

Note
Priorities 1 to 4 are only valid for automatically measured values, not for manual values.

Related information
Disconnecting alarms
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5.5  Setting alarm limits
An Operator can set up alarm limits for various parameters in the Alarm Limits window,
including:
• Level and level rate
• Average temperature and vapor temperature
• Analog inputs
• Vapor pressure and liquid pressure

5.5.1  Alarm limits
The Alarm Limits window lets you specify limits for a large number of parameters.
Procedure

1. In the TankMaster workspace right-click on a tank and choose Alarm Entry → Alarm
Limits, or select the same option in the Entry menu.

2. Specify the desired alarm limits.
Leak Once a Leak alarm is activated, the alarm will trigger in case the level

value drops the amount specified in the Leak entry field.
Leak alarm for Volume can be set in the Volume Alarm Limits
window. A volume leak alarm monitors changes of the Net Standard
Volume (NSV).
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Leak alarms can be enabled and disabled for single tanks as well as
for entire tank groups.

Hi, HiHi, Lo,
and LoLo

These alarms can be set for Level, Level Rate, and various sensors.

Hysteresis Prevents alarms from activating due to turbulent surface level
conditions.
For example, the Level Hi limit is set to 10 m and the hysteresis to 0.1
m. The alarm is activated when the level exceeds 10 m and remains
active until the level drops below 9.9 m. In this case, small waves on
the liquid surface do not influence the Hi alarm.
For example: the Level Rate Hi limit is set to 4,5 m/h and the
hysteresis to 0.1 m/h. The alarm is activated when the level exceeds
4,5 m/h. It remains active until the level rate drops below 4,4 m/h. In
this case fluctuations in the flow do not influence the Hi alarm.

Delay A delay time can be used to prevent temporary changes of the
measurement value from activating the alarm. This value specifies
the delay in seconds.

3. When finished, click OK to activate the current settings and close the Alarm Limits
window.

Related information
Volume alarm limits
Disconnecting alarms
Enable and disable leak alarms
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5.5.2  Volume alarm limits
Volume alarm limits can be configured for Net Standard Volume (NSV), Flow Rate, and Flow
Direction.
Procedure

1. Right-click on a tank in the workspace and select Alarm Entry → Volume Alarm
Limits, or choose the same option from the Entry menu.

2. Enter alarm limits in the appropriate input fields.
3. Click Apply to activate the current settings and OK to close the Volume Alarm Limits

window.

Net Standard Volume
Hi, Lo
Defines alarm thresholds for high and low conditions.
Leak
A volume leak alarm monitors changes in the Net Standard Volume (NSV).
Hysteresis
A hysteresis value can be set to stop alarms activating due to turbulent surface level
conditions.
Delay
The Delay time can be used to prevent temporary changes of the measurement value from
activating the alarm. This value specifies the delay in seconds.
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Flow rate
Hi
Defines the alarm threshold for the high condition.
Hysteresis
A hysteresis value is configured to stop alarms activating due to turbulent surface level
conditions when filling or emptying a tank
For example: the Level Hi limit is set to 10 m3/h and the hysteresis to 0.1 m3/h. The alarm is
activated when the level exceeds 10 m3/h. It remains active until the level drops below 9.9
m3/h. In this case small waves on the liquid surface do not influence the Hi alarm.
Delay
The Delay time can be used to prevent temporary changes of the measurement value from
activating the alarm. This value specifies the delay in seconds.

Low flow

The Low Flow option is a safety feature which is used to verify that the correct tank is
activated when filling or emptying is in progress.
Enabled enables the Flow Rate Lo alarm function. This value specifies the minimum

flow in m3/h.
Start Delay the amount of time that is given to reach the maximum transfer rate. If the

time limit is exceeded and the flow rate is too low, an alarm is triggered. This
value specifies the delay in seconds.

Flow direction alarm
The Flow Direction Alarm monitors the direction of flow. If the flow direction is other than
expected an alarm is triggered.

Disabled The Flow Direction Alarm function is disabled.
Filling If the product is pumped out of the tank, TankMaster will trigger a High Leak

alarm for the flow rate parameter.
Emptying If the product is pumped into the tank, TankMaster will trigger a High Leak

alarm for the flow rate parameter.

Leak
In order to avoid unnecessary alarms in turbulent conditions, for example, soon after
pumping begins, a flow rate limit can be specified in the Leak input field.
If the product temporarily flows in the wrong direction, the Flow Direction Alarm will not
be triggered as long as the flow rate remains below the Leak value.
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5.5.3  Set-point alarms
The Set-point Alarms Setup option allows you to specify alarm limits for Level, Volume and
Weight parameters. Set-point alarms must first be enabled in the Tank Set-Point Alarm
Setup window.

Set-point alarm setup
Procedure

1. In the TankMaster workspace do one of the following:
• right-click on the desired tank and select Tank Setup → Tank Set-Point Alarm

Setup
• open the Setup menu and select Tank Setup → Tank Set-Point Alarm Setup.

2. In the Tank Set-Point Alarm Setup window you can enable or disable Level, Volume,
and Weight set-point alarms for the selected tank.

You can also specify Data Source for Volume and Weight set-point alarms:
Volume TOV, GOV, GSV, or NSV
Weight TOV, GOV, GSV, or NSV

3. Click OK to close the Tank Set-Point Alarm Setup window and activate the selection.
Note
Only set-point alarms enabled in the Tank Set-Point Alarm Setup window are
available in the Set-Point Alarm Limits window.

Related information
Set point alarm limits

Reference Manual Alarm handling
00809-0200-5110 March 2024

Rosemount TankMaster 123



Set point alarm limits
The Tank Set-Point Alarm Limits window lets you set LoLo, Lo, Hi, and HiHi alarm limits for
Level, Volume, and Weight set-point alarms.
Procedure

1. In the TankMaster workspace do one of the following:
• right-click on the desired tank and select Tank Set-Point Alarm Limits
• open menu option Entry → Tank Set-Point Alarm Limits.

2. The Tank Set-Point Alarm Limits window lets you configure the desired alarm limits
as well as Hysteresis and Delay for the selected tank.
Note
The Tank Set-Point Alarm Limits window only shows enabled alarm options.
If you attempt to open the Tank Set-Point Alarm Limits window before you have
enabled any set-point alarms, the following prompt will appear:

Related information
Set-point alarm setup
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Viewing set-point alarms for a tank
You can view set-point alarm details for a tank.
Procedure
In the TankMaster workspace do one of the following:
• right-click on the desired tank and select View Tank → Tank Set-Point
• open menu option View → Tank → Tank Set-Point .

Figure 5-1: Set-point View

Alarm sounds
Specific sounds can be used for set-point alarms.
Related information
Alarm setup

Alarm colors
Specific colors can be used for set-point alarms in inventory windows. You can specify
colors for the different set-point alarms (LoLo, Lo, Hi, HiHi) as well as for the text string that
shows alarm type, date and time.
Related information
Alarm setup
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Disable set-point alarms for a tank group
You can disable set-point alarm details for a tank group.
Procedure

1. In the TankMaster workspace do one of the following:
• right-click on the desired tank and select Disable Set-Point Alarms
• open menu option Entry → Disable Set-Point Alarms.

2. You will be prompted to confirm that you want to disable all set-point alarms for the
selected group.

Figure 5-2: Disable Set-point Alarm Parameters
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5.6  Alarm summary
TankMaster makes it easy to view a summary of alarm details for a particular group of
tanks, or for all tanks in the system.
Procedure
To view a summary of current alarms for a group, do one of the following:
• in the Workspace, select a tank group and select menu option View Alarms → Alarm

Summary
• right-click on a group and select View Alarms → Alarm Summary
• click the Alarms Summary button in the toolbar

Figure 5-3: Alarm Summary

A. View → Alarms toolbar menu option
B. Alarms Summary shortcut button
C. View Alarms right-click menu option

5.6.1  View alarm summary
The Alarm Summary window shows details for active alarms including related tanks and
parameters. The time when an alarm was activated is shown in the On column, and the
time it was accepted is shown in the Accepted column.
An alarm is displayed until it is accepted and the cause of the alarm is resolved.
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Figure 5-4: Alarm Summary

Note
A Leak Lo/Hi alarm is not removed until it has been disconnected in the Alarm Disconnect
window.

Related information
Disconnecting alarms

5.7  Alarm log
TankMaster has an alarm log which allows you to view the alarm history for a a tank or
a group of tanks. The Alarm Log window shows a list of logged alarms as well as other
important information such as tank name, time and date, and the operator who accepted
the alarm.
Procedure
To view the Alarm Log for a selected group, do one of the following:
• Right-click on a tank group in the TankMaster workspace and select View Alarms → 

Alarm Log.
• From the View menu, choose View Alarms → Alarm Log

• Click the Alarm Log button  in the toolbar

Similar to the Alarm Summary, the Alarm Log window displays the following information
for each alarm:
• Alarm type (High, Low etc.).
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• Tank name.
• Parameter that activated the alarm.
• Parameter value when the alarm was activated.
• Alarm status.
• Time and date when the alarm was activated and accepted.
• Operator who accepted the alarm.

5.7.1  Alarm status
The following values can be applied to the Status column:
• When an alarm is activated, the status column displays On
• When the alarm is accepted, the status changes to Acc
If an alarm is unaccepted, the status will continue be displayed as On, even if the value that
activated the alarm returns to normal.
The alarm status is changed to Off when the corresponding alarm has been accepted and
the value that activated the alarm returns to within the accepted range.
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5.7.2  Filter settings
The Alarm Log can be filtered by tanks and time period.
Procedure

1. In the Alarm Log window, click the Filter button:

Note
In case a single tank is shown in the Alarm Log window, only that particular tank will
appear in the Selected Tanks pane when the Filter button is pressed. All tanks will
appear in the Selected Tanks pane if All Tanks optoins is selected in the Alarm Log
window.

2. In the Alarm Log Filter Settings window, specify the desired time period:
a) Choose All dates to view every alarm that has been logged for the selected

tanks.
b) Select Date between to view alarms within a specific period.
c) Click Not older than to view all alarms from a certain point until the present

time.

3. To filter tanks that the alarm log will apply to, select a tank in the Available Tanks
pane and click the Add button. Tanks can be removed from the Selected Tanks pane
by clicking the Remove button.

4. Optional: Select the Save settings as default check box in case you would like to use
the selected settings as default for the Alarm Log.

5. Click OK .
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Related information
Viewing the alarm history log

5.7.3  Saving the alarm log to file
The Alarm Log can be saved to file and the log file can be viewed in the Alarm History
window.
Note
The Filter option in the Alarm History window can be used to reduce the displayed number
of days. This will not affect the actual number of days stored in the log file.

Procedure
1. From the Tools menu, choose Options.
2. Select the Log Setup tab:

3. Select the Log to File option.
4. Set the maximum log file size by specifying the number of records or the number of

days to be logged:
• 10 days will save all alarm events from the previous 10 days up until the current

time.
• 1000 records will save 1000 alarm events to the alarm log.

5. Click Apply to save the alarm log file settings.
6. Click OK to close the program options.

Related information
Viewing the alarm history log
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5.7.4  Viewing the alarm history log
If the Alarm Log is saved to file, it can be viewed in the Alarm History window.
Procedure

1. To view the alarm log history for a tank group, do one of the following:
• Right-click on a tank group in the TankMaster workspace and select View Alarms 

→ Alarm History Log.
• From the View menu, select Alarms → Alarm History Log

2. Click the Filter button to specify which tanks to show in the History Log or to change
time periods.

3. Click Print to print the alarm history log.
4. Click the Close button to close the Alarm History window.

Related information
Saving the alarm log to file
Filter settings
Alarm printer settings

5.7.5  Alarm printer settings
Alarms can be printed directly to a printer. A print out of an alarm is executed when the
alarm is activated.
Procedure

1. From the Tools menu choose Options.
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2. Select the Log Setup tab:

3. Select the Log to Printer check box.
4. Select the appropriate Printer Port option for the designated printer.
5. Enter a value for the maximum number of lines to be per printed page.
6. Enter a value for the maximum number of characters per line.
7. Click the Verify connection button to print a test page.
8. Click Apply to save the settings.
9. Click OK to close the program options.

Related information
Viewing the alarm history log

5.7.6  Changing the operator name
The Operator name can be displayed in three different ways when it is associated with
accepted alarms in the Alarm Log window.
Procedure

1. From the Tools menu choose Options.
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2. Select the Log Setup tab:

3. Choose one of the following:
• User name - User Id for logging in to the workstation.
• PC name - node name of the current workstation in the network.
• User defined - a custom name to be displayed in the Operator field.

4. Click Apply to save any changes.
5. Click the OK button to close the program options.

The Alarm Log shows which alarms have been accepted by an Operator.

Figure 5-5: Alarm History

A. PC name
B. User defined name
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5.8  Alarm groups
Alarm groups can be used to distribute the authority to accept alarms. An alarm group
can contain tanks with a similar type of product which can be associated with different
workstations or users.
From the current workstation, alarms can only be accepted from an Active alarm group.
Other alarms are indicated, but can not be accepted. An alarm group can be set as Active
when it is created by selecting the Set as active alarm group check box in the New Alarm
Group window, or at a later time by right-clicking on the group and selecting Edit Alarm
Group.

5.8.1  Creating an alarm group
Procedure

1. In the TankMaster workspace, right-click on the Groups icon and select New Alarm
Group.
Note
Depending on the current protection level, a request for an access level password
may appear.

2. In the New Alarm Group dialog, enter a name of the new group.

3. Click OK.
Note
An alarm group cannot have the same name as another group in the TankMaster
workspace.
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4. In the New Alarm Group window, select a tank to add to the new group and click the
Select button.

5. Repeat for all tanks to be added to the group.
Objects can also be removed from the Chosen tanks/groups pane by using the
Remove and Remove All buttons.

6. To associate the new alarm group with the current workstation, select the Set as
Active Alarm Group check box. The current workstation will be authorized to accept
alarms from tanks within the active alarm group.

7. Click the OK button.

More than one alarm group can be created, but only one alarm group can be active
at any given time for the current workstation.
It is possible to set the group All Tanks as active in order to be able to accept alarms
from all tanks in the current system.

Related information
Set required access levels
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5.8.2  Setting an alarm group as active
Setting an alarm group as Active enables the current workstation to accept alarms from
tanks within that alarm group.
Procedure

1. Right click the alarm group that is to be active.

2. Select the Edit Alarm Group option.

3. Enable the Set as active alarm group check box.
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4. Click OK.
A yellow star indicates which alarm group that is active.
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5.8.3  Accepting alarms
Alarms can be accepted by the operator if the current program protection level is equal to
or higher than the required access level.
Alarms can only be accepted for tanks included in an active alarm group.
To accept an alarm do one of the following:
• Press <SHIFT + F9>.
• Click the Accept button on the toolbar.
• Open menu option View → Alarms → Accept Alarm.
• Right click on the active alarm group and select View Alarms → Accept Alarm.
If the current workstation is not associated with an active alarm group, alarms can be
accepted for all tanks.

Figure 5-6: Accept Alarm Options

Related information
Set required access levels
Setting an alarm group as active
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5.9  Disconnecting alarms
Disconnecting alarms can be useful during maintenance work. Specific alarms can be
disconnected individually, or all alarms can be disconnected at once. The Alarm Disconnect
window provides an overview of which alarms are active or disconnected, and allows you
to specify which alarms should enabled or disabled.
Procedure

1. In the TankMaster workspace, do one of the following:
• Right-click a tank in the Workspace window and select Alarm Entry → Alarm

Disconnect
• select menu option Entry → Alarm Entry → Alarm Disconnect

2. To disconnect an individual alarm, click the corresponding check box.
3. Optional: To disconnect all alarms, select the Disconnect Tank check box.
4. Click Apply to implement changes, and OK to close the Alarm Disconnect window.

Alarm status The status of a disconnected alarm is displayed as Discon in tank and
group view windows.

Calculations WinOpi continues to monitor and update measurement values for a
parameter when the corresponding alarm is disconnected.
A disconnected temperature sensor is not included in the average
temperature calculation.

Note
There are no error alarms for disconnected sensors. Sensor failures are not
indicated for sensors with disconnected alarms.

Related information
Enable and disable leak alarms
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5.9.1  Enable and disable leak alarms
The Enable/Disable Leak Alarms function is used for enabling or disabling leak alarms
for entire groups. To enable/disable alarms for individual tanks use the Alarm Disconnect
function.
Procedure

1. In the TankMaster workspace, do one of the following:
• Right-click a tank group in the Workspace window and select Enable/Disable

Leak Alarms
• select menu option Entry → Enable/Disable Leak Alarms

2. Select one of the following options from the Parameters list:
• Level only
• NSV only
• Level & NSV

3. Click the Enable button to activate leak alarms for all tanks in the selected tank
group.
The Enable button is active if one or more leak alarms for Level or NSV are disabled
for the selected group.

4. Click the Disable button to disable the selected leak alarms for all tanks in the
selected tank group.
The Disable button is active if one or more leak alarms for Level or NSV are enabled
for the selected group.

Related information
Disconnecting alarms
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5.10  Alarm setup
Alarms can be configured to provide unique notifications for specific alarms. Alarm settings
can be customized for sounds, colors, notifications, users, and shifts.

5.10.1  Alarm sound notification
Sounds can be used to clearly distinguish between different alarm signals.
Procedure

1. In the TankMaster workspace, select menu option Tools → Options, and then select
the Alarm Sounds tab.

2. Select an alarm from the Alarms list.
3. Choose a Sound mode from the following options:

• PC speaker only - this option uses Microsoft Windows sounds
• WAV file
• None - this option disables alarm signaling

4. Repeat Step 2 to Step 3 for as many alarms as required.
5. Click Apply, and OK to close the program options.

Using a WAV sound
You may use a WAV sound file as alarm signal.
Procedure

1. In the Alarm Sounds tab, click the Browse button.
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2. Locate a *.WAV file. Default alarm sounds are available in the following
location: ...\Rosemount\Tankmaster\Opi\Data.

5.10.2  Alarm colors
You can configure alarms to be displayed in unique colors.

Related information
Color settings

5.10.3  Alarm notification via e-mail
WinOpi can be configured to send notifications via e-mail when an alarm is activated.
Procedure

1. In the TankMaster workspace, select menu option Tools → Options, and then select
the Alarm Notifications tab.

2. From the Alarm group drop-down list, select the desired alarm group to configure
for notifications.

3. Select an E-mail client for e-mail notifications. The Microsoft MAPI does not require
further configuration. To configure the Built-in e-mail client, see E-mail client
configuration.
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Note
On some systems the MAPI mail client generates a security warning dialog from the
server when trying to send an alarm notification. On these systems, the distribution
of alarm notifications requires user interaction and no alarm notifications will be
sent if the security warning dialog is left unattended.

4. Click the Address Book button in case you need to add recipients for notification via
e-mail.

5. In the Available Contacts pane, select a name to be included in the list of Recipients
and click the Add > button.

6. Click the Add New button if you need to add a new contact to the Address Book.
7. Enter name and e-mail address for the new recipient and click OK.

8. Repeat Step 5 to Step 7 for all recipients to be included in the e-mail notification.

Note
To remove a recipient from the Recipients list, select a name and click the Remove
button.

9. Click OK to save the configuration and close the Address Book window.
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10. For each e-mail recipient, configure:
• desired alarms to be included in the e-mail notification (CFail, Error, HiHi and

LoLo, High and Low, Leak)
• one or more weekday and weekend shifts for which the e-mail notification

function will be activated

11. Select OK to save the current setup.

Configure shifts
This is a description on how to setup weekday and weekend shifts for e-mail alarm
notifications.
Procedure

1. In the Alarm Notifications tab, click the Shifts button.

2. Select desired shifts for which notifications will be sent.
3. Configure start and stop times for shifts using the From and To fields.
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4. Click Configure Weekdays to specify days for Weekday and Weekend.

5. Click OK.
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5.10.4  E-mail client configuration
Rosemount TankMaster™ has a built-in e-mail client which allows alarm notifications,
reports and other e-mails without using a third-party e-mail client.
Procedure

1. In the TankMaster workspace, select menu option Tools → Options, and then select
the E-mail Configuration tab.

2. Configure the following options:
SMTP Server Specify an SMTP server for outgoing messages. Contact

your LAN administrator or Internet Service Provider (ISP) for
details.

Sender Address The e-mail account which will send e-mails from the current
workstation must be located on the specified SMTP server.

SMTP Port Optional. Contact your LAN administrator or ISP for details.
Authentication
Configuration

Select this option and enter a Login name and Password if
authentication is required on the mail server. Contact your
LAN administrator or ISP for details.

Channel Security
Configuration

Select this option if the e-mail client requires the use of
channel security. Contact your LAN administrator or ISP for
details.

Subject Enter a title for an e-mail alarm notification. The subject is only
used for alarm notification and is optional. This subject will not
be used for other e-mails sent from the built-in e-mail client.

3. Click OK.
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6  Reports
Rosemount TankMaster™ allows you to create reports to be scheduled for automatic
distribution. The reports provide inventory information on tanks and their contents.

6.1  Set up an automatic report
Procedure

1. To set up a scheduled automatic report, do either of the following:
• In the TankMaster workspace Groups view, right-click the Reports icon and select

Add Report
• Select the Reports icon in the Groups view and open menu option Reports → Add

Report
• Open menu option Tools → Options, select the Reports tab, and click Add

A. Right-click → Add Report
B. Reports → Add Report
C. Tools → Options → Reports
D. Add a new report
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2. In the Report Data window specify the following for a report:
• report type, subtype, and title
• which tank or tank group to send reports from
• how the report will be published and distributed
• how often the report will be automatically distributed

6.1.1  General report settings
Under General Report Settings, select a Report Type, a Report Sub Type, and enter a name
of the report in the Report Title field. These settings determine which parameters are
included in the report and the report layout.
Example 1 Log Report
Table 6-1: Parameters for Log Reports
Report SubType Parameters shown
Default Product

Level
Average temperature
Net Standard Volume
Reference Density
Level status
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Table 6-1: Parameters for Log Reports (continued)
Report SubType Parameters shown
HtmlLogReport Product

Level
Average temperature
Net Standard Volume
Reference Density
Level status

HtmlGroupLogReport Average temperature
Net Standard Volume
Reference Density
Level status

HtgLogReport Product
Volume table
Level
Temperature
Weight in Air
Gross Observed Volume
Level status

HtmlTankInvLogReport Product
Volume table
Level
Free Water Level
Ambient temp.
Shell temperature
Product temperature
Total Observed Vol.
Free Water Volume
Shell temp. Correction factor

Floating roof adjust.
Gross Observed Volume
Observed density
Reference density
Volume Correction Factor
Gross Standard Volume
Sediment and Water
Net Standard Volume
Weight in Vacuum

PdfLogReport Product
Level
Average Temperature
Net Standard Volume
Reference density
Level Status

PdfGroupLogReport Product
Level
Net Standard Volume
Average temperature
Reference Density
Alarm Status
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Table 6-1: Parameters for Log Reports (continued)
Report SubType Parameters shown
PdfTankInvLogReport Product

Volume table
Level
Free Water Level
Ambient temp.
Shell temperature
Product temperature
Total Observed Vol.
Free Water Volume
Shell temp. Correction factor

Floating roof adjust.
Gross Observed Volume
Observed density
Reference density
Volume Correction Factor
Gross Standard Volume
Sediment and Water
Net Standard Volume
Weight in Vacuum

Example 2 Mass Balance Report
Table 6-2: Parameters for Mass Balance Reports
Report SubType Parameters shown
Default Product

Level
Average temperature
Total Observed Volume
Net Standard Volume
Reference density
Weight in Air
Level status
Net Standard Volume - difference since last report

HtmlMassbalanceReport Product
Level
Average temperature
Total Observed Volume
Net Standard Volume
Reference density
Weight in Air
Level status
Net Standard Volume - difference since last report

CtMassbalanceReport Product
Volume table
Level
Average temperature
Total Observed Volume
Net Standard Volume
Weight in Vacuum
Level Status
Net Standard Volume - difference since last report
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Table 6-2: Parameters for Mass Balance Reports (continued)
Report SubType Parameters shown
HtgMassbalanceReport Product

Volume table
Level
Temperature
Gross Observed Vol.
Net Standard Vol.
Weight in Vacuum
Level status
Weight in Vacuum - difference since last report

PdfMassbalanceReport Product
Level
Average temperature
Total Observed Volume
Net Standard Volume
Reference density
Weight in Vacuum - difference since last report
Level status
Net Standard Volume - difference since last report
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6.1.2  Report examples
Figure 6-1: LogReport, subtype: Default

Figure 6-2: LogReport, subtype: HtmlLogReport

Figure 6-3: MassBalanceReport, subtype: Default

Figure 6-4: MassBalanceReport, subtype: HtmlMassbalancereport

Note
To sum up the NSV field for all tanks, the RGM.ini file needs to be edited. For more
information, please contact Emerson Automation Solutions/Rosemount Tank Gauging.
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6.1.3  Adding tanks or groups to a report
The Report Data window lets you specify which groups or tanks that should be included in
a report.
To specify which groups or tanks to include in the report, select from the available options
for Groups(s) or Tank(s).
Select All Tanks in case you want to include all tanks in the report, or choose a specific tank
or tank group.

Figure 6-5: Adding Groups and Tanks to Reports

Related information
Create a tank group
Set up an automatic report
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6.1.4  Configure publication type
Reports can be printed, sent by e-mail, or saved as a text file in HTML or pdf format.
The report format can be configured in the Publication Type section in the Report Data
window.

Configure printed report
Procedure

1. In the Publication Type Available pane, double click Printer, or select Printer and
click the Add button.

2. In the Selected pane on the right-hand side, select Printer and click Config.

3. Select a specific printer for publishing the reports.
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4. Click OK.

Configure email reports
Procedure

1. In the Available pane, double click eMail, or select eMail and click the Add button.

2. In the Selected pane on the right, select eMail and click the Config to add recipients
and a subject.

3. Click Add to add a recipient for the e-mail report. Repeat this for each recipient.
4. Add a subject for the e-mail.
5. Click OK.
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To create more e-mail distribution lists, repeat this procedure. The selected report
will be sent to all e-mail distribution lists in the Selected pane on the right-hand side
of the Report Data window.

Related information
E-mail client configuration

Configure file reports
Reports can be saved as text file, HTML report, or pdf report.
Procedure

1. In the Available pane, double click File, or, select File and click the Add button.
2. In the Selected pane on the right, select File and click Config.

3. Enter a path to the folder where the report will be saved and a file name.

4. To add a unique suffix to the report files, check the Add Unique Suffix box. In
this example, the first report file will be called North Area Report_1.txt, the second
report file North Area Report_2.txt, and so on. When the Max Number of Report
Files is reached, the oldest report file will be overwritten.
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5. Enter a maximum number of report files to be saved. In this example, when North
Area Report_10.txt has been created, the next file will be North Area Report_1.txt,
and the previous file with that name will be overwritten.

6. Click OK.
Note
If only a file name is specified with no directory, report files are saved in the default
folder: ...\Rosemount\TankMaster\Opi\Shared.

6.1.5  Recurrence pattern
To define how often a report will be automatically distributed:
• select either hourly, daily, weekly, or monthly
• specify a start time and frequency
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6.2  Publishing a report
The Report Data window lets you set up reports for automatic publishing according
to configured settings. In addition to automatic scheduling, a report can also be
manually published at any time you like using the configured settings for publication and
distribution.
Procedure

1. In the WinOpi workspace, select the desired report.
2. Do one of the following:

• Click the right mouse button and select Publish Report
• select menu option Reports → Publish Report

The selected report will be published immediately according to the configured
Report Type and Publication Type settings for that report.
In addition to the Publish Report option, the Reports menu lets you change, delete,
and review reports.

A B C

A. Report type
B. Tank / Tank group
C. Publication type

Reports Reference Manual
March 2024 00809-0200-5110

160 Emerson.com/Rosemount



7  Audit log
The Audit Log function enables operations performed by a Rosemount TankMaster™ user
to be recorded. Audit log records can include events and actions such as changing alarm
limits, logging on or off, and setting parameter values manually.

7.1  Setup an audit log
The Audit Log function can be enabled or disabled at any time.
Procedure

1. In the TankMaster workspace, select menu option Tools → Options, and then select
the Log Setup tab.

2. Under Audit Log Settings, select the desired Tankserver to be monitored by the
Audit Log function.

3. Activate the Audit Log function by selecting one of the two options:
• Set size of log file by number of records
• Set size of log file by number of days
Either of these two options can be used to limit the size of the Audit Log file. When
the file reaches its limit, the oldest records will be removed as new records are
stored.

4. Click OK, or Apply to activate the new settings.

7.2  Viewing the audit log
Procedure

1. In the TankMaster workspace, select menu option Tools → View Audit Log.
2. Select a server. The Audit Log can only be viewed for one tank server at a time.
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The Audit Log displays the time stamps for each event and the Operator who was
logged on at the time.
The Filter button allows you to record events over a certain time period, and for
specific tanks.
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7.3  Filtering the audit log
The Audit Log can be set up to record events over a certain period of time and for specific
tanks.
The Filter button in the Audit Log window opens the Audit Log Filter Settings window
which allows you to record events over a certain time period, and specific tanks.
To configure desired filtering options, open menu Tools → View Audit Log and select the
Filter button.

7.3.1  Filtering by date
There are three options available for date filtering:
• All dates
• Date between
• Not older than
Procedure

1. In the TankMaster workspace, select menu option Tools → View Audit Log.
2. In the Audit Log window, select the Filter button.
3. To log events within a certain period, select Date between and set the dates using

the pop-up calendar.
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4. To limit the audit log to events which are not older than a specific period, select Not
older than. The log can be limited to minutes, hours, days, weeks, or months.

5. Select All dates in case you want to disable filtering by date. All records regardless of
date appear in the Audit Log window.
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7.3.2  Filtering by tanks
The audit log can be filtered to display only those events which are related to specific tanks.
Procedure

1. In the TankMaster workspace, select menu option Tools → View Audit Log.
2. In the Audit Log window, select the Filter button:

3. In the Available Tanks pane, select a tank to be included in the audit log.
4. Click the Add  button. The tank appears in the Selected Tanks pane on the right.
5. Proceed by adding the desired tanks to appear in the Audit Log window.

Click the Add All  button in case you want to include all tanks.
You can remove tanks by using the Remove  and Remove All  buttons. Tanks
can also be added and removed by double-clicking an entry.

6. To set the maximum number of rows to be displayed in an audit log, enter a number
between 1 and 5000 in the Number of rows in table field.

7. In case you want to save the current settings as default, select the Save settings as
default check box.

8. Click the OK button to save the current filtering settings.
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8  Tank calculators
8.1  Density calculator

The Density Calculator is a TankMaster™ tool which calculates the reference density of
petroleum products according to the API standard.
The tool converts the observed density at any temperature to the corresponding reference
density at the standard temperature 15ºC/60ºF.
Procedure

1. Select menu option Tools  → Density Calculator.

2. Select the desired temperature unit: deg C or deg F.
3. Select the desired density unit:

• kg/m3

• deg API
• 60/60 deg F

4. Under Sample Data, enter the temperature of the product sample.
5. Select the appropriate Correction Table:

• 53, 53A, 53B, 53D, 53A20, 53B20
• 5A, 5B, 5D
• 23A, 23B

6. Under Sample Data, enter the observed Density of the product sample.

Reference Manual Tank calculators
00809-0200-5110 March 2024

Rosemount TankMaster 167



7. To correct for thermal expansion of the glass hydrometer, check the Hydrometer
correction of density box.
Reference Density=(Observed Density)*HYC.
Two different formulas are used for calculating HYC. One is adapted to tables 53,
53A, 53B and 53D. The other formula is used for tables 5A, 5B, 5D, 23A and 23B.
Note
Use the Hydrometer correction to compare the calculated values with printed API
tables. The reference density values in the API tables are adjusted to take glass
hydrometer expansion into account.

8. Click Calculate.
The calculated reference density is shown. This value can be entered manually into
the corresponding input field in the Tank Entry window (menu option Entry → Tank
Entry).

Related information
Product parameter setup
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8.2  Tank inventory calculator
The Tank Inventory Calculator generates inventory values based on manually entered
product data for a specific tank. Input fields are initiated using the current tank
configuration and readings from devices. The operator can change input fields and
calculate new inventory values based on different scenarios.
Procedure

1. Select the desired tank.
2. Select Tools → Tank Inventory Calculator.

3. Change one or more of the parameters in the Input pane.
4. Click Calculate to see the results.
5. Repeat this procedure for different scenarios with alternate input values.
6. Click Close to exit the Tank Inventory Calculator.
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8.3  Tank transfer calculator
The Tank Transfer Calculator tool allows you to calculate transferred product volume or
closing values using inventory parameters such as TOV, GOV, GSV, NSV, WIA, and WIV.
Procedure

1. Select a tank in the WinOpi workspace.
2. Select menu option Tools  → Tank Transfer Calculator.

Note
The Maximum Level in the WinSetup configuration for a tank should correspond to
the Maximum Volume in the Tank Capacity Setup. Maximum Volume is equal to the
TOV at the Maximum Level.
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8.3.1  Calculation setup for transferred values
This is a description of how to calculate values for volume and mass for a product transfer.
Procedure

1. Select a tank in the WinOpi workspace.
2. Select menu option Tools  → Tank Transfer Calculator.
3. In the Calculation Setup pane, select Calculate Transferred Values.
4. In the Opening Values and Closing Values panes, select the radio button next to

parameters to be used as input for the calculation:
• Opening values indicate the value for a parameter when the product transfer

begins
• Closing values indicate the value for a parameter when the transfer is completed

5. Enter a value for the selected parameter.
6. Repeat for the other parameters as required.
7. Click Calculate.

The calculated volumes and mass appear in the Transferred Values column on the
right-hand side of the Tank Transfer Calculator window.

8.3.2  Calculation setup for closing values
This is a description of how to calculate closing values for a product transfer.
Procedure

1. Select a tank in the WinOpi workspace.
2. Select menu option Tools  → Tank Transfer Calculator.
3. In the Calculation Setup pane, select Calculate Closing Values.
4. Select the desired movement type:

• Shipping
• Receiving

5. In the Opening Values and Transferred Values panes, select the radio button next
to a parameter to be used as input for the calculation.

6. Enter the desired value for a parameter in the Opening Values or Transferred
Values column.

7. Repeat for the other parameters as required.
8. Click Calculate.

The resulting values for level, volume and mass appear in the Closing Values
column. For a Shipping calculation, the closing value is always lower than opening
value. For a Receiving calculation, the closing value is always higher than opening
value.
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8.3.3  Tank transfer calculation setup
The Tank Transfer Calculation Setup window is used to manually set up the input
parameters for transfer calculations.
Procedure

1. Select menu option Setup → Tank Setup → Tank Transfer Calculation.

2. Enter the transfer calculation input parameters and click Apply to see the result in
the Transfer Calculation Output parameters pane.

3. Click OK to close the window.
Table 8-1: Calculation Type
Parameters Description
Calculation Type TOV, GOV, GSV, NSV, WIA, and WIV.
Open Gauge Volume The calculations starts at this volume (+/- volume hysteresis).
Close Gauge Volume The calculations stops at this volume (+/- volume hysteresis).
Volume Hysteresis Hysteresis value for Open Gauge Volume and Close Gauge

Volume.

Table 8-2: Transfer Calculation Output
Parameters Description
Open Gauge Date The date when the current volume passed the Open Gauge

Volume
(open volume + hysteresis).

Elapsed Transfer Time Elapsed time since open gauge.
Transfer Volume Difference between current volume and open volume.
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Table 8-3: Estimated Parameters
Parameters Description
Time to Full/Empty Tank Estimated number of days, hours and minutes until full/

empty tank.
Time to Close Gauge Estimated number of days, hours and minutes until the

transfer is completed.
Full/Empty Tank Date Estimated date (YY-MM-DD, hh:mm:ss) when the tank is full/

empty.
Close Gauge Date Estimated date (YY-MM-DD, hh:mm:ss) when the tank

transfer is completed.

Related information
Inventory parameters

8.3.4  Viewing transfer data
You can create your own group windows to view transfer data. For transfer data the
Transfer parameter can be added to a group window and shown as:
• Transfer Volume
• Time to Close
• Close Date
• Time to Full/Empty
Modified windows will be available in the View → Group menu.
Related information
Modifying group views

Reference Manual Tank calculators
00809-0200-5110 March 2024

Rosemount TankMaster 173



8.4  Tank settling calculator
The Tank Settling Setup window is used to manually set up and enable the input
parameters for a product transfer.
Procedure

1. Select menu option Setup → Tank Setup → Tank Settling Calculation.

2. Enter desired values for flow rate threshold:
Parameter Description
Disabled Check this box to disable the settling calculation.
Open Gauge Flow rate limit for opening gauge. The settling calculation is

started when the current flow rate (absolute) value is greater
then the open gauge limit.

Close Gauge Flow rate limit for closing gauge. The settling date will be
calculated when the current flow rate (absolute) value is
smaller then the close gauge limit.

3. Click OK to close the Tank Settling Setup window.
Related information
Create a product table

8.4.1  Settling calculation output

Table 8-4: Settling Calculation Output Parameters
Output Parameters Description
Settling State Defines the tank as either Settled or Not Settled. The tank is

considered to be settled when a certain time has elapsed since
the last movement in the tank. This calculation is based on the
Settling Data in the product table.

Tank Settled The calculated Settling Date, presented as YY-MM-DD, hh:mm:ss.
The calculation is performed after a transfer or significant
movement in the tank is observed. This calculation is based on
the Settling Data in the product table.
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Table 8-4: Settling Calculation Output Parameters (continued)
Output Parameters Description
Open Gauge The Open Gauge Date, is when the current flow rate passed the

Open Gauge Limit.
Close Gauge The Close Gauge Date, is when the current flow rate passed the

Close Gauge Limit.

8.4.2  Viewing settling data
You can create your own group windows for viewing settling data. The Settling parameter
can be added to a group window and shown as:
• Settling Status
• Settling Date
Modified windows will be available in the View  → Group menu.
Related information
Modifying group views
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9  Customizing the layout
You can create customized menus, windows and tool bars. This enables you to add a menu
item to the Tools menu for easy access to a program, such as TankMaster WinSetup, or
design windows showing specific parameters.

9.1  Add an item to the Tools menu
This is a description of how to add items to the Tools menu.
Procedure

1. Select menu option Tools → Customize.

2. In the Customize window, click Add.

3. In the Menu Text field, type the name of the item as it will appear in the Tools menu.
4. In the Command field, type the name of the application that will be the new menu

item.
5. In the Arguments field type any argument to be added to the command line. This is

optional and can be left blank.
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6. In the Initial Directory field type the path to the folder where the application is
located.

7. Click OK.
8. Open the Tools menu and check that the new menu option is available.

9. Click the new menu option to verify that the application starts.
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9.2  Create a customizable window
This is a description of how to create a customizable window in TankMaster WinOpi. Once it
is created you may modify it to fit your requirements.
There are five default options available that you can edit to create a customizable window.
You may also create an entirely new window.
Procedure

1. Select menu option Tools → Options and select the Custom Views tab.

2. Select a view to edit, for example Tank &View, and click Copy.

3. Double-click the Name field and rename your customized view.
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4. Enter a new name and click OK.

The new name appears in the Name column.

9.2.1  Custom views
If Type is set to Tank View, the new window is available in menu options:
View>Tank if Menu is set to View
Entry> if Menu is set to Entry

If Type is set to Specific, the new window is available in menu options:
View>Specific if Menu is set to View
Entry> if Menu is set to Entry

Example
In this example, the custom window is available in two locations:

1. View > Tank > My Tank View.

2. Custom > My Tank View.
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9.3  Edit customizable window
A customizable window is available in the View menu. For TankMaster WinOpi a
customizable window may also be available in the Entry menu, depending on the menu
option chosen when creating the window.
The following description is an example of how to modify the design and appearance of a
customizable window.
Procedure

1. Select a tank in the TankMaster workspace and open a customizable window.
Note
Only windows which have been created as Custom Views can be edited. The Edit
Tools feature is not available for standard windows.

2. Press Ctrl+E when the customizable window is active to open the Edit Toolbox:

3. Choose the Selection Tool  in the edit toolbox.

The Selection Tool lets you select items in the customizable window. Then you can
delete or move items such as, for example, HART Input or Analog Input.
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4. To change, for example, Level to Ullage in the tank view, the following actions must
be performed:
• Change the text label from Level to Ullage
• Change the OPC item Current Value (CV) for level to Current Value for ullage
• Change the OPC item Value Unit (VU) for level to Value Unit for ullage
• Change the OPC item Alarm Status (AS) for level to Alarm Status for ullage

5. To change the text label from Level to Ullage, select the Level text block and right
click to open the Property Sheet:

6. In the Property Sheet, double-click on the Caption entry and change Level to Ullage.
7. Close the Property Sheet window to verify the change.
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8. To change the OPC item Current Value (CV) for Level to Current Value (CV) for
Ullage, right click the parameter block to bring up the Property Sheet:

9. In the Property Sheet, select OPCItem in the left-hand column and click the browse
 button.
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10. In the Browse OPC Items window, open TANKS>%tank%>ULL>CV:
a) Click on TANKS and browse to find the name of the tank to be edited. In this

example, TK-06.
b) Select the item ULL.
c) Select the item CV.
d) The Item Name shown should be %tank%.ULL.CV. In this example;

TK-06.ULL.CV.

11. Click OK.
12. Now repeat these steps for the other OPC items in the same way. Select the

corresponding parameter block, right-click to bring up the Property Sheet, and edit
the OPC items:
OPC Item Original Value New Value
Value Unit (VU) %tank%.LL.VU %tank%.ULL.VU
Alarm Status (AS) %tank%.LL.AS %tank%.ULL.AS

13. To exit edit mode, press Ctrl+E.
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14. Open the customized window from the View or Entry menu depending on the
selected option when creating the customizable window, and verify the changes:

15. Optional: The customized window can also be opened from the Custom menu:
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9.4  Create a custom toolbar
The Toolbar contains several buttons which act as shortcuts to actions and tools in
TankMaster™ WinOpi.

Procedure
1. Select menu option Tools → Customize Toolbar.

2. Use the Add button to move toolbar buttons from Available toolbar buttons to
Current toolbar buttons. Then they will appear in the toolbar. Use the Remove
button for buttons you want to remove from the tool bar.
The current selection is shown in the Current toolbar buttons pane. The default
setting shows all buttons.
You may add separators to distinguish between different categories.
Buttons can be re-organized using the Move Up and Move Down buttons.
Note
You may click Reset to return the toolbar to its original configuration.
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10  Servo commands
For tanks configured as servo tanks, it is possible to send commands to a servo gauge
using the Servo Command window.

10.1  Sending a servo command
Prerequisites
To send a servo command, the tank must be configured as a servo tank.
See the Rosemount Tank Gauging System Configuration manual for more information.
Procedure

1. Right-click on a servo tank in the Workspace window. Do one of the following:
• Select Send Servo Command
• Select main menu option Entry → Send Servo Command

The Servo Command window appears.
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2. Click the desired servo command.

When a servo command is sent, the Level /Displacer position field in the Servo
Command window turns orange and the servo state is displayed to the left of the
Level /Displacer position.

3. Click Close.
Note
Before you close the Servo Command window, verify that the servo command
indicator next to Level /Displacer pos field is cleared.

Example
For example, in case the Test command was sent to the gauge, ensure that T (Test)
is not visible before you close the window.

10.1.1  Servo commands
Table 10-1: Servo Commands
Command Description
Freeze (Block) Holds the displacer in its current position.
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Table 10-1: Servo Commands (continued)
Command Description
Park (Lock/Stow) Raises the displacer to the top of the tank.
Measure (Unlock/Unstow) Unlocks the gauge after Freeze or Park, and the displacer

moves to the surface of the product.
Test Raises the displacer and then returns it to the surface of the

product.
Search for water level Initiates a search for the product/water interface.
Quit Water Measurement Quit measuring the water interface and return to measure

the product level.
Measure Density Displacer will be lowered into the product to measure the

product density.
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10.1.2  Tank inventory and active servo command
When a servo command is executed the Level position field in all View Tank windows turns
orange. All Inventory (volume) calculations are disabled as long as the servo command is
active. Only Level and Temperature values are displayed.
Note
When a servo command is active, the Level value does not show the current product level.
The level shown is the current displacer level.

Figure 10-1: Tank Inventory and Active Servo Command
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10.2  Servo states
The table below shows the different servo commands and servo states shown when using
CIU and Rosemount 2460 System Hub.

The Up, Freeze and Down states refer to the displacer movement.
Table 10-2: Servo States
Servo Command Displayed servo state in Windows

Enraf® CIU Rosemount 2460 System Hub
Raise Freeze Lower Raise Freeze Lower

Freeze (Block) - F - - F -
Park (Lock/Stow) P F - P F -
Measure (Unlock/
Unstow)

- - T - - T

Test T - T T - T
Search for water
level

- W ? - - D

Water found - W -
Quit water
measurement

T - - T - -

Measure density R - R R - R

Note
When a servo command is active and the displacer is in movement, the active device
communication is prioritized.

Additional states
Table 10-3: Servo States
Servo state character Displayed servo state

? Reduced accuracy
M Warning
! Unsupported status
T Temperature

OPC and Modbus
The current servo command is viewable via OPC or Modbus from a host computer.
To view the servo command status via OPC, use the TK.xx.LL.SS tag.
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