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TankMaster

NOTICE
Read this manual before working with the product. For personal and system safety, and for optimum product
performance, make sure you thoroughly understand the contents before installing, using, or maintaining this
product.
For equipment service or support needs, contact your local Emerson representative.

Version

This manual is based on the functionality of TankMaster version 6.G1.
For older TankMaster versions all functionality described in this manual may not be available and the Graphical User
Interface (GUI) may look different.

Safety messages

 WARNING
Physical access
Unauthorized personnel may potentially cause significant damage to and/or misconfiguration of end users’
equipment. This could be intentional or unintentional and needs to be protected against.
Physical security is an important part of any security program and fundamental in protecting your system. Restrict
physical access by unauthorized personnel to protect end users’ assets. This is true for all systems used within the
facility.
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1  Introduction
Rosemount TankMaster WinView is a software package with basic inventory capabilities.
TankMaster WinView has limited functionality and is an alternative for smaller tank
terminals. It is a cost-efficient alternative for operational control at smaller tank terminals,
marketing terminals, biofuels, and chemical plants, etc.
This reference manual covers the functionality of the TankMaster WinView software.

1.1  What is Rosemount TankMaster™?
The TankMaster software suite provides you with the tools that you need to configure
and operate the Rosemount Tank Gauging system. The Rosemount Tank Gauging product
portfolio includes a wide range of components for small and large customized tank
gauging systems. The system includes various field devices, such as radar level gauges,
temperature transmitters, and pressure transmitters for complete inventory control. For
detailed descriptions of how to setup various devices refer to the respective reference
manuals.
TankMaster is an Emerson inventory management software package for installation and
configuration of level gauging equipment. It is a complete custody transfer and inventory
software package that provides operator overview for Rosemount Tank Gauging systems.
All calculations are based on current API and ISO standards.
TankMaster provides you with powerful and easy-to-use tools for installation and
configuration of level gauging devices such as radar transmitter gauges (RTGs). The
settings for protocols, devices and tanks can be changed in real time.
The graphical interface gives you a clear overview of installed devices and tanks. For each
tank you can easily see the associated transmitters in the WinSetup application.

1.1.1  Key features
• Monitoring of measured data
• Clear overview of installed tanks and devices (using WinSetup)
• Simple installation using wizards (using WinSetup)
• Open connectivity
• Object-oriented, user-friendly Graphical User Interface (GUI)
TankMaster is designed to be used in a Microsoft® Windows environment, providing easy
access to measurement data from any PC in your network. Measurements and data are
presented in realtime and you can customize views to suit your needs.
Rosemount TankMaster lets you connect via the Ethernet TCP/IP interface. You may also
use TRL2, RS232, or RS485 interfaces if needed. Other communication interfaces, such
as Enraf BPM, are also supported. Rosemount TankMaster is based on the open OPC
standard, allowing you to import data into other systems such as DCS:s, PLC:s, Scada
systems and Microsoft Office programs.

1.1.2  Intended use of product
Rosemount TankMaster serves as a monitoring interface that provides the user with tank
data such as level, temperature, pressure, volume etc. It is a custody transfer and inventory
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software package that supports calculations based on current API and ISO standards. See
End User License Agreement for complete terms and conditions for using the Rosemount
TankMaster software package

1.2  Manual overview
The Rosemount TankMaster WinView Reference Manual provides descriptions of the
TankMaster WinView operator's interface and instructions for operating the Rosemount
Tank Gauging system. The manual includes the following sections:
Chapter Introduction provides a short introduction to Rosemount TankMaster.
Chapter The main window provides an introduction to the basic features of the WinView
operator’s interface. It describes the workspace, menus, and various toolbars.
Chapter Viewing tank data provides a description of various functions for viewing tank data
and inventory data.
Chapter Installing a tank measurement system provides a description of how to setup a
tank management system in TankMaster WinView.
Chapter Alarm handling describes how to setup alarm limits, alarm groups, and how to
view and accept current alarms.
Chapter Reports provides a description of how to create and distribute reports with
inventory information.
Chapter Audit log provides a description of how to enable recording of operations and
actions performed by a TankMaster user.
Chapter Customizing the layout describes how to create customized menus, windows, and
toolbars in TankMaster.
Chapter Servo commands describes how to send commands to servo gauges.
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1.3  Technical documentation
The Rosemount Tank Gauging System includes a wide portfolio of user documentation. For
a complete list, see product pages on Emerson.com/Rosemount.
Reference manuals
• Rosemount Tank Gauging System Configuration Manual (00809-0300-5100)
• Rosemount 2460 System Hub (00809-0100-2460)
• Rosemount 2410 Tank Hub (00809-0100-2410)
• Rosemount 5900S Radar Level Gauge (00809-0100-5900)
• Rosemount 5900C Radar Level Gauge (00809-0100-5901)
• Rosemount 2240S Multi-Input Temperature Transmitter (00809-0100-2240)
• Rosemount 2230 Graphical Field Display (00809-0100-2230)
• Rosemount 5300 Guided Wave Radar (00809-0100-4530)
• Rosemount 5408 Radar Level Transmitter (00809-0300-4408)
• Rosemount 3308 Series Wireless Guided Wave Radar (00809-0100-4308)
• Rosemount Tank Gauging Wireless System (00809-0100-5200)
• Rosemount TankMaster Software Installation Manual (00809-0400-5110)
• Rosemount TankMaster WinOpi (00809-0200-5110)
• Rosemount TankMaster WinSetup (00809-0100-5110)
• Rosemount TankMaster WinView (00809-0300-5110)
• Rosemount 5900 Proof Test with Reference Reflector (00809-0200-5900)
• Rosemount TankMaster Floating Roof Monitoring (00809-0500-5100)
• Rosemount TankMaster Full containment tanks (00809-0500-5110)
• Rosemount TankMaster Network Configuration (303042EN)
• Rosemount 5900 Radar Level Gauge and Rosemount 2410 Tank Hub Safety Manual

Option S (00809-0400-5100)
• Rosemount 5900 Radar Level Gauge and Rosemount 2410 Tank Hub Safety Manual SIL3

(00809-0200-5100)
• Rosemount TankMaster Mobile User Guide (00809-0100-5120)
• Rosemount TankMaster Mobile Installation Manual (00809-0200-5120)
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Product data sheets
• Rosemount Tank Gauging System (00813-0100-5100)
• Rosemount TankMaster Inventory Management Software (00813-0100-5110)
• Rosemount TankMaster Mobile Inventory Management Software (00813-0100-5120)
• Rosemount 2460 System Hub (00813-0100-2460)
• Rosemount 2410 Tank Hub (00813-0100-2410)
• Rosemount 5900S Radar Level Gauge (00813-0100-5900)
• Rosemount 5900C Radar Level Gauge (00813-0100-5901)
• Rosemount 2240S Multi-input Temperature Transmitter (00813-0100-2240)
• Rosemount 565/566/765/614 Temperature and Water Level Sensors (00813-0100-5565)
• Rosemount 2230 Graphical Field Display (00813-0100-2230)
• Rosemount 5300 Level Transmitter (00813-0100-4530)
• Rosemount 5408 Level Transmitter (00813-0100-4408)
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1.3.1  System and user documentation structure
Figure 1-1: Rosemount Tank Gauging System and User Documentation Structure

Rosemount 2240S Reference Manual 
(Document No. 00809-0100-2240)

Rosemount 2230 Reference Manual 
(Document No. 00809-0100-2230)

Rosemount Tank Gauging System Configuration Manual 
(Document No. 00809-0300-5100)

Rosemount TankMaster WinSetup Reference Manual 
(Document No. 00809-0100-5110)
Rosemount TankMaster WinOpi Reference Manual 
(Document No. 00809-0200-5110)

Rosemount TankMaster WinView Reference Manual 
(Document No. 00809-0300-5110)
Rosemount TankMaster Software Installation Manual  
(Document No. 00809-0400-5110)

Rosemount 2460 Reference Manual 
(Document No. 00809-0100-2460)

Rosemount 2410 Reference Manual 
(Document No. 00809-0100-2410)

Rosemount 5900S Reference Manual 
(Document No. 00809-0100-5900)
Rosemount 5900C Reference Manual 
(Document No. 00809-0100-5901)
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1.4  TankMaster software package
The TankMaster software package comprises the following software modules:
• WinOpi
• WinSetup
• WinView
• Batch server
• Tank server
• Master Protocol server
• Slave Protocol server

Figure 1-2: Software Modules

WinOpi
WinOpi is the operator interface to the tank gauging system. It communicates with the
Tank Server and various protocol servers to let the user monitor measured tank data.
WinOpi also provides:
• alarm handling
• automatic report distribution
• historical data sampling
• inventory calculations for volume, observed density and other parameters.
WinSetup
The WinSetup program is a graphical user interface (GUI) for installation, configuration and
maintenance of level gauging devices.
WinView
WinView is a software package with basic inventory capabilities. It communicates with the
Tank Server and the different protocol servers to let the user monitor measured tank data.
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Tank server
The Tank Server communicates with devices via the Master Protocol Server and handles
configuration data for all installed tanks and devices. Parameters stored by the Tank Server
include:
• device names
• configuration data, such as antenna type
• number of connected temperature sensors
• number of connected analog inputs
The Tank Server collects data from connected devices and distributes this information to
the WinView and WinSetup user interface.
Master protocol server
The Master Protocol Server transfers configuration data and measured data between the
Tank Server and connected devices in the tank gauging system. The Master Protocol Server
is able to communicate with various types of devices such as FCUs, the Rosemount 2410
Tank Hub, and the Rosemount 5900S Radar Level Gauge to collect measurements for, for
example, level, temperature and pressure.
Slave protocol
The Slave Protocol Server is used to connect the TankMaster system to a host computer
(DCS system). The Slave Protocol Server exchanges tank data between the Tank Server and
the host computer.
OPC Server with browser
TankMaster uses OPC Data Access 2.0 (OLE for Process Control), an open industry
standard, which eliminates the need for costly customized software integration.
With the OPC server and the browser it is easy to import all custody transfer and inventory
data to other OPC clients such as different DCS:s, PLC:s, Scada systems, or Microsoft
Office® programs.
See the web site for the OPC Foundation for more information: www.opcfoundation.org.
Customized views
You can customize specific views and windows in TankMaster. Existing objects can be
modified or new ones. You could, for example, create a window with an embedded image
of your own plant, to give a realistic overview, and configure the window so that when you
click on a specific tank in the image you can access the corresponding data for that tank.

1.5  Server hardware key
The Server Hardware Key Info window displays the functions enabled by the TankMaster™

hardware key. The information displayed is only valid for the selected server and cannot
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be altered. Also shown is the number of tanks that can be installed according to the
TankMaster license, and the current number of installed tanks.
Procedure

1. Open menu option Tools → View Server HW Key Info.

2. Select the desired server to view hardware key information.
3. Click Close to close the Server Hardware Key Info window.

1.5.1  System type
System Type indicates which mode TankMaster™ is running.
Inventory system
TankMaster runs as a complete custody transfer and inventory software package. All
calculations are based on current API and ISO standards.
WinView system
WinView basic inventory capabilities suitable for smaller plants and terminals.
Demo system
TankMaster is running with full functionality using simulated values.
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1.5.2  Supported functions
The Supported Functions pane in the Server Hardware Key Info window shows available
TankMaster™ options. Selected options indicate that the corresponding function is enabled
with the current hardware key. The table below gives an overview of the available
functions.
Table 1-1: Supported Functions
Function Explanation
Host Access to server via OPC
and serial

Enables OPC and Modbus communications between TankMaster
and SCADA/DCS

Redundancy Enables the use of redundant servers
Network access for TM client
nodes

Enables a TankMaster client to connect to the network and read
tank and device data.

Extended Batch Function(1) Creates MS Access files. Stores closed batches for up to 365
days. Delivery tickets can be recalculated. Tank Transfer Calculator
enabled.

Custody Transfer System Setup mode for the Custody Transfer System.
Custody Transfer Seal Write-protected mode. No possibility to change configuration.
HTG calculation and Setup Hydrostatic Tank Gauging, Enables level and inventory data from

pressure.
Window Customizing Enables the creation of customized windows.
Service Key Personal key for service engineers.
Floating Roof Monitoring Enables TankMaster function for monitoring floating roof tilt and

buoyancy.

(1) For more information and instructions on Batch Handling, please refer to the
TankMaster Batch Handling User Guide

1.5.3  Tanks
The Tanks pane shows the number of licensed tanks and the number of installed tanks.
If the number of installed tanks exceeds the number of licensed tanks, the inventory
calculation option is disabled until a hardware key with a sufficient number of licensed
tanks is installed, or until tanks are uninstalled and the number of installed tanks is equal
to or less than the number of licensed tanks.

1.5.4  TankMaster Network client nodes
The TankMaster Network Client Nodes pane shows the number of licensed nodes and
the number of connected nodes for the selected server. The number of connected nodes
cannot exceed the number of licensed nodes.
If the number of connected nodes is the same as the number of licensed nodes, no more
nodes will be able to connect unless currently connected nodes are first disconnected, or
until a new license key with an increased number of licensed nodes is installed.
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1.6  Illegal characters
The following characters should not be used when naming objects in TankMaster™ as this
may cause undesirable results:
Table 1-2: Illegal Characters in TankMaster
\ Reverse solidus % Percent symbol
/ Solidus < Less-than symbol
? Question mark > Greater-than symbol
* Asterisk { Left curly bracket
[ Left square bracket } Right curly bracket
] Right square bracket ' Apostrophe
| Vertical line " Quotation mark
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2  The main window
All tools and functionality can be accessed from the main menu bar at the top of the
screen. The toolbar directly below the menu contains buttons with shortcuts to the most
common operations.
The main window includes a Workspace which displays tanks, devices, alarm groups and
reports. Right-clicking on objects in the workspace gives access to associated views, tools
and functionality for that object.
A status bar at the bottom of the screen shows alarm and connectivity information.

Figure 2-1: WinView Workspace

A. Menu bar
B. Tool bar
C. Workspace
D. Status bar

The Workspace area can be docked on any side of the main window, or it can be moved
anywhere in the Main window when it is floating.
Docking and floating is toggled by right-clicking in the Workspace area and selecting, or
deselecting Allow Docking.
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2.1  Menus
The menu bar at the top of the main window contains the following menus: File, View,
Entry, Setup, Reports, Tools, and Help.

Figure 2-2: Menu Bar

Some menu options are available by right-clicking on an object in the Workspace window.
Available options varies depending on the type of object that is selected.
Example
The Entry → Tank Entry option in the menu bar can also be found by right-clicking on a
tank icon.

Figure 2-3: Tank View
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2.2  Toolbar
The toolbar contains buttons which act as shortcuts to various tools and functionality.
The toolbar can be toggled on or off from the View menu.

Figure 2-4: Toolbar Options

A. Lets you log off to View Only mode.
B. Lets you log on to TankMaster as Operator, Supervisor or Administrator.
C. Lets you turn the Workspace window On or Off.
D. Opens the Tank View window.
E. Opens the View Group window.
F. Opens the Bargraph Group window.
G. Opens the Tank Movement window.
H. Opens the Alarm Summary window.
I. Opens the Alarm Log window.
J. Lets you accept alarms.

K. Opens the Tools/Options window.
L. About WinView
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2.3  Status bar
The status bar located at the bottom of the TankMaster main window displays information
about connectivity, current alarms and the current protection level status (View Only,
Operator, Supervisor, Administrator, and ChiefAdmin).

Figure 2-5: Status Bar

A. Connection status
B. Alarm status
C. Current user
D. Current protection level
E. Operation status (green=normal operation)
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2.4  Workspace views
The workspace displays an overview of all devices and tanks.

Figure 2-6: Workspace Views

The workspace lets you perform a variety of tasks:
• View tank data.
• View tank operation data.
• View alarm logs and alarm summary.
• Supervise alarms.
• Specify reports.

2.4.1  Viewing tanks
Various tank data can be monitored such as level, temperature as well as alarm logs and
summary of current alarms.
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Figure 2-7: Viewing Tank Data
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2.4.2  Create a tank group
Tank groups can be a convenient way to get a better overview of, for example:
• tanks in a specific geographical area
• tanks containing a certain product
• tanks connected to the same host
A tank may appear in more than one group and a group may contain other groups. There
is no limit on the number of groups that can be created.
Procedure

1. In the Groups view, select menu option Entry → New Group .
2. Type a name for the new tank group and click OK.

3. In the left-hand pane, select a tank or a group to add to the new group and click the
Select button.

4. Repeat for all tanks to be added to this group.
5. Click OK when you have finished adding objects to the new group. The new tank

group will be displayed in the Workspace window.
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2.4.3  Icons
In the Workspace windows various items are represented by the following icons:
Table 2-1: Icons

 Cylindrical tank  Tank group

 Floating roof tank  Plant node

 Spherical tank  Server node

 Horizontal tank Report
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2.5  User management
TankMaster offers a number of protection levels for increased security. These levels are
categorized as User Access Levels and User Access Sub Levels. The User Access Levels are:
• Administrator
• Supervisor
• Operator
• View Only
• ChiefAdmin
Each User Access Level has five sub levels, giving total of 20 unique access levels. The
default user names and passwords for each user type are as follows:
Table 2-2: User Access Levels and Sub Levels
User Level Sub Level Default Password
View VIEW ONLY * view
Operator OPERATOR * oper
Supervisor SUPERVISOR * super
Administrator ADMINISTRATOR * admin
ChiefAdmin ADMINISTRATOR ***** chief

User authentication (log on) is required in order to change settings such as:
• Alarm limits
• Tank Setup
Note
Settings cannot be changed by a user in View mode.
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2.5.1  Log on to TankMaster
Procedure

1. Select File → Log On, or click the Log On button  in the toolbar.
2. Type your user name and password. The password is case sensitive but the user

name is not.

3. Click OK.
Note
If log on is unsuccessful after five consecutive attempts, the user account is
disabled. The user account must be enabled by an Administrator.
The user type and the protection level is displayed in the status bar as well as any
status messages in case there are any.

Figure 2-8: Status Bar

A. User name
B. Protection level
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2.5.2  Manage user accounts
You must be logged on as Administrator in order to add new user accounts, change
settings for an existing user, or to configure user levels and sub levels.
Procedure

1. Log on to TankMaster as an Administrator.
2. Open Tools → Administrative Tools → User Manager.

3. In the User Manager window select a cell in an empty row and click New.

4. Enter a user name.
5. A description of the new user profile is optional.
6. Enter and confirm a password.
7. Next, select the desired Level and Sub Level and click OK.
8. Verify that the new user is displayed in the User Manager window.
9. To make a default user name appear in the Log On dialog, check the box Use first

account with required access level as default. If not selected, the User Name field is
empty when the Log On dialog opens.

10. Click the OK button.
Related information
User management
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2.5.3  Configure a sub level description
TankMaster allows you to change the names for Sub Levels to something more descriptive
than the default settings.
Procedure

1. Open Tools → Administrative Tools → User Manager.
2. In the User Manager window, click the Config Desc button.

3. In the Config Access Sub Levels Description window enter a new description in the
desired field. In the example above, the description of item number 5 of category
Admin Sub Levels is changed from “*****” to “Sub5-admin”.

4. Click OK to close the Config Access Sub Level Description window.

The main window Reference Manual
June 2023 00809-0300-5110

26 Emerson.com/Rosemount



2.5.4  Set required access levels
TankMaster WinView offers the possibility to set unique required access levels for the
following actions:
• Report handling
• Accepting alarms
• Exiting WinView
For example, if you are logged on as an Operator (* * *), you are not allowed to exit
WinView if the required exit level for this action is set to Operator (****) or higher.
To modify required access levels:
Procedure

1. Open Tools → Administrative Tools → Set Required Access Levels.
Note
You must be logged on as an Administrator (* * * * *) to be able to set the required
access levels.

2. Set the required access level for each action and click OK.
Related information
Manage user accounts
Add an item to the Tools menu
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2.5.5  Change protection levels for specific windows
Prerequisites
To be able to change the Protection Level, the user must be logged on as an Administrator
(* * * * *).
To set a Protection Level for a specific window, for example, Alarm Limits:
Procedure

1. Select menu option Entry → Alarm Entry → Alarm Limits to open the Alarm Limits
window.

2. Click the window icon in the upper left corner of the Alarm Limits window.

3. Click on Protection Level in the menu.

4. Select the desired Protection Level and Sub Level from the menus.
5. Click OK.

Now the user must be logged in at the specified protection level, or a higher level, in
order to make any changes to the Alarm Limits window.
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2.5.6  Change password
Procedure

1. Go to Tools → Administrative Tools  → Set Password.

2. Select the Tank Server which is valid for your user account.
If you are already logged on to TankMaster, the current server is already selected
and your user name appears in the User name field.

3. If the workspace is in View Only mode, enter your User name.
4. Enter your old password and the new password.

Note
The password is case sensitive.

5. Confirm the new password and click OK.

2.5.7  Change inactivity timeout
You can set a timeout after which the current user is automatically logged off after a period
of inactivity.
The timeout period is reset each time the user performs an activity that requires an access
level check, for example, setting a new alarm limit or logging on. You must be logged on as
an Administrator in order to change the inactivity timeout.
Procedure

1. Go to Tools → Administrative Tools  → Set Inactivity Timeout.

2. Enter the number of minutes to use for the inactivity timeout.
3. Click OK.
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2.5.8  Program security options
TankMaster offers security options which can be used to restrict user privileges to run
certain Windows programs or perform specific actions.
Table 2-3: TankMaster Operator's Interface
Security option Description
Run application maximized The program will always run with the application window

maximized. The minimize and restore buttons in the upper-right
corner of the window are disabled.

Disable possibility to switch to
other programs

Ignores keyboard commands such as Alt+Tab, Alt+Esc, Ctrl+Esc,
etc.

Table 2-4: TankMaster Administrator and Windows Security
Security option Description
Run TankMaster Administrator
as Shell

Allows the TankMaster Administrator program to run as a
Windows shell instead of the standard Windows Explorer shell.
When this option is selected, all other security options in
the TankMaster Administrator and Windows Security group are
automatically set. You may need to restart your PC.

Disable Task Manager Prevents the user from starting Task Manager (Taskmgr.exe).
Disable Lock Workstation Prevents the user from locking the system (WIN+L). When

Windows is locked, the desktop is hidden and the system cannot
be used. Only the user who locked the system or the system
administrator can unlock it.

Disable Change Password Disables the Change Password button on the Windows Security
dialog box (Ctrl+Alt+Del).

Disable Registry Editor Disables the Windows registry editors, Regedt32.exe and
Regedit.exe. If this option is selected and the user attempts to
start a registry editor, a message appears explaining that a system
policy prevents the action.

Disable Windows Shutdown/
Restart

Prevents the user from shutting down or restarting Windows. This
option removes the Shut Down option from the Start menu and
disables the Shut Down button on the Windows Security dialog
(Ctrl+Alt+Del). It does not prevent the user from running programs
that may shut down Windows.

Disable Command Prompt Prevents the user from running the interactive command prompt,
Cmd.exe. This option also determines whether batch files (.cmd
and.bat) can be run on the computer.

Disable Autorun/Autoplay Disables the Autoplay feature on all drives.
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To set program security options
Procedure

1. Open Tools → Administrative Tools → Security Options.

2. Select the desired security options and click OK to apply.
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3  Viewing tank data

3.1  Measured values
Rosemount TankMaster™ offers a number of options to view measured and calculated
inventory data for individual tanks and tank groups. Windows can be created or modified
with standard and manual parameters to show customized views.

3.1.1  Viewing single tank data
This is a description of how to view measurement data for a single tank.
Procedure

1. Select a tank in the Workspace window.
2. Right-click and select the desired view, for example View Tank → Tank View , or from

the View menu select Tank → Tank View .
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Example
The Tank View window shows data from the Rosemount 2410 Tank Hub, the Rosemount
5900S Radar Level Gauge, and the Rosemount 2240S Multi-Input Temperature Transmitter
for a single tank. For each item, the value, measurement unit, and status is displayed.

Figure 3-1: Tank View

A bar graph shows the product level as well as the amount of free water at the bottom
of the tank. Flow rates exceeding a certain threshold are indicated by an arrow on the left
side of the bar graph.
Depending on the actual flow rate value one of two arrow types appears. The thresholds
which control the arrow indication can be changed.
Temperature sensors immersed in a product are marked with a “*” symbol. The
temperature sensors can be connected to a Rosemount 2240S Multi-input Temperature
Transmitter or other supported devices.
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3.1.2  Viewing tank groups
Data for a group of tanks can be viewed in various windows. The windows can display
values for Level, Level Status, Level Rate, Average Temperature and other parameters for
all tanks in a group.
Procedure

1. Select a tank group in the Workspace window.
2. Do one of the following:

• Right-click and select View Group
• Open menu option View → Group

3. Select the desired View Group option:
• View Group
• Bar graph Group
• Tank Movement

Example
A tank which is currently being filled or emptied is indicated with arrows as illustrated
in Figure 3-2. There are two different arrow sizes. By setting appropriate thresholds, the
arrows can be used to indicate level rates within different ranges according to a predefined
threshold.

Figure 3-2: Group View

To specify level rate thresholds, open Tools  → Options and select the Tank Movement tab.
Tank movements can be highlighted with different colors for flow rates and level rates.
Related information
Tank movement
Editing group view templates
Modifying group views
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3.1.3  Viewing bar graph groups
Data for a tank group can be presented in bar graph format.
Procedure

1. Select a tank group in the Workspace window.
2. Do one of the following:

• Right-click and select View Group
• Open menu option View → Group

3. Select Bar Graph Group.
Example
In the Bar Graph Group window each tank in a group is represented by a bar graph
showing Product Level and Free Water Level for each tank. It also indicates level changes
by showing an arrow next to the bar graph.

Figure 3-3: Bar Graph Group

The Bar Graph Group window can be modified in the same way as the Group View window.
Related information
Tank movement
Editing group view templates
Modifying group views
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3.1.4  Editing group view templates
To change the appearance and contents of group views, do one of the following:
• open menu option Tools → Options and select the Group Templates tab,
• from an open group view window, select Edit Group Template from the shortcut menu

to access editing options.
Tank comment
A comment can be added to a tank and made visible for group views.
Sorting
Contents in a group view can be sorted by clicking a column title cell.
Related information
Modifying group views
Shortcut menu
Tank comment
Sorting content in a product table
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3.1.5  Shortcut menu
For quick access to other groups and tank views in any group view window, right-click on a
tank for a shortcut menu.
The shortcut menu gives you quick access to other windows. For example, the Observed
Inventory window may be opened by selecting View Group → Observed Inventory.

Figure 3-4: Shortcut Menu in Group View Window

Related information
Modifying group views

Viewing tank data Reference Manual
June 2023 00809-0300-5110

38 Emerson.com/Rosemount



3.2  Tank operation
To view data for a specific tank do the following:
Procedure

1. Select the desired tank in the TankMaster Workspace window.
2. Click the right mouse button and select View Tank → Tank Operation, or select

menu option View → Tank → Tank Operation.
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3.3  Tank movement
The Tank Movement window shows the direction of the current product surface
movement, including Level Rate and Flow Rate.
Procedure

1. In the Workspace window, select the desired tank.
2. Do one of the following:

• right-click a tank group and select View Group → Tank Movement
• in View menu, select Group → Tank Movement.

3.3.1  Movement indication
An arrow points in the direction of surface movement. A thick arrow indicates a high
flow rate, or level rate. A thin arrow indicates a low flow rate, or level rate. There is no
movement indication for level rates below set thresholds.

3.3.2  Limits
A limit can be set in order to exclude tanks with flow rates below a specified value. Tanks
are automatically added to and removed from the Tank Movement window depending on
flow rates.
Related information
Flow rate thresholds

3.3.3  Color highlighting
Tank movements can be highlighted using color coding to improve visibility.
Related information
Enable color highlight
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3.3.4  Custom appearance
The contents of the Tank Movement window can be modified to show specific parameters.
Procedure

1. Open the Tools menu.
2. Select Options.
3. Select the Group Template tab.

Related information
Modifying group views

3.3.5  Level rate thresholds
There are two thresholds for Level Rate, Major and Minor.
Minor Level rates above this value are indicated with a thin arrow in the Tank Movement

window.
Major Level rates above this value are indicated with a thick arrow in the Tank Movement

window.

Note
The Level Rate threshold settings apply to all windows which indicate product surface
movement, such as View Group, and Tank View.

Procedure
1. Go to Tools → Options.
2. Select the Tank Movement tab.
3. Enter values for the major and minor Level Rate Thresholds.

4. Click Apply to activate the new threshold values.
5. Click OK to close the Options window

3.3.6  Flow rate thresholds
Flow Rate Thresholds can be set to indicate the flow rate state.
Minor Flow rates above this value are indicated with a thin arrow in the Tank Movement

window.
Major Flow rates above this value are indicated with a thick arrow in the Tank Movement

window.

Note
The Flow Rate threshold settings apply to all windows which indicate product surface
movement, such as View Group, and Tank View.
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Common flow rate thresholds
Procedure

1. Go to Tools → Options.
2. Select the Tank Movement tab.
3. Select Use common threshold for each tank.

4. Enter the desired threshold values.
Note
Tanks with Flow Rates below the Minor threshold value will not appear in the Tank
Movement window.

5. Click Apply, and OK to close the Options window.

3.3.7  Enable color highlight
Color coding and highlighting for tank movement can be edited.
Procedure

1. In the Tools menu, select Options.
2. Select the Group Templates tab.
3. Select the Tank Movement group template and click the Edit button.
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4. Select the Highlight tanks in movement check box.

5. Click OK.
Related information
Color settings for tank movement
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3.4  Modifying group views
The appearance of a group view can be changed by editing the appropriate template.
Procedure

1. In the Tools menu, click Options.
2. Select the Group Templates tab.

3. Select one of the following options:
• To modify an existing group template, select the view and click Edit.
• To duplicate an existing template, click the Clone button. This is a convenient

way to create a new template by simply modifying an existing one.
• To create a new group template, click the New button.
• To remove an existing template, click the Delete button.

3.4.1  Example of how to create new group views
This example illustrates how to create a new group template.
Procedure

1. Select menu option Tools → Options.
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2. Select the Group Templates tab and click the New button.

The Edit Group Template window appears which lets you specify a new group view:

3. In the Menu Item field, enter a group name as it will appear in the View → Group
menu.

4. In the View Title field, type the name that will be displayed in the title bar of the new
group view.

5. Next, select parameters in Available Parameters pane and click the Select button.
The parameters are added to the Selected Parameters pane.
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6. In the Show As column, for each parameter choose the desired format for data
presentation.
The Show As format determines how the parameter is presented in the view
window.

Selected Parameters Show As Description
MI Spot temperature in liquid
CV Current Value
VU Value Unit
AS Alarm Status

7. The parameters can also be sorted in the table view as ascending or descending
from the Sort Order column.

8. Finally, in the View Type list, select if tanks will be presented row by row, column by
column, or in both rows and columns.

9. Click the OK button.
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10. To open the new group view, do one of the following:
• Right-click a tank group and select View Group  → [Menu Item]
• Select a tank group and in the main menu, go to View → Group → [Menu Item]
In this example, [Menu Item] is View Temp Sensors.

Note
The Highlight tanks in movement option is not enabled in this example.

Related information
Enable color highlight
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3.4.2  Changing group view appearance
Font and text alignment can be modified for cells and headers in windows where data is
presented in tables.
Procedure

1. Select menu option Tools → Options and select the Group Templates tab.

2. Under Common Group View Settings, click the Change button.
The Group View Appearance window opens:

3. Select the appropriate Change font button to select desired fonts for table headers
and cells.

4. Select desired alignment.
A preview of the formatting changes is shown in the Example box.
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5. Click OK to close the Group Views Appearance window
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3.5  Color settings
Using colors can be a useful way highlight and distinguish information. Colors can be
specified for many areas, including bar graphs, backgrounds in input fields, manually
entered values, alarms, and products in the Product Table.
Procedure

1. Open the Tools menu.
2. Select Options.
3. Select the Colors tab.

4. Select an item from the list.
5. Click the Change button to open the Color palette:
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6. Choose a color from the palette, or click the Define Custom Colors button to expand
the Color window. This allows you to add a custom color:

7. Click OK when the color selection is done.
Related information
Product color
Create a product table
Product color settings
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3.5.1  Product color settings
In the Product Table, colors can be used to represent specific products. These colors are
then used in bar graphs to show the current product level.
There are two different options for product colors in bar graphs:
• Option 1: the same color is used for all products.
• Option 2: Each product is associated with a color according to the Product Table setup.
Procedure

1. In the Tools menu, select Options.
2. Select the Colors tab.
3. Under Items, select Bar Graph Product, and select the Use Product Color check box.

4. Scroll down the Items list and select a product to edit (Product1 in this example).

Viewing tank data Reference Manual
June 2023 00809-0300-5110

52 Emerson.com/Rosemount



5. Click the Change button to define a product color.

6. Select the desired color and click the OK button. Now the new product color
appears.

7. Repeat this procedure for the desired products.
8. In the Tools Options Colors window, click the OK button when you are finished.

Related information
Color settings
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3.5.2  Color settings for tank movement
Items Major Moving Up, Major Moving Down, Minor Moving Up, and Minor Moving Down
can be modified to change the colors for highlighting tank movement.
Procedure

1. Open menu option Tools → Options and select the Color tab.
2. Select one of the following items:

• Major Moving Up
• Major Moving Down
• Minor Moving Up
• Minor Moving Down

3. Click Change to edit the color settings for the selected item.
4. Click Apply and then OK to close the Options window.

Postrequisites
Ensure that color highlighting for tank movement is enabled.
Related information
Enable color highlight
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4  Installing a tank measurement
system

4.1  Installation procedure
Setting up a tank measurement system for level measurement and inventory calculation
includes a few basic steps.
Procedure

1. System setup.
Specify measurement units and other system parameters.

2. Set up a Tank Capacity Table.
Specify the geometry of the tank for volume calculation by setting up a tank capacity
table. This is commonly referred to as a strapping table.

3. Create a product table.
Specify the products to be used in the tank.

4. Configure tank inventory parameters.
Specify parameters for inventory calculation.

5. Configure alarm limits.
Specify alarm limits for level, volume, and data from external sensors.

Related information
System setup
Setting up a tank capacity table
Create a product table
Inventory parameters
Alarm handling
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4.2  Setting up a tank capacity table
The geometry of a tank is defined in a strapping table called a Tank Capacity Table (TCT). It
is used to convert a product level to the corresponding volume. The values can be entered
either as absolute levels, as relative levels, or as pairs of level and volume.
There are three different types of tank capacity tables:
• Raw
• Northern (relative levels; mostly used in Sweden and Finland)
• International (absolute levels)
You can specify a default TCT type that will automatically be used for new tanks in Setup → 
System.
You can change the TCT type for a tank from the default setting in Setup → Tank Setup → 
Tank Capacity.
Note
When specifying a TCT using either the Northern or International method, it is extremely
important that the resulting level-volume curve is continuous. The calculated volume at
the top of one interval must correspond exactly to the volume at the bottom of the next
interval.
Both the relative and the absolute method of entering TCT data require four parameters
at each strapping point. The Northern and the International methods do not use the same
Base Volume and Tank Area Coefficient.
Table 4-1: Strapping Table Parameters
Parameter Description
From product level at the beginning of the interval
To product level at the end of the interval
Volume Base Volume
Area Tank Area Coefficient
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Figure 4-1: Volume Calculations Based on Strapping Table
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A. Level at end of interval
B. Measured level
C. Level at beginning of interval
D. Calculated volume
E. Base volume

4.2.1  Using the Raw method
When using the Raw method, data is entered in pairs of Level and Volume values. For each
level value the corresponding standard volume must be entered.
The following table shows an example of pairs of Level and Volume values as input for
TankMaster when using TCT type Raw.
Table 4-2: Example of TCT Type Raw Table
Level Volume
1.53 10 105
2.72 22 309
3.18 29 934
4.78 41 249
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4.2.2  Using the International method
When using the International method, the Base Volume is the volume at the beginning
of the interval. The Tank Area Coefficient describes how the volume varies with the level
within the interval.

Figure 4-2: International Method
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Volume
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A. Volume at end of interval
B. Level at beginning of interval (From)
C. Level at end of interval (To)

With the International Method, the desired volume is calculated as:
Desired Volume = Vo + Area × (Level - Lo)
Table 4-3: International Method Parameters
Parameter Description
Desired Volume Volume at the measured level
Level Measured level
Lo Level at the beginning of the interval
Vo Base volume
Area Tank Area Coefficient. This is not the surface area of the product,

although the measurement unit of this parameter is the same as
for a surface area (volume/length).
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4.2.3  Using the Northern method
The Northern method is based on the fact that within an interval, there is an approximately
linear relationship between level and volume, as illustrated below.

Figure 4-3: Northern Method
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A. Volume at beginning of interval
B. Level at beginning of interval (From)
C. Volume at end of interval
D. Level at end of interval (To)

The Base Volume corresponds to the volume at Level = 0, given by extrapolation of the
linear level - volume relationship.
The Tank Area Coefficient describes how the volume varies with the level within the
interval based on this Base Volume. The volume is calculated as:
Desired Volume = Vo + Area × Level
Table 4-4: Northern Method Parameters
Parameter Description
Desired Volume Volume at the measured level
Level Measured level
Vo Base volume
Area Tank Area Coefficient. This is not the surface area of the product,

although the measurement unit of this parameter is the same as
for a surface area (volume/length).

4.2.4  Create a tank capacity table
TankMaster allows you to specify a strapping table to be used for volume calculations.
• The geometry of the tank is defined in the TCT
• The TCT is used to convert a product level to the corresponding volume
• The values can be entered either as pairs of level and volume, either as absolute, or

relative levels depending on the type of TCT that is used
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• The TCT is stored as pairs of level and volume irrespective of the way the values are
entered into the system

Procedure
1. In the TankMaster workspace, right-click on the desired tank and select Tank Setup 

→ Tank Capacity, or open menu option Setup → Tank Setup → Tank Capacity.

2. To change the TCT type for the current tank, or to specify the number of strapping
points, click the Change button.

3. Click OK to close the TCT Table window and apply any changes.
Note
Changing the TCT or number of points in the TCT Table window only affects the
current tank. The default TCT type is specified in the System Setup window (Setup 
→ System) and is automatically chosen when strapping tables are created for new
tanks.

4. In the Units pane, select measurement units for Level, Volume and Temperature.
These units are also specified in the System Setup window as default for all tanks,
but can be changed here for the current tank.

5. In the Volume section, enter a Maximum Volume and a Minimum Volume for the
current tank. The Minimum Volume is equal to the volume between the outlet and
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the bottom of the tank. Tank Volume refers to the total volume of the tank. This
parameter is used for LPG tanks in order to calculate Equivalent Liquid Volume and
Vapor Mass.

6. The Sump Volume is what is left when the tank is emptied to the Zero Level. This
value may be included in the strapping table instead of the Sump Volume field. In
this case, the Base Volume at the Zero Level is equal to the Sump Volume.
Note
Ensure that the Sump Volume is not specified in both the Sump Volume parameter
and the strapping table.

A

B

C

A. Zero Level
B. Sump
C. Minimum volume

7. In the Shell pane, specify if the tank is insulated or not, enter the Base Temperature
and a Steel Expansion Coefficient:
• The Base Temperature is the temperature at which the strapping table is

specified
• Temperatures other than the Base Temperature are taken into account and

compensated for when performing volume calculations.
• If a tank is insulated the ambient temperature does not have any influence on

the inventory calculations.
• The Steel Expansion Coefficient is used in the calculations of Gross Observed

Volume (GOV) in order to correct for the thermal expansion of the tank wall. The
default value, 0.0000112/°C, is used for mild carbon steel.

8. Enter numerical values for the strapping table points.
9. Click OK to store the values and close the window.

Related information
Inventory parameters
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4.3  Create a product table
Product specific information is stored in a Product Table. It is possible to edit the default
selection of products and also add new products to the table.
Procedure

1. Select menu option Setup → Product Table.

2. Select a Product Table source, i.e. a server where the product table is stored.
3. The content in the product table can be sorted.
4. To edit an item In the Product Table, double-click a cell, or select a cell and click the

Edit Product button. The Edit Product No <x> window appears.

5. Enter the appropriate product data in the Edit Product window.
6. Repeat the appropriate steps to add new, or edit existing products in the Product

Table.
7. Click OK when finished.

Related information
Color settings
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Sorting content in a product table
System setup

4.3.1  Product color
Enter a number that corresponds to a product color. This requires that a set of product
colors has already been defined.
Related information
Color settings

4.3.2  Sorting content in a product table
The Product Table can be sorted for a clear overview.
Procedure

1. To sort the table rows in ascending order for a field, click the title cell for that
column.

2. Click the cell again to sort the cells in descending order.

3. Right click on the selected column title to reset sorting.
4. Repeat this procedure until the table is sorted appropriately for your needs.

Reference Manual Installing a tank measurement system
00809-0300-5110 June 2023

Rosemount TankMaster 63



4.4  Inventory parameters
Rosemount TankMaster ™calculates inventory parameters based on input data available for
the current tank.
The following figure illustrates how TankMaster converts a measured product level with
given tank parameters to a standardized volume:

Figure 4-4: Standard Volumes

Free Water 
Volume

Level

Tank Capacity 
Table

Total Observed 
Volume

Mass

The following figure outlines the relationship between tank parameters and physical
quantities. The main parameters are shown on the left-hand side, and input parameters
on the right-hand side of the flow chart:

Installing a tank measurement system Reference Manual
June 2023 00809-0300-5110

64 Emerson.com/Rosemount



Figure 4-5: Tank Parameters Flow Chart

Table 4-5: Inventory Parameters
Parameter Description
Total Observed Volume, TOV Calculated from strapping tables. It is the total volume at

the observed temperature of the product.
Mass is the TOV multiplied by the Obs Density
Maximum Volume The volume that corresponds to the maximum product

level.
Available Room, AVRM Calculated by substracting the TOV from the Maximum

Volume of the tank.
Sump volume The volume that is left in a tank when emptied down to the

Zero level.
Minimum Volume Volume between the outlet and the bottom of the tank.
Pumpable Volume TOV minus the Minimum Volume.
Flow Rate The Flow Rate is calculated using the level rate and the

strapping tables.
Free Water Level, (FWL) Manually entered or measured by a water interface sensor.
Free Water Volume, (FWV) Calculated on the basis of the FWL and the TCT.

Related information
Create a tank capacity table
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5  Alarm handling
Rosemount TankMaster lets you manage various types of alarms. You can set alarm levels
as well as hysteresis and delay times for various parameters, such as Level, temperatures,
and analog input signals.
An alarm status can be one of the following:
• HiHi
• High
• LoLo
• Low
• Leak Hi
• Leak Lo
• CFail (communication failure)
• Normal
• Error
The data that TankMaster receives from field devices are continuously checked against
the alarm limits. Alarm limits, delay times, hysteresis and leak alarms are defined by the
operator in the password protected Alarm Limits window.
If a value exceeds an alarm limit, the corresponding alarm will be activated after a certain
delay as given by the Delay Time setting. The alarm status will flash bright red in, for
example, the Alarm Summary window, or the Tank Inventory window until the operator
accepts the alarm.
Even if conditions have returned to normal, the alarm status is not reset until the operator
has accepted the alarm. In order to accept and disable an alarm, the parameter that
caused the alarm must pass below the alarm limit and satisfy the Alarm Hysteresis value.
When these conditions are satisfied, the alarm reset is delayed an amount of time given by
the Delay Time.
When an alarm is accepted, the alarm status turns dark red by default. Alarm colors can be
changed.
Related information
Alarm colors
Alarm status
Color settings

5.1  Leak alarms
The level leak alarm monitors product level changes.
When the Leak Limit is set the current tank level will be stored. The WinView program
monitors the difference between the actual level and the stored level, and activates the
Leak Alarm when the difference becomes greater than the Leak Limit programmed by the
operator.
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5.2  Sensor failure
In the event of a sensor failure, for example if a temperature sensor malfunctions, then the
sensor status Error is displayed.

5.3  Communication failure
If a Rosemount 2460 System Hub, or a Rosemount 2410 Tank Hub does not respond after
three queries, the alarm status of the tank parameters are set to Communication Failure
(CFail) and the following error message displayed in the status bar: <Tank Name> CFail.
All parameters associated with a unit that do not respond inherit the CFail status in this
case. Even though the status of the alarm can be shown for a number of parameters, it is
only regarded as one alarm, and therefore only needs to be accepted once for each unit.

5.4  Alarm status priority
Each parameter status has a certain priority, as shown below. If, for example a CFail alarm
is activated for a specific tank, the alarm status Error will not be shown for that tank as long
as the CFail status is valid.
If the parameter is disconnected then Discon will replace CFail as the parameter status.
Alarms are given the following order of priority:

1. Disconnect (Discon)
2. Communication Failure (CFail)
3. Error
4. Blocked
5. HiHi, LoLo
6. Leak Alarm Hi, Leak Alarm Lo
7. High, Low

Note
Priorities 1 to 4 are only valid for automatically measured values, not for manual values.

Related information
Disconnecting alarms
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5.5  Setting alarm limits
An Operator can set up alarm limits for various parameters in the Alarm Limits window,
including:
• Level and level rate
• Average temperature and vapor temperature
• Analog inputs
• Vapor pressure and liquid pressure

5.5.1  Alarm limits
The Alarm Limits window lets you specify limits for a large number of parameters.
Procedure

1. In the TankMaster workspace right-click on a tank and choose Alarm Entry → Alarm
Limits, or select the same option in the Entry menu.

2. Specify the desired alarm limits.
Leak Once a Leak alarm is activated, the alarm will trigger in case the level

value drops the amount specified in the Leak entry field.
Leak alarm for Volume can be set in the Volume Alarm Limits
window. A volume leak alarm monitors changes of the Net Standard
Volume (NSV).
Leak alarms can be enabled and disabled for single tanks as well as
for entire tank groups.

Hi, HiHi, Lo,
and LoLo

These alarms can be set for Level, Level Rate, and various sensors.

Hysteresis Prevents alarms from activating due to turbulent surface level
conditions.
For example, the Level Hi limit is set to 10 m and the hysteresis to 0.1
m. The alarm is activated when the level exceeds 10 m and remains
active until the level drops below 9.9 m. In this case, small waves on
the liquid surface do not influence the Hi alarm.
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For example: the Level Rate Hi limit is set to 4,5 m/h and the
hysteresis to 0.1 m/h. The alarm is activated when the level exceeds
4,5 m/h. It remains active until the level rate drops below 4,4 m/h. In
this case fluctuations in the flow do not influence the Hi alarm.

Delay A delay time can be used to prevent temporary changes of the
measurement value from activating the alarm. This value specifies
the delay in seconds.

3. When finished, click OK to activate the current settings and close the Alarm Limits
window.

Related information
Volume alarm limits
Disconnecting alarms
Enable and disable leak alarms
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5.6  Alarm summary
TankMaster makes it easy to view a summary of alarm details for a particular group of
tanks, or for all tanks in the system.
Procedure
To view a summary of current alarms for a group, do one of the following:
• in the Workspace, select a tank group and select menu option View Alarms → Alarm

Summary
• right-click on a group and select View Alarms → Alarm Summary
• click the Alarms Summary button in the toolbar

Figure 5-1: Alarm Summary

5.6.1  View alarm summary
The Alarm Summary window shows details for active alarms including related tanks and
parameters. The time when an alarm was activated is shown in the On column, and the
time it was accepted is shown in the Accepted column.
An alarm is displayed until it is accepted and the cause of the alarm is resolved.
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Figure 5-2: Alarm Summary

Note
A Leak Lo/Hi alarm is not removed until it has been disconnected in the Alarm Disconnect
window.

Related information
Disconnecting alarms

5.7  Alarm log
TankMaster has an alarm log which allows you to view the alarm history for a a tank or
a group of tanks. The Alarm Log window shows a list of logged alarms as well as other
important information such as tank name, time and date, and the operator who accepted
the alarm.
Procedure
To view the Alarm Log for a selected group, do one of the following:
• Right-click on a tank group in the TankMaster workspace and select View Alarms → 

Alarm Log.
• From the View menu, choose View Alarms → Alarm Log

• Click the Alarm Log button  in the toolbar

Similar to the Alarm Summary, the Alarm Log window displays the following information
for each alarm:
• Alarm type (High, Low etc.).
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• Tank name.
• Parameter that activated the alarm.
• Parameter value when the alarm was activated.
• Alarm status.
• Time and date when the alarm was activated and accepted.
• Operator who accepted the alarm.

5.7.1  Alarm status
The following values can be applied to the Status column:
• When an alarm is activated, the status column displays On
• When the alarm is accepted, the status changes to Acc
If an alarm is unaccepted, the status will continue be displayed as On, even if the value that
activated the alarm returns to normal.
The alarm status is changed to Off when the corresponding alarm has been accepted and
the value that activated the alarm returns to within the accepted range.
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5.7.2  Filter settings
The Alarm Log can be filtered by tanks and time period.
Procedure

1. In the Alarm Log window, click the Filter button:

Note
In case a single tank is shown in the Alarm Log window, only that particular tank will
appear in the Selected Tanks pane when the Filter button is pressed. All tanks will
appear in the Selected Tanks pane if All Tanks optoins is selected in the Alarm Log
window.

2. In the Alarm Log Filter Settings window, specify the desired time period:
a) Choose All dates to view every alarm that has been logged for the selected

tanks.
b) Select Date between to view alarms within a specific period.
c) Click Not older than to view all alarms from a certain point until the present

time.

3. To filter tanks that the alarm log will apply to, select a tank in the Available Tanks
pane and click the Add button. Tanks can be removed from the Selected Tanks pane
by clicking the Remove button.

4. Optional: Select the Save settings as default check box in case you would like to use
the selected settings as default for the Alarm Log.

5. Click OK .
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Related information
Viewing the alarm history log

5.7.3  Saving the alarm log to file
The Alarm Log can be saved to file and the log file can be viewed in the Alarm History
window.
Note
The Filter option in the Alarm History window can be used to reduce the displayed number
of days. This will not affect the actual number of days stored in the log file.

Procedure
1. From the Tools menu, choose Options.
2. Select the Log Setup tab:

3. Select the Log to File option.
4. Set the maximum log file size by specifying the number of records or the number of

days to be logged:
• 10 days will save all alarm events from the previous 10 days up until the current

time.
• 1000 records will save 1000 alarm events to the alarm log.

5. Click Apply to save the alarm log file settings.
6. Click OK to close the program options.

Related information
Viewing the alarm history log
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5.7.4  Viewing the alarm history log
If the Alarm Log is saved to file, it can be viewed in the Alarm History window.
Procedure

1. To view the alarm log history for a tank group, do one of the following:
• Right-click on a tank group in the TankMaster workspace and select View Alarms 

→ Alarm History Log.
• From the View menu, select Alarms → Alarm History Log

2. Click the Filter button to specify which tanks to show in the History Log or to change
time periods.

3. Click Print to print the alarm history log.
4. Click the Close button to close the Alarm History window.

Related information
Saving the alarm log to file
Filter settings
Alarm printer settings

5.7.5  Alarm printer settings
Alarms can be printed directly to a printer. A print out of an alarm is executed when the
alarm is activated.
Procedure

1. From the Tools menu choose Options.
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2. Select the Log Setup tab:

3. Select the Log to Printer check box.
4. Select the appropriate Printer Port option for the designated printer.
5. Enter a value for the maximum number of lines to be per printed page.
6. Enter a value for the maximum number of characters per line.
7. Click the Verify connection button to print a test page.
8. Click Apply to save the settings.
9. Click OK to close the program options.

Related information
Viewing the alarm history log

5.7.6  Changing the operator name
The Operator name can be displayed in three different ways when it is associated with
accepted alarms in the Alarm Log window.
Procedure

1. From the Tools menu choose Options.
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2. Select the Log Setup tab:

3. Choose one of the following:
• User name - User Id for logging in to the workstation.
• PC name - node name of the current workstation in the network.
• User defined - a custom name to be displayed in the Operator field.

4. Click Apply to save any changes.
5. Click the OK button to close the program options.

The Alarm Log shows which alarms have been accepted by an Operator.

Figure 5-3: Alarm History

A. PC name
B. User defined name
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5.8  Accepting alarms
Alarms can be accepted by the operator if the current program protection level is equal to
or higher than the required access level.
Alarms can only be accepted for tanks included in an active alarm group.
To accept an alarm do one of the following:
• Press <SHIFT + F9>.
• Click the Accept button on the toolbar.

• Open menu option View → Alarms → Accept Alarm.

Figure 5-4: Accept Alarm Options
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5.9  Disconnecting alarms
Disconnecting alarms can be useful during maintenance work. Specific alarms can be
disconnected individually, or all alarms can be disconnected at once. The Alarm Disconnect
window provides an overview of which alarms are active or disconnected, and allows you
to specify which alarms should enabled or disabled.
Procedure

1. In the TankMaster workspace, do one of the following:
• Right-click a tank in the Workspace window and select Alarm Entry → Alarm

Disconnect
• select menu option Entry → Alarm Entry → Alarm Disconnect

2. To disconnect an individual alarm, click the corresponding check box.
3. Optional: To disconnect all alarms, select the Disconnect Tank check box.
4. Click Apply to implement changes, and OK to close the Alarm Disconnect window.

Alarm status The status of a disconnected alarm is displayed as Discon in tank and
group view windows.

Calculations WinView continues to monitor and update measurement values for a
parameter when the corresponding alarm is disconnected.
A disconnected temperature sensor is not included in the average
temperature calculation.

Note
There are no error alarms for disconnected sensors. Sensor failures are not
indicated for sensors with disconnected alarms.

Related information
Enable and disable leak alarms
Enable and disable leak alarms
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5.9.1  Enable and disable leak alarms
The Enable/Disable Leak Alarms function is used to enable or disable level leak alarms for
all tanks.To enable/disable alarms for individual tanks use the Alarm Disconnect function.
Procedure

1. In the TankMaster workspace, do one of the following:
• Right-click a tank group in the Workspace window and select Enable/Disable

Leak Alarms
• select menu option Entry → Enable/Disable Leak Alarms

2. Select the Enable button to activate the selected leak alarms for all tanks. The
Enable button is active if the leak alarm is disabled for one or more tanks.

3. Select the Disable button to disable the selected leak alarms for all tanks in the
selected tank group. The Disable button is active if the leak alarm is enabled for one
or more tanks.

Related information
Disconnecting alarms
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5.10  Alarm setup
Alarms can be configured to provide unique notifications for specific alarms. Alarm settings
can be customized for sounds, colors, notifications, users, and shifts.

5.10.1  Alarm sound notification
Sounds can be used to clearly distinguish between different alarm signals.
Procedure

1. In the TankMaster workspace, select menu option Tools → Options, and then select
the Alarm Sounds tab.

2. Select an alarm from the Alarms list.
3. Choose a Sound mode from the following options:

• PC speaker only - this option uses Microsoft Windows sounds
• WAV file
• None - this option disables alarm signaling

4. Repeat Step 2 to Step 3 for as many alarms as required.
5. Click Apply, and OK to close the program options.

Using a WAV sound
You may use a WAV sound file as alarm signal.
Procedure

1. In the Alarm Sounds tab, click the Browse button.

Alarm handling Reference Manual
June 2023 00809-0300-5110

82 Emerson.com/Rosemount



2. Locate a *.WAV file. Default alarm sounds are available in the following
location: ...\Rosemount\Tankmaster\Opi\Data.

5.10.2  Alarm colors
You can configure alarms to be displayed in unique colors.

Related information
Color settings

5.10.3  Alarm notification via e-mail
WinView can be configured to send notifications via e-mail when an alarm is activated.
Procedure

1. In the TankMaster workspace, select menu option Tools → Options, and then select
the Alarm Notifications tab.

2. From the Alarm group drop-down list, select the desired alarm group to configure
for notifications.

3. Select an E-mail client for e-mail notifications. The Microsoft MAPI does not require
further configuration. To configure the Built-in e-mail client, see E-mail client
configuration.

Reference Manual Alarm handling
00809-0300-5110 June 2023

Rosemount TankMaster 83



Note
On some systems the MAPI mail client generates a security warning dialog from the
server when trying to send an alarm notification. On these systems, the distribution
of alarm notifications requires user interaction and no alarm notifications will be
sent if the security warning dialog is left unattended.

4. Click the Address Book button in case you need to add recipients for notification via
e-mail.

5. In the Available Contacts pane, select a name to be included in the list of Recipients
and click the Add > button.

6. Click the Add New button if you need to add a new contact to the Address Book.
7. Enter name and e-mail address for the new recipient and click OK.

8. Repeat Step 5 to Step 7 for all recipients to be included in the e-mail notification.

Note
To remove a recipient from the Recipients list, select a name and click the Remove
button.

9. Click OK to save the configuration and close the Address Book window.
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10. For each e-mail recipient, configure:
• desired alarms to be included in the e-mail notification (CFail, Error, HiHi and

LoLo, High and Low, Leak)
• one or more weekday and weekend shifts for which the e-mail notification

function will be activated

11. Select OK to save the current setup.

Configure shifts
This is a description on how to setup weekday and weekend shifts for e-mail alarm
notifications.
Procedure

1. In the Alarm Notifications tab, click the Shifts button.

2. Select desired shifts for which notifications will be sent.
3. Configure start and stop times for shifts using the From and To fields.
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4. Click Configure Weekdays to specify days for Weekday and Weekend.

5. Click OK.
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5.10.4  E-mail client configuration
Rosemount TankMaster™ has a built-in e-mail client which allows alarm notifications,
reports and other e-mails without using a third-party e-mail client.
Procedure

1. In the TankMaster workspace, select menu option Tools → Options, and then select
the E-mail Configuration tab.

2. Configure the following options:
SMTP Server Specify an SMTP server for outgoing messages. Contact

your LAN administrator or Internet Service Provider (ISP) for
details.

Sender Address The e-mail account which will send e-mails from the current
workstation must be located on the specified SMTP server.

SMTP Port Optional. Contact your LAN administrator or ISP for details.
Authentication
Configuration

Select this option and enter a Login name and Password if
authentication is required on the mail server. Contact your
LAN administrator or ISP for details.

Channel Security
Configuration

Select this option if the e-mail client requires the use of
channel security. Contact your LAN administrator or ISP for
details.

Subject Enter a title for an e-mail alarm notification. The subject is only
used for alarm notification and is optional. This subject will not
be used for other e-mails sent from the built-in e-mail client.

3. Click OK.
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6  Reports
Rosemount TankMaster™ allows you to create reports to be scheduled for automatic
distribution. The reports provide inventory information on tanks and their contents.

6.1  Automatic reports
TankMaster WinView lets you specify reports to be distributed at a predefined schedule.
Procedure

1. In the WinView workspace select the Reports icon.
2. To set up a scheduled automatic report, do either of the following: Click the right

mouse button and select Add Report.
• In the TankMaster workspace Groups view, right-click the Reports icon and select

Add Report
• Select the Reports icon in the Groups view and open menu option Reports → Add

Report
• Open menu option Tools → Options, select the Reports tab, and click Add
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3. The Report Data window lets you specify the following:
• report title
• tanks to send reports to
• how the report will be distributed (publication type): via email, printer, or stored

in text file format.
• recurrence pattern, i.e. how often the report will be sent
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6.1.1  Tanks in report
To define for which Tank/Tanks the report should be published, select the desired option in
the Tank(s) to keep track of in Report pane.
Select for which tank the report should be published.
Select All Tanks to include all tanks in the report, or select a specific tank.

Figure 6-1: Adding tanks to a report

Reference Manual Reports
00809-0300-5110 June 2023

Rosemount TankMaster 91



6.1.2  Configure publication type
Reports can be printed, sent by e-mail as well as saved in text file format to be opened by
any program which can handle text files.

Configure printed report
Procedure

1. In the Publication Type/Available pane, double click Printer, or select Printer and
click the Add button.

2. In the Selected pane on the right-hand side, select Printer and select the Config
button.

3. Select the desired printer for publishing.

4. Click OK.
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Configure email reports
Procedure

1. In the Available pane, double click eMail, or select eMail and click the Add button.

2. In the Selected pane on the right, select eMail and click the Config to add recipients
and e-mail subject.

3. Click Add to add a recipient for the e-mail report. Repeat this for each recipient.
4. Add an e-mail subject.
5. Click OK.

To create more e-mail distribution lists, repeat this procedure. The selected report
will be sent to all e-mail distribution lists in the Selected pane on the right-hand side
of the Report Data window.

Related information
E-mail client configuration
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Configure file reports
Reports can be saved as text file or pdf report.
Procedure

1. In the Available pane, double click File, or select File and click the Add button.
2. In the Selected pane on the right, select File and click Config.

3. Enter a path to the folder where the report will be saved and a file name.

4. To add a unique suffix to the report files, check the Add Unique Suffix check box.
In this example, the first report file will be called AllTanks_1.txt, the second report
file AllTanks_2.txt, and so on. When the Max Number of Report Files is reached, the
oldest report file will be overwritten.

5. Enter a maximum number of report files to be saved. In this example, when
AllTanks_10.txt has been created, the next file will be AllTanks_1.txt, and the
previous file with that name will be overwritten.

6. Click OK.
Note
If only a file name is specified with no directory, report files are saved in the default
folder: ...\Rosemount\TankMaster\Opi\Shared.
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6.1.3  Recurrence pattern
To define how often a report will be automatically distributed:
• select either hourly, daily, weekly, or monthly
• specify a start time and frequency
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6.2  Publishing a report
The Report Data window lets you set up reports for automatic publishing according
to configured settings. In addition to automatic scheduling, a report can also be
manually published at any time you like using the configured settings for publication and
distribution.
Procedure

1. In the WinView workspace, select the desired report.
2. Do one of the following:

• Click the right mouse button and select Publish Report
• select menu option Reports → Publish Report

The selected report will be published according to the configured Report Type and
Publication Type settings for that report.
In addition to the Publish Report option, the Reports menu lets you change, delete,
and review reports.

A. Report title
B. Tank
C. Publication type
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7  Audit log
The Audit Log function enables operations performed by a Rosemount TankMaster™ user
to be recorded. Audit log records can include events and actions such as changing alarm
limits, logging on or off, and setting parameter values manually.

7.1  Setup an audit log
The Audit Log function can be enabled or disabled at any time.
Procedure

1. In the TankMaster workspace, select menu option Tools → Options, and then select
the Log Setup tab.

2. Under Audit Log Settings, select the desired Tankserver to be monitored by the
Audit Log function.

3. Activate the Audit Log function by selecting one of the two options:
• Set size of log file by number of records
• Set size of log file by number of days
Either of these two options can be used to limit the size of the Audit Log file. When
the file reaches its limit, the oldest records will be removed as new records are
stored.

4. Click OK, or Apply to activate the new settings.

7.2  Viewing the audit log
Procedure

1. In the TankMaster workspace, select menu option Tools → View Audit Log.
2. Select a server. The Audit Log can only be viewed for one tank server at a time.
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The Audit Log displays the time stamps for each event and the Operator who was
logged on at the time.
The Filter button allows you to record events over a certain time period, and for
specific tanks.
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7.3  Filtering the audit log
The Audit Log can be set up to record events over a certain period of time and for specific
tanks.
The Filter button in the Audit Log window opens the Audit Log Filter Settings window
which allows you to record events over a certain time period, and specific tanks.
To configure desired filtering options, open menu Tools → View Audit Log and select the
Filter button.

7.3.1  Filtering by date
There are three options available for date filtering:
• All dates
• Date between
• Not older than
Procedure

1. In the TankMaster workspace, select menu option Tools → View Audit Log.
2. In the Audit Log window, select the Filter button.
3. To log events within a certain period, select Date between and set the dates using

the pop-up calendar.
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4. To limit the audit log to events which are not older than a specific period, select Not
older than. The log can be limited to minutes, hours, days, weeks, or months.

5. Select All dates in case you want to disable filtering by date. All records regardless of
date appear in the Audit Log window.
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7.3.2  Filtering by tanks
The audit log can be filtered to display only those events which are related to specific tanks.
Procedure

1. In the TankMaster workspace, select menu option Tools → View Audit Log.
2. In the Audit Log window, select the Filter button:

3. In the Available Tanks pane, select a tank to be included in the audit log.
4. Click the Add  button. The tank appears in the Selected Tanks pane on the right.
5. Proceed by adding the desired tanks to appear in the Audit Log window.

Click the Add All  button in case you want to include all tanks.
You can remove tanks by using the Remove  and Remove All  buttons. Tanks
can also be added and removed by double-clicking an entry.

6. To set the maximum number of rows to be displayed in an audit log, enter a number
between 1 and 5000 in the Number of rows in table field.

7. In case you want to save the current settings as default, select the Save settings as
default check box.

8. Click the OK button to save the current filtering settings.
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8  Customizing the layout
You can create customized menus, windows and tool bars. This enables you to add a menu
item to the Tools menu for easy access to a program, such as TankMaster WinSetup, or
design windows showing specific parameters.

Reference Manual Customizing the layout
00809-0300-5110 June 2023

Rosemount TankMaster 103



8.1  Create a customizable window
This is a description of how to create a customizable window in TankMaster WinView. Once
it is created you may modify it to fit your requirements.
There are five default options available that you can edit to create a customizable window.
You may also create an entirely new window.
Procedure

1. Select menu option Tools → Options and select the Custom Views tab.

2. Select a view to edit, for example Tank &View, and click Copy.

3. Double-click the Name field and rename your customized view.
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4. Enter a new name and click OK.

The new name appears in the Name column.

8.1.1  Custom views
The new window will be available in menu option View>Tank.
Example
In this example, the custom window is available in View → Tank → My Tank View:
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8.2  Edit customizable window
A customizable window is available in the View menu. For TankMaster WinOpi a
customizable window may also be available in the Entry menu, depending on the menu
option chosen when creating the window.
The following description is an example of how to modify the design and appearance of a
customizable window.
Procedure

1. Select a tank in the TankMaster workspace and open a customizable window.
Note
Only windows which have been created as Custom Views can be edited. The Edit
Tools feature is not available for standard windows.

2. Press Ctrl+E when the customizable window is active to open the Edit Toolbox:

3. Choose the Selection Tool  in the edit toolbox.

The Selection Tool lets you select items in the customizable window. Then you can
delete or move items such as, for example, HART Input or Analog Input.
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4. To change, for example, Level to Ullage in the tank view, the following actions must
be performed:
• Change the text label from Level to Ullage
• Change the OPC item Current Value (CV) for level to Current Value for ullage
• Change the OPC item Value Unit (VU) for level to Value Unit for ullage
• Change the OPC item Alarm Status (AS) for level to Alarm Status for ullage

5. To change the text label from Level to Ullage, select the Level text block and right
click to open the Property Sheet:

6. In the Property Sheet, double-click on the Caption entry and change Level to Ullage.
7. Close the Property Sheet window to verify the change.
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8. To change the OPC item Current Value (CV) for Level to Current Value (CV) for
Ullage, right click the parameter block to bring up the Property Sheet:

9. In the Property Sheet, select OPCItem in the left-hand column and click the browse
 button.
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10. In the Browse OPC Items window, open TANKS>%tank%>ULL>CV:
a) Click on TANKS and browse to find the name of the tank to be edited. In this

example, TK-06.
b) Select the item ULL.
c) Select the item CV.
d) The Item Name shown should be %tank%.ULL.CV. In this example;

TK-06.ULL.CV.

11. Click OK.
12. Now repeat these steps for the other OPC items in the same way. Select the

corresponding parameter block, right-click to bring up the Property Sheet, and edit
the OPC items:
OPC Item Original Value New Value
Value Unit (VU) %tank%.LL.VU %tank%.ULL.VU
Alarm Status (AS) %tank%.LL.AS %tank%.ULL.AS

13. To exit edit mode, press Ctrl+E.
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14. Open the customized window from the View or Entry menu depending on the
selected option when creating the customizable window, and verify the changes:

15. Optional: The customized window can also be opened from the Custom menu:
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9  Servo commands
For tanks configured as servo tanks, it is possible to send commands to a servo gauge
using the Servo Command window.

9.1  Sending a servo command
Prerequisites
To send a servo command, the tank must be configured as a servo tank.
See the Rosemount Tank Gauging System Configuration manual for more information.
Procedure

1. Right-click on a servo tank in the Workspace window. Do one of the following:
• Select Send Servo Command
• Select main menu option Entry → Send Servo Command

The Servo Command window appears.
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2. Click the desired servo command.

When a servo command is sent, the Level /Displacer position field in the Servo
Command window turns orange and the servo state is displayed to the left of the
Level /Displacer position.

3. Click Close.
Note
Before you close the Servo Command window, verify that the servo command
indicator next to Level /Displacer pos field is cleared.

Example
For example, in case the Test command was sent to the gauge, ensure that T (Test)
is not visible before you close the window.
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9.1.1  Servo commands
Table 9-1: Servo Commands
Command Description
Freeze (Block) Holds the displacer in its current position.
Park (Lock/Stow) Raises the displacer to the top of the tank.
Measure (Unlock/Unstow) Unlocks the gauge after Freeze or Park, and the displacer

moves to the surface of the product.
Test Raises the displacer and then returns it to the surface of the

product.
Search for water level Initiates a search for the product/water interface.
Quit Water Measurement Quit measuring the water interface and return to measure

the product level.
Measure Density Displacer will be lowered into the product to measure the

product density.

9.1.2  Tank operation and active servo command
In the Tank Operation window, the Level position field turns orange. All Inventory
calculations field are disabled as long as the servo command is executed.
Note
When a servo command is active, the Level value does not show the current product level.
The level shown is the current displacer level.

Figure 9-1: Tank Operation and Active Servo Command
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9.2  Servo states
The table below shows the different servo commands and servo states shown when using
CIU and Rosemount 2460 System Hub.

The Up, Freeze and Down states refer to the displacer movement.
Table 9-2: Servo States
Servo Command Displayed servo state in Windows

Enraf® CIU Rosemount 2460 System Hub
Raise Freeze Lower Raise Freeze Lower

Freeze (Block) - F - - F -
Park (Lock/Stow) P F - P F -
Measure (Unlock/
Unstow)

- - T - - T

Test T - T T - T
Search for water
level

- W ? - - D

Water found - W -
Quit water
measurement

T - - T - -

Measure density R - R R - R

Note
When a servo command is active and the displacer is in movement, the active device
communication is prioritized.

Additional states
Table 9-3: Servo States
Servo state character Displayed servo state

? Reduced accuracy
M Warning
! Unsupported status
T Temperature

OPC and Modbus
The current servo command is viewable via OPC or Modbus from a host computer.
To view the servo command status via OPC, use the TK.xx.LL.SS tag.
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