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TankMaster WinSetup

NOTICE
Read this manual before working with the product. For personal and system safety, and for optimum product
performance, make sure you thoroughly understand the contents before installing, using, or maintaining this
product.
For equipment service or support needs, contact your local Emerson representative.

Version

This manual is based on the functionality of TankMaster version 6.G1.
For older TankMaster versions all functionality described in this manual may not be available and the Graphical User
Interface (GUI) may look different.

Safety messages

 WARNING
Physical access
Unauthorized personnel may potentially cause significant damage to and/or misconfiguration of end users’
equipment. This could be intentional or unintentional and needs to be protected against.
Physical security is an important part of any security program and fundamental in protecting your system. Restrict
physical access by unauthorized personnel to protect end users’ assets. This is true for all systems used within the
facility.
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1  Introduction
Rosemount TankMaster WinSetup is the recommended tool for setting up a Rosemount
Tank Gauging system.
This manual describes the basic functions of the WinSetup configuration software, how
to set up tank capacity tables (TCT), product parameters for inventory calculations, and
various service functions. The manual includes a brief description of the recommended
setup procedure for a Rosemount Tank Gauging system.
Related information
The WinSetup main window

1.1  What is Rosemount TankMaster™?
The TankMaster software suite provides you with the tools that you need to configure
and operate the Rosemount Tank Gauging system. The Rosemount Tank Gauging product
portfolio includes a wide range of components for small and large customized tank
gauging systems. The system includes various field devices, such as radar level gauges,
temperature transmitters, and pressure transmitters for complete inventory control. For
detailed descriptions of how to setup various devices refer to the respective reference
manuals.
TankMaster is an Emerson inventory management software package for installation and
configuration of level gauging equipment. It is a complete custody transfer and inventory
software package that provides operator overview for Rosemount Tank Gauging systems.
All calculations are based on current API and ISO standards.
TankMaster provides you with powerful and easy-to-use tools for installation and
configuration of level gauging devices such as radar transmitter gauges (RTGs). The
settings for protocols, devices and tanks can be changed in real time.
The graphical interface gives you a clear overview of installed devices and tanks. For each
tank you can easily see the associated transmitters in the WinSetup application.

1.1.1  Key features
• Monitoring of measured data
• Clear overview of installed tanks and devices (using WinSetup)
• Simple installation using wizards (using WinSetup)
• Open connectivity
• Object-oriented, user-friendly Graphical User Interface (GUI)
TankMaster is designed to be used in a Microsoft® Windows environment, providing easy
access to measurement data from any PC in your network. Measurements and data are
presented in realtime and you can customize views to suit your needs.
Rosemount TankMaster lets you connect via the Ethernet TCP/IP interface. You may also
use TRL2, RS232, or RS485 interfaces if needed. Other communication interfaces, such
as Enraf BPM, are also supported. Rosemount TankMaster is based on the open OPC
standard, allowing you to import data into other systems such as DCS:s, PLC:s, Scada
systems and Microsoft Office programs.
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1.2  TankMaster software package
The TankMaster software package comprises the following software modules:
• WinOpi
• WinSetup
• WinView
• Batch server
• Tank server
• Master Protocol servers
• Slave Protocol servers

Figure 1-1: Software Modules

WinOpi
WinOpi is the operator interface to the tank gauging system. It communicates with the
Tank Server and various protocol servers to let the user monitor measured tank data.
WinOpi also provides:
• alarm handling
• automatic report distribution
• historical data sampling
• inventory calculations for volume, observed density and other parameters.
WinSetup
The WinSetup program is a graphical user interface (GUI) for installation, configuration and
maintenance of level gauging devices.
WinView
WinView is a software package with basic inventory capabilities. It communicates with the
Tank Server and the different protocol servers to let the user monitor measured tank data.
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Tank server
The Tank Server communicates with devices via the Master Protocol Server and handles
configuration data for all installed tanks and devices. Parameters stored by the Tank Server
include:
• device names
• configuration data, such as antenna type
• number of connected temperature sensors
• number of connected analog inputs
The Tank Server collects data from connected devices and distributes this information to
the TankMaster and WinSetup user interface.
Master protocol server
The Master Protocol Server transfers configuration data and measured data between the
Tank Server and connected devices in the tank gauging system. The Master Protocol Server
is able to communicate with various types of devices such as FCUs, the Rosemount 2410
Tank Hub, and the Rosemount 5900S Radar Level Gauge to collect measurements for, for
example, level, temperature and pressure.
Slave protocol
The Slave Protocol Server is used to connect the TankMaster system to a host computer
(DCS system). The Slave Protocol Server exchanges tank data between the Tank Server and
the host computer.
OPC Server with browser
TankMaster uses OPC Data Access 2.0 (OLE for Process Control), an open industry
standard, which eliminates the need for costly customized software integration.
With the OPC server and the browser it is easy to import all custody transfer and inventory
data to other OPC clients such as different DCS:s, PLC:s, Scada systems, or Microsoft®

Office programs.
See the web site for the OPC Foundation for more information: www.opcfoundation.org.
Customized views
You can customize specific views and windows in TankMaster. Existing objects can be
modified, or you can build new ones. You could, for example, create a window with an
embedded image of your own plant, to give a realistic overview, and configure the window
so that when you click on a specific tank in the image you can access the corresponding
data for that tank.
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1.3  Manual overview
The Rosemount TankMaster WinSetup Reference Manual includes the following sections:
Chapter Introduction provides a description of the various components in the Rosemount
Tank Gauging system and an introduction to the TankMaster software package.
Chapter The WinSetup main window provides an introduction to the basic features of the
WinSetup configuration program. It describes the workspace, menus, and various toolbars.
Chapter Basic functions provides a brief description of basic functions supported by the
Rosemount TankMaster WinSetup configuration tool for setting up a Rosemount Tank
Gauging system.
Chapter Device handling describes basic functions for changing device configuration and
uninstalling devices.
Chapter Service functions includes a description of various functions supported by
TankMaster WinSetup for service and maintenance of field devices.
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1.4  Technical documentation
The Rosemount Tank Gauging System includes a wide portfolio of user documentation. For
a complete list, see product pages on Emerson.com/Rosemount.
Reference manuals
• Rosemount Tank Gauging System Configuration Manual (00809-0300-5100)
• Rosemount 2460 System Hub (00809-0100-2460)
• Rosemount 2410 Tank Hub (00809-0100-2410)
• Rosemount 5900S Radar Level Gauge (00809-0100-5900)
• Rosemount 5900C Radar Level Gauge (00809-0100-5901)
• Rosemount 2240S Multi-Input Temperature Transmitter (00809-0100-2240)
• Rosemount 2230 Graphical Field Display (00809-0100-2230)
• Rosemount 5300 Guided Wave Radar (00809-0100-4530)
• Rosemount 5408 Radar Level Transmitter (00809-0300-4408)
• Rosemount 3308 Series Wireless Guided Wave Radar (00809-0100-4308)
• Rosemount Tank Gauging Wireless System (00809-0100-5200)
• Rosemount TankMaster Software Installation Manual (00809-0400-5110)
• Rosemount TankMaster WinOpi (00809-0200-5110)
• Rosemount TankMaster WinSetup (00809-0100-5110)
• Rosemount TankMaster WinView (00809-0300-5110)
• Rosemount 5900 Proof Test with Reference Reflector (00809-0200-5900)
• Rosemount TankMaster Floating Roof Monitoring (00809-0500-5100)
• Rosemount TankMaster Full containment tanks (00809-0500-5110)
• Rosemount 5900 Radar Level Gauge and Rosemount 2410 Tank Hub Safety Manual

Option S (00809-0400-5100)
• Rosemount 5900 Radar Level Gauge and Rosemount 2410 Tank Hub Safety Manual SIL3

(00809-0200-5100)
• Rosemount TankMaster Mobile User Guide (00809-0100-5120)
• Rosemount TankMaster Mobile Installation Manual (00809-0200-5120)
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Product data sheets
• Rosemount Tank Gauging System (00813-0100-5100)
• Rosemount TankMaster Inventory Management Software (00813-0100-5110)
• Rosemount TankMaster Mobile Inventory Management Software (00813-0100-5120)
• Rosemount 2460 System Hub (00813-0100-2460)
• Rosemount 2410 Tank Hub (00813-0100-2410)
• Rosemount 5900S Radar Level Gauge (00813-0100-5900)
• Rosemount 5900C Radar Level Gauge (00813-0100-5901)
• Rosemount 2240S Multi-input Temperature Transmitter (00813-0100-2240)
• Rosemount 565/566/765/614 Temperature and Water Level Sensors (00813-0100-5565)
• Rosemount 2230 Graphical Field Display (00813-0100-2230)
• Rosemount 5300 Level Transmitter (00813-0100-4530)
• Rosemount 5408 Level Transmitter (00813-0100-4408)
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1.5  System and user documentation structure
Figure 1-2: Rosemount Tank Gauging System and User Documentation Structure

Rosemount 2240S Reference Manual 
(Document No. 00809-0100-2240)

Rosemount 2230 Reference Manual 
(Document No. 00809-0100-2230)

Rosemount Tank Gauging System Configuration Manual 
(Document No. 00809-0300-5100)

Rosemount TankMaster WinSetup Reference Manual 
(Document No. 00809-0100-5110)
Rosemount TankMaster WinOpi Reference Manual 
(Document No. 00809-0200-5110)

Rosemount TankMaster WinView Reference Manual 
(Document No. 00809-0300-5110)
Rosemount TankMaster Software Installation Manual  
(Document No. 00809-0400-5110)

Rosemount 2460 Reference Manual 
(Document No. 00809-0100-2460)

Rosemount 2410 Reference Manual 
(Document No. 00809-0100-2410)

Rosemount 5900S Reference Manual 
(Document No. 00809-0100-5900)
Rosemount 5900C Reference Manual 
(Document No. 00809-0100-5901)
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2  The WinSetup main window
The TankMaster WinSetup main window includes a Workspace which displays tanks,
devices, a menu bar at the top of the screen, a status bar at the bottom of the screen
and a number of buttons in the toolbar.

Figure 2-1: The WinSetup Main Window

A. Menubar
B. Toolbar
C. Workspace
D. Status bar
E. Minimize
F. Maximize
G. Close

The Workspace window can be moved anywhere on the Main window. It can be docked to
either side, to the top, or to the bottom. It can also be left floating in the Main window.
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Figure 2-2: The WinSetup workspace

Right click in the Workspace window and choose Allow Docking to place the Workspace
window along the Main window side.
Related information
Introduction

2.1  Menus
The menu bar at the top of the screen contains menus such as File, View, Service, Tools,
and Help.

Figure 2-3: WinSetup menu

Service menu options are also available by clicking the right mouse button. Different
options are available depending on the type of object selected in the Workspace window.
For example, clicking the right mouse button on the Devices folder will open the following
menu:

The WinSetup main window Reference Manual
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Figure 2-4: Service menu

Clicking the right mouse button on a device icon brings up a menu with different
configuration and service options:

Figure 2-5: Right-click menu

Reference Manual The WinSetup main window
00809-0100-5110 November 2023

Rosemount TankMaster 15



2.2  Toolbar
The toolbar provides buttons acting as shortcuts to certain menu options.
Normally the Toolbar is visible. To hide it, open the View menu and deselect the Toolbar
option:

Figure 2-6: WinSetup Toolbar

A. Toolbar
B. Hide/Show Toolbar

Items included in the standard toolbar:

Figure 2-7: Toolbar items

A. Log off to View Only mode
B. Log on to TankMaster as Operator, Supervisor or Administrator
C. Rename a tank
D. Search for a tank or a device in the workspace tree structure
E. Open the Properties dialog
F. Open the Tank View window
G. Install a new tank
H. Install a new device
I. Uninstall a tank
J. Uninstall a device

K. Turn the Workspace window On or Off
L. About WinSetup

The WinSetup main window Reference Manual
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2.3  Status bar
The status bar is located at the bottom of the TankMaster main window. It provides
general information about the current system state.
The status bar shows information about a device, tank or any other item that is selected in
the WinSetup main window. Connection status, current user, current protection level (View
Only, Operator etc.), and operation status are shown as well.
To hide the TankMaster status bar, open the View menu and deselect the Status bar
option:

Figure 2-8: WinSetup Status bar

A. Status bar
B. Connection status
C. Current user
D. Current protection level
E. Indicator for normal operation

Reference Manual The WinSetup main window
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2.4  Workspace - viewing tanks and devices
The workspace displays an overview of all devices and tanks. You can switch between two
different views: Logical and Physical view.

Figure 2-9: Logical and Physical Views in the WinSetup Workspace

A. Logical view
B. Physical view

In the workspace you can perform various tasks such as:
• Install and configure tanks, devices, and protocols
• Remove tanks and devices
• Change the configuration of tanks and devices
• View database and input registers
• Setup the tank view layout
• Specify tags for tank and device names
• Upload new application software to a radar tank gauge
• View communication log

The WinSetup main window Reference Manual
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2.4.1  Workspace examples
The Workspace window shows the installed tanks and devices and available
communication protocols. It also provides information about the configuration of installed
devices.
Example 1
In the Logical View all installed tanks and devices, as well as available communication
protocols, are organized in separate folders to provide a clear overview of the system.
“+”-sign indicates that a device is connected to associated devices.

Figure 2-10: Logcial view

Example 2
The Tanks folder shows an overview of the installed tanks. For each tank the associated
devices are displayed. The Workspace provides information that reflects the system
configuration.
In this example, the symbols indicate that level gauge LT-1 communicates with This
Workstation via Rosemount 2410 Tank Hub HUB-101 and Rosemount 2460 System Hub
SYSHUB-201.

Figure 2-11: Logcial view
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Example 3
Available communication protocols are displayed in the Protocols folder.

Figure 2-12: Logcial view
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2.4.2  Icons
In the Workspace window the different tanks and devices are represented by varous icons.
Table 2-1: Device icons
Icon Device

Rosemount 2460 System Hub

Rosemount 2410 Tank Hub

Rosemount 2410 Tank Hub (Simulation Mode)

Rosemount 5900S Radar Level Gauge (configured)

Rosemount 5900S Radar Level Gauge (not configured)

Rosemount 5900C Radar Level Gauge.
Configured.

Rosemount 5400 Series Radar Transmitter

Rosemount 5300 Series Radar Transmitter

ATD (Auxiliary Tank Device; for example Rosemount 2240S, Rosemount 3051S).
Configured.
ATD (Auxiliary Tank Device; for example Rosemount 2240S, Rosemount 3051S).
Not configured.
Emerson Wireless 1410S Gateway

Emerson Wireless 1420 Gateway

Emerson Wireless 775 THUM Adapter

Rex Radar Tank Gauge (RTG)

Rosemount 2160/2165/2175 Field Communication Unit (FCU)

Slave Data Acquisition Unit (SDAU)

COM port status

COM port status for wireless system

Communication Protocol
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Table 2-1: Device icons (continued)
Icon Device

Communication Protocol Channel

Communication Channel Modbus TCP

TRL PU

IOT 51XX

MCG32XX

MDPII

CIU

DS4

Table 2-2: Tank icons
Icon Tanks

Fixed Roof, HTG Fixed Roof

Floating Roof, HTG Floating Blanket

Full Containment

Sphere, LPG Sphere

Horizontal, LPG Horizontal

HTG Fixed Roof

HTG Floating Roof, HTG Floating Blanket

Servo Tank Fixed Roof

Servo Tank Floating Roof

Servo Tank Sphere, Servo Tank Sphere LPG

Servo Tank Horizontal, Servo Tank Horizontal LPG

The WinSetup main window Reference Manual
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Table 2-2: Tank icons (continued)
Icon Tanks

Cryogenic Tank
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2.5  User management
TankMaster provides several protection levels allowing you to prevent unauthorized
changes. These protection levels are categorized as User Access Levels and User Access
SubLevels.
Each user access level has five User Sub Access Levels providing a large number of unique
access levels.
In order to change tank and device configuration, install new tanks and devices, calibrate a
level gauge, change holding register values etc. you must be logged on to the appropriate
TankMaster user access level.
You can be logged on as Chief Administrator, Administrator, Supervisor, Operator, or
View Only mode. The default username and password for each user type is as follows:
Table 2-3: User Access Levels and Sub Levels
User Level Sub Level Default password
View VIEW ONLY * view
Operator OPERATOR * oper
Supervisor SUPERVISOR * super
Administrator ADMINISTRATOR * admin
ChiefAdmin ADMINISTRATOR * * * * * chief

Related information
To set required access levels

The WinSetup main window Reference Manual
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2.5.1  Logging on to TankMaster
Procedure

1. From the File menu choose Log On or click the Log On  button in the WinSetup
toolbar.

2. Type your Username and Password. The password is case sensitive but the
username is not.
Note
If logging on fails five consecutive times the user account is disabled. In this case the
user account has to be enabled by an administrator.

3. Click the OK button. The currently logged on user and the corresponding protection
level is displayed in the status bar.

A. Username
B. User access level

Reference Manual The WinSetup main window
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2.5.2  Managing user accounts
TankMaster allows you to setup a number of users at different levels and sub levels. You
must be logged on as an Administrator in order to add new user accounts or to change the
existing user account settings.
Procedure

1. Log on as an Administrator.
2. Go to Tools → Administrative Tools → User Manager.

3. In the User Manager window, select a cell in an empty row and click the New button.

4. Type a user name and a password. If you like, you may enter a description in the
Description field.

The WinSetup main window Reference Manual
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5. Choose the desired User Access Level and Sub Level and click the OK button.

A. A new user account is added
B. Use first account with required access level as default

6. Verify that the new user appears in the User Manager window.
7. Select the check box Use first account with required access level as default if you

want a default user name to appear in the Log On dialog whenever it is opened. If
this box is unmarked, the User Name field is empty when the Log On dialog opens.

8. Click OK to save the changes and close the User Manager window.
Related information
User management
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2.5.3  Configuring a sub level description
TankMaster allows you to change Sub Level names to something more descriptive than the
default settings.
Procedure

1. Go to Tools → Administrative Tools →  User Manager.
2. In the User Manager window, click the Config Desc button.

3. In the Config Access Sub Levels Description window, enter new descriptions in the
desired fields. In the example above, the description of item number 5 of category
Admin Sub Levels is changed from “*****” to “Sublevel 5”.

4. Click OK to close the window.
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2.5.4  To set required access levels
In TankMaster WinSetup, you can set the access level required for the following actions:
• Tank/Device Install and Uninstall
• Tank/Device Configuration
• Replace, Restore and Restart Device
• Protocol Configuration
• Exit WinSetup
• Add Program
• Start Program (in the Tools menu)
For example, if you are logged on as an Operator (* * * * *), you are not allowed to exit
WinSetup if the required exit level for this action is set to Supervisor (*) or higher.
Prerequisites
You have to be logged on as an Administrator (* * * * *) to be able to set the required
access levels.
Procedure

1. From the Tools/Administrative Tools menu choose Set Required Access Levels.

2. Set the required access levels for each type of action and click the OK button.
Related information
Customizing the Tools menu in WinSetup
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2.5.5  To change protection level of separate windows
In TankMaster it is possible to set a Protection Level for a specific window, e.g. the
Properties window for a device. This function is only available if you are logged on at
Administrator (* * * * *) level.
Prerequisites
You have to be logged on as an Administrator (* * * * *) to be able to change the
Protection Level.
Procedure

1. Put the cursor on the icon at the upper left corner and click the left mouse button.

2. Select the Protection Level... option.
3. Select the desired protection level from the drop down menus and click the OK

button. Now you will have to be logged on at the specified protection level or higher
in order to make any change in this window.

Related information
Managing user accounts
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2.5.6  To change password
Procedure

1. From the Tools/Administrative Tools menu choose the Set Password option.

2. Select the Tank Server on which your user account is valid. You can see the different
servers in the WinSetup workspace window. (If you are logged on, the current server
is already selected in the Change User Password window).

3. Enter your username if the workspace is in View Only mode. If you are already
logged on, your username appears in the Username field.

4. Enter the old password and the new password in the corresponding fields.
Note
The password is case sensitive.

5. Confirm the new password and click the OK button.

2.5.7  To change inactivity timeout
TankMaster WinSetup includes the option to set a timeout after which the current user
is automatically logged off. The timeout period is reset each time the user performs an
activity that requires an access level check, for example changing the configuration of a
device or logging on to WinSetup.
Procedure

1. From the Tools/Administrative Tools menu choose the Set Inactivity Timeout option
(you have to be logged on as Administrator).

2. Type the desired value in the corresponding input field.
3. Click the OK button.
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2.6  New connection
The New Connection window allows you to connect to another TankServer PC on a Local
Area Network (LAN).
Before you can connect to another server on the network, a configuration of the DCOM(1)
settings has to be performed.
Related information
Rosemount TankMaster Software installation Manual

2.6.1  Connecting to another server
Procedure

1. Select the Logical View in the WinSetup workspace.
2. Select the Network Connections icon.
3. Open the File menu or click the right mouse button.
4. Choose New Connection.
5. In the New Connection window press the Browse button and choose the computer

with the desired Tank Server.
6. Type a name in the Alias field. This name will be used in the WinSetup workspace for

the new server.
7. Press the OK button.

(1) Distributed Component Object Model is a Microsoft® technology for communication between software
components on computers in a network.
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3  Basic functions
This section describes functions supported by the Rosemount TankMaster™ WinSetup
configuration tool for installing a Rosemount™ Tank Gauging system.
The WinSetup configuration program lets you setup communication protocols, preferences
for measurement units, inventory parameters, as well as device installation, and tank
installation.
In brief, the installation procedure includes the following steps:
• Communication protocol setup
• Preferences
• Installation and configuration of a Rosemount 2460 System Hub
• Installation and configuration of a Rosemount 2410 Tank Hub
• Installation and configuration of field devices
• Installation and configuration of tanks
• Calibration
Related information
Rosemount Tank Gauging System Configuration Manual

3.1  Communication protocol setup
The TankMaster work station can be connected to field devices and host computers via
Master and Slave protocols.
Modbus Master protocol such as Modbus TCP (Ethernet) and Modbus RTU (TRL2, RS232,
RS485) is available as default protocol when the Rosemount TankMaster software is
installed on a TankMaster work station. Optional protocols, such as the Modbus Slave
protocol for communication with host systems such as OPC and Modbus RTU (PLC, SCADA,
DCS), can be obtained as well. Please contact Emerson Automations Solutions for more
information on various options in Rosemount Tank Gauging systems.
A Modbus protocol offers up to 32 channels. Enraf and HART protocols support 16
channels. For each channel you can specify which PC communication port (USB/COM) to
connect to, as well as standard communication parameters such as Baud Rate, Parity, and
number of Stop Bits.

Reference Manual Basic functions
00809-0100-5110 November 2023

Rosemount TankMaster 33

http://www.emerson.com/documents/automation/104482.pdf


Figure 3-1: Rosemount TankMaster and Rosemount 2460 System Hub
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Figure 3-2: Rosemount 2460 System Hub and field devices
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3.1.1  Master protocol channel configuration
The Modbus Master protocol channel can be configured for communication between field
devices and a TankMaster work station. The procedure applies to other protocols and
modems as well, but other parameter settings may be required.
Procedure

1. Open the Protocols folder in the Workspace window.
2. Select the icon that corresponds to the particular protocol to be configured (this

example shows the Modbus Master protocol).

3. Click the right mouse button and select Properties, or from the Service menu,
choose Protocols → Properties.

4. The Protocol Properties window lists the available protocol channels. For each
channel the corresponding icon indicates whether the channel is enabled or
disabled.

5. Select the desired channel.
6. Click the Properties button to configure the protocol channel.
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7. The Enable Channel check box lets you activate the protocol channel.

• The Communication tab allows you to configure parameters for communication
between field devices and a TankMaster work station.

• The File Log tab lets you specify what type of information to be logged and saved
to disk.

Once enabled, the Modbus Master Channel icon appears in the WinSetup
workspace.

Related information
Saving the communication log to file
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3.1.2  Slave protocol channel configuration
A Slave protocol allows you to collect data from a TankMaster workstation to a host
computer.
Prerequisites
A hardware key must be installed in order to run a slave protocol server. Host
communication needs to be enabled.
To configure the Modbus Slave protocol channel:
Procedure

1. Open the Protocols folder in the Workspace window.
2. Select the ModbusSlave protocol icon.
3. Click the right mouse button and select Properties, or from the Service menu select

Protocols → Properties.

4. The Protocol Properties window lists enabled and disabled protocol channels.

5. Select the desired channel.
6. Click the Properties button to configure the protocol channel.
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7. The Enable Channel check box lets you activate the protocol channel.

This window has three tabs:
• The Communication tab allows you to configure parameters for communication

between field devices and a TankMaster work station.
• The File Log tab lets you specify what type of information to be logged and saved

to disk.
• The Tank Mapping tab lets you specify from which tanks to collect data for the

host system.
Note
If handshaking includes DSR, no query will be sent from the TankMaster Protocol
Server if the communication is interrupted. This may result in a Query Timeout.

8. Click the OK button to store the current configuration and close the configuration
window.e

Related information
Saving the communication log to file
Tank mapping configuration
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Tank mapping configuration
The slave protocol allows you to send data from a Rosemount Tank Gauging system to a
host computer.
In the Tank Mapping window you can specify from which tanks to collect data for the host
system.
Procedure

1. In the Slave Protocol Channel Configuration window, select the Tank Mapping tab.

2. From the list of tanks that appear in the Available Tanks pane, select the tanks that
the host will connect to.

3. Click the  button to move the selected tanks to the list of Mapped Tanks. Ensure
that the tanks appear in the order required by the host system. When the host sends
a query, TankMaster responds by sending tank data in the order as the tanks are
listed in the Mapped Tanks column. You can easily change the position of mapped
tanks by using the  and  buttons.

4. Click the OK button to save the current configuration and close the window.
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3.1.3  Log file configuration
The Master Protocol Channel log file can be saved to disk.
Procedure

1. Select the protocol channel icon.

2. Click the right mouse button and choose Properties, or from the Service menu
choose Channels → Properties.

3. Select the File Log tab.

4. Type a name of the log file in the File Name field and set the Maximum File Size
to limit the amount of disk space required for storing log files. The Maximum File
Size option can be used in combination with the Multiple Log Files option in order to
store the log files on a number of floppy disks.
Note
If the maximum number of files is reached, TankMaster will replace existing log files.

5. Configure other options as desired and click the OK button.
Related information
Protocol handling
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3.1.4  Changing the current protocol channel configuration
The channel configuration can be changed at any time.
Procedure

1. In the WinSetup Workspace open the Protocols folder and the protocol sub folder
with the enabled channels.

2. Select the channel icon.
3. Click the right mouse button and choose Properties, or from the Service menu

choose Channels → Properties.
4. Choose the appropriate tab and change the protocol settings as described in the

previous sections.
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3.1.5  Protocol server configuration
You can specify which protocol servers that will be connected when starting TankMaster
WinSetup.
Procedure

1. In the WinSetup workspace select the Protocols folder.
2. Click the right mouse button and choose Configure.

3. In the Connect column, select the check box of each protocol to be automatically
connected when WinSetup starts up

Disable protocol server
You may disable a protocol server at any time by using the Disable command.
Procedure

1. In the Winsetup workspace, open the Protocols folder.
2. Click the right mouse button on the desired protocol server icon and choose

Disable.
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3.2  Preferences

3.2.1  Measurement units
Specify units for inventory calculations and measured variables such as level and
temperature
Prerequisites
Note
Make sure that the desired measurement units are specified before installing new tanks
and devices.

Procedure
1. Select the desired server (e.g. “This Workstation”) in the WinSetup workspace.
2. Click the right mouse button and choose Setup, or from the Service menu choose

Servers → Setup.
3. In the Server Preferences window, select the Units tab.

4. Choose the desired measurement units for level/ullage, temperature, pressure,
volume, density, and weight.

5. Click the OK button to save the current setting and close the window.
Note
Note that these settings only affect installation of new tanks. Tanks which are
already installed in the WinSetup Workspace will not be affected.
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3.2.2  Ambient air temperature
Procedure

1. Select the desired server (e.g. “This Workstation”) in the WinSetup workspace.
2. Click the right mouse button and choose Setup, or from the Service menu choose

Servers → Setup.
3. In the Server Preferences window select the Ambient Air Temperature tab:

4. Choose Auto when there is a temperature sensor available that can be used for
Ambient Air Temperature measurements. Otherwise, select the Manual option and
type a value for the Ambient Air temperature.

• Click the  button and select the device to which a temperature sensor is
connected

• Select Ambient Air Temperature source associated with the selected device. In a
Rosemount Tank Gauging system the associated temperature transmitter has to
be configured in the tank database of the Rosemount 2410 Tank Hub.

• Choose a specific sensor to be used for Ambient Air Temperature.
• The Value Range defines the minimum and maximum values when Ambient Air

Temperature is manually entered.

5. Click the OK button to save the current setting and close the window.
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3.2.3  Inventory
Local Gravity and Ambient Air Density calculations are used for automatic density
measurements.
Procedure

1. Select the desired server (e.g. “This Workstation”) in the WinSetup workspace.
2. Click the right mouse button and choose Setup, or from the Service menu choose

Servers → Setup.
3. In the Sever Preferences window select the Inventory tab.

4. Local Gravity is used for density and weight calculations when an optional pressure
transmitter is installed.

Local Gravity Calculation Option
Manual Allows you to use a specific value for the Local Gravity.
Calculated If you want the local gravity to be calculated by

TankMaster. In this case you need to enter the
Latitude and Elevation of the site.

5. Ambient Air Density is used for calculating Observed Density and Weight in Air
(WIA).

Ambient Air Density Option
Manual Allows you to use a specific value for the Ambient Air

Density.
Calculated If you want the Ambient Air Density to be calculated

by TankMaster. The calculated value is based on the
Base Density and the Ambient Air Temperature.

6. Click the OK button to save the current settings and close the window.
Related information
Rosemount TankMaster WinOpi Reference Manual
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3.2.4  Miscellaneous
The Server Preferences Miscellaneous window lets you change parameters such as type of
Tank Capacity Table, Reference Temperature, and number of digital alarms.
Procedure

1. Select the desired server (e.g. “This Workstation”) in the WinSetup workspace.
2. Click the right mouse button and choose Setup, or from the Service menu choose

Servers → Setup.
3. In the Server Preferences window select the Miscellaneous tab.

4. Choose the type of Tank Capacity Table (TCT) to be used as default setting when
installing new tanks. The default TCT type will automatically be chosen when
strapping tables are created for new tanks. However, the TCT type can be changed
when the strapping table is specified in the Tank Capacity Setup window regardless
of the settings in the Server Preferences window.
You can choose between TCT type Raw, Raw Comp, International, and Northern.

5. Specify the maximum number of Digital Alarms that will be used.
6. Specify the Reference Temperature to be used for inventory calculations. Normally,

the standard value 15 °C (59 °F) is used.
7. Click the OK button to save the current settings and close the window.

Related information
Rosemount TankMaster WinOpi Reference Manual
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3.2.5  Setting the name tag prefixes
TankMaster WinSetup allows you to specify default name tag prefixes that will appear
automatically when installing new tanks and devices. Note that Tank Tag must begin with a
letter. These prefixes can be ignored if you want to use other prefixes instead.
Procedure

1. From the Service menu choose Preferences.
2. In the Preferences window select the Tag Prefixes tab.

3. Type the prefixes to be used for tank names and device names. and click the OK
button.
You can change the prefixes later at any time. Note that this will not affect names of
existing tanks and devices.
The following characters should not be used when naming objects in TankMaster as
this may cause undesirable results:
Table 3-1: Illegal Characters

\ Reverse solidus % Percent symbol
/ Solidus < Less-than symbol
? Question mark > Greater-than symbol
* Asterisk { Left curly bracket
[ Left square bracket } Right curly bracket
] Right square bracket ' Apostrophe
| Vertical line " Quotation mark
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3.2.6  E-mail configuration
TankMaster WinSetup allows you to setup an e-mail client for alarm notifications and
reports.
Procedure

1. From the Service menu choose Preferences.
2. In the Preferences window select the E-mail Configuration tab.

3. Enter the following information:
Item Description
SMTP Server Specify an SMTP server for outgoing messages. Contact

your LAN administrator or Internet Service Provider (ISP) for
details.

Sender Address The e-mail account which will send e-mails from the current
workstation must be located on the specified SMTP server.

SMTP Port Optional. Contact your LAN administrator or ISP for details.
Authentication Configuration Select this option and enter a Login name and Password if

authentication is required on the mail server.
Contact your LAN administrator or ISP for details.

Channel Security
Configuration

Select this option if the e-mail client requires the use of
channel security.
Contact your LAN administrator or ISP for details.

Subject Enter a title for an e-mail alarm notification. This subject is
only used for Alarm notification and is optional. This subject
will not be used for other e-mails sent from the built-in e-mail
client.
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3.2.7  Tank view layout
The Setup Tank View tab is used to specify variables to be presented in the Tank View
window.
TankMaster WinSetup allows you to create a new tank view layout and store it on disk, or
load an existing table layout from disk.
Procedure

1. From the Service menu choose Preferences.
2. In the Preferences window select the Setup Tank View tab.

3. Click the Load Table button if you wish to edit an existing Table Layout.
4. In the Available Parameters pane on the left-hand side of the Preferences/Setup

Tank View window, select the parameter to be presented in the Tank View window.
5. Click the Move button to move it to the Selected Parameters pane on the right-hand

side of the Preferences/Setup Tank View window.
6. Repeat for each parameter you wish to include. The Move All button allows you to

move all variables at once to the Selected Parameters list box.
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7. Ensure that all parameters to appear in the Tank View window are included in the
Selected Parameters list box as illustrated below:

8. Click the Save As button if you wish to store the current tank view table for future
use.

9. Click the OK button to save the current Tank View settings and close the window.
Note
when clicking the Apply or the OK button, the parameter setup is stored in the table
layout that is currently used by the Tank View window.
To view the result in Tank View with specified parameters, click the right mouse
button and choose the Open Tank View option:

Related information
Viewing tank data
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3.2.8  Tank visibility
The Tanks Visibility tab lets you configure tanks on a tank server to make them visible on
the current TankMaster client.
Procedure

1. From the Service menu choose Preferences and select the Tanks Visibility tab:

2. Select the Enable Tank Visibility function check box.
3. From the Select tank server drop-down list, select the remote tank server on which

the tanks are installed.
4. In the Select tanks to be visible on this workstation pane, check the tanks you wish

to make visible on the current workstation. In the default setting all tanks are visible.
5. Choose the Visible on this workstation option to make new tanks visible on the

current workstation.
6. Click the OK button to store the current configuration and close the Preferences

window.
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7. Figure 3-3 and Figure 3-4 show result in the WinSetup workspace when tank visiblity
is enabled and disabled, respectively:

Figure 3-3: Tanks Visiblity Enabled for All Tanks

Figure 3-4: One Tank Disabled from Visiblity (TK-X)
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3.3  Device installation
The WinSetup device installation wizard guides you step-by-step through the installation
procedure. See the respective device manuals and the Rosemount System Configuration
Manual for comprehensive information on how to install various devices in a Rosemount
Tank Gauging system.
Related information
Rosemount Tank Gauging System Configuration Manual

3.3.1  Device installation via devices folder
Procedure

1. Select the Devices folder.
2. Click the right mouse button and choose Install New from the popup menu, or from

the Service → Devices menu choose Install New.
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3.3.2  Device installation via server
Procedure

1. Select the server where your system is installed.
2. From the File → Install New menu choose Device.
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3.4  Tank installation
The purpose of the tank installation procedure is to associate various devices to the right
tanks. It also includes mapping variables such as Free Water Level and Vapor Pressure to
specific instrument outputs.

Figure 3-5: Tank and associated devices

Prerequisites
Note
Make sure that measurement units are specified before installing a new tank.
The specified measurement units only affect installation of new tanks. Changing
measurement units has no effect on tanks which are already installed in WinSetup. This
means that if you want to change measurement units for an installed tank, it has to be
uninstalled first, and then installed again after changing the measurement units in the
Server Preferences/Units window.

Installing a new tank is a simple and straightforward procedure when using the tank
installation wizard.
Procedure

1. In the TankMaster WinSetup workspace, select the Tanks folder.
2. Click the right mouse button and select Install New from the popup menu, or from

the Service → Tanks menu, choose Install New.
3. Specify desired tank type: Fixed Roof, Floating Roof, Sphere, Horizontal or any other

suitable tank type.
4. Select which devices to associate with the tank.
5. Configure the tank. For inventory calculations you will need to specify source signals

for Free Water Level (FWL), Vapor Temperature, Vapor Pressure and Liquid Pressure.
6. Specify input for the different tank variables: automatic (measured by a field device)

or manual values.
Related information
Rosemount Tank Gauging System Configuration Manual
Measurement units
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3.5  Level gauge calibration
A minor level gauge adjustment may be needed in order to accurately match measured
and actual product levels. For example, a deviation may result from minor errors in
tank geometry parameters such as the tank height (R) or the position of the Gauge
Reference Point (see the Rosemount 5900S Radar Level Gauge reference manual, for more
information on tank geometry).
The Rosemount 5900 can be calibrated by using the Calibration Distance parameter. It can
be manually adjusted in the 5900 Properties/Geometry window.
For Still-pipe applications, you may use the Calibrate function to automatically calculate
an optimized Correction Factor and Calibration Distance based on measurement data and
hand dipping at different product levels.
Procedure
To access the Calibrate function, select the level gauge icon in the WinSetup workspace,
click the right mouse button and choose Calibrate, or select Calibrate from the Service/
Devices menu:

Related information
Rosemount 5900S Reference Manual
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3.6  Tank capacity
The tank geometry can be defined in a strapping table; the Tank Capacity Table (TCT). The
TCT is used to convert a product level to the corresponding volume. Different TCT types can
be specified: Raw; International, and Northern.
To open the Tank Capacity Setup window:
Procedure

1. Select the desired tank in the WinSetup workspace window.
2. Click the right mouse button and select the Tank Capacity option.

The Tank Capacity Setup window lets you configure the desired type of tank capacity
table (strapping table).
Floating roof specific parameters can be configured by selecting the Roof Setup
button.

Related information
Rosemount TankMaster WinOpi Reference Manual
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3.7  Tank Entry
The Tank Entry window is used for specifying a number of product parameters to be used
for inventory calculations. TankMaster can use measured data, or data that is manually
entered.
Procedure

1. In the WinSetup workspace select the tank to configure.
2. Click the right mouse button and choose the Tank Entry option:

3. To enter manual values, select the check box and type the desired value in the input
field. Manual values are marked yellow.

Related information
Rosemount TankMaster WinOpi Reference Manual
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4  Device handling
4.1  To change device configuration

Once a device is installed and configured, you can modify the current settings at any time
by opening the Properties dialog.
Procedure

1. In the Rosemount WinSetup workspace window select the desired device.
2. Open the Devices folder and select the device icon.
3. Click the right mouse button and choose the Properties option, or from the Service

menu choose the Devices/Properties option.
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4. The device properties window (5900S RLG Properties window in this example)
appears with various tabs allowing you to change the current device settings.

Multiple tabs are available for configuration of communication parameters, tank
geometry, device specific parameters and advanced configuration options. Some of
the tabs refer to the different steps in the device installation wizard. Similar dialogs
are available for other device types as well, for example the Rosemount 2410 Tank
Hub.

Related information
Basic functions
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4.2  To uninstall a device
A device can be uninstalled from the WinSetup workspace at any time. The associated tank
must be uninstalled first. As an alternative you may keep the tank by disconnecting the
device from the associated tank before the device is uninstalled.

4.2.1  Uninstall a device and associated tank
Procedure

1. Start by uninstalling the associated tank (see the Rosemount Tank Gauging System
Configuration manual for more information).

2. In the WinSetup workspace, select the device, click the right mouse button and
choose the Uninstall option.

Now the device will be removed from the WinSetup workspace.

4.2.2  Uninstall a device without uninstalling the tank
If you prefer to keep the tank, you can disconnect it from the device and then uninstall the
device.
Procedure

1. In the WinSetup workspace, select the desired tank and click the right mouse
button.

2. Choose the Properties option and select the Configuration tab.
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3. In the Tank Configuration window, click the Change button.

4. In the right-hand side of the Select Devices window, select the device and click the
 arrow button. Then the device will be removed from the Selected Devices pane

to the Available Devices pane on the left-hand side. This means that the device is no
longer associated with the tank.

5. Click the OK button.
6. Open the Tanks folder.
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7. Verify that the device (LT-TK-1 in this example) is no longer associated with the tank.

8. Open the Devices folder:

9. Select the device and click the right mouse button.
10. Choose the Uninstall option.

Now the device will be removed. However, the tank is still available in the WinSetup
workspace.
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5  Service functions
5.1  Safety messages

Instructions and procedures in this section may require special precautions to ensure
the safety of the personnel performing the operations. Information that potentially raises
safety issues is indicated by a warning symbol ( ). Refer to the following safety messages
before performing an operation preceded by this symbol.

 WARNING
Failure to follow safe installation and servicing guidelines could result in death or
serious injury.
Ensure only qualified personnel perform the installation.
Use the equipment only as specified in this manual. Failure to do so may impair the
protection provided by the equipment.
Do not perform any service other than those contained in this manual unless you are
qualified.

 WARNING
High voltage that may be present on leads could cause electrical shock.
Avoid contact with the leads and terminals.
Ensure the mains power to the device is off and the lines to any other external power
source are disconnected or not powered while wiring the device.

Reference Manual Service functions
00809-0100-5110 November 2023

Rosemount TankMaster 67



5.2  System status
The System Status Overview shows status and properties for the overall system, Tank
Server, Protocol Servers, and devices.
Procedure

1. Select a workstation in the Workspace window.
2. Click the right mouse button and choose System Status Overview, or from the

Service menu, choose Servers → System Status Overview.
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5.3  Customizing the Tools menu in WinSetup
Procedure

1. Choose the Tools → Applications menu option to open the Customize window.

2. Click the Add button to add a new menu option to the Tools menu.
3. In the Menu Text field type the text you would like to appear in the Tools menu.

Example
In this example menu option WinOpi is added to the Tools menu.
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4. Press the  button next to the Command field.

5. Browse to the program file that will be associated with the new Tools menu option
as given in the Menu Text field.

6. Click the Open button and return to the Customize window.
7. In the Arguments field, type any argument that you want to add to the command

line. This line is usually left blank.
8. Click the OK button.
9. In the Tools menu, choose the new menu option and verify that the associated

application starts as expected.
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5.4  Viewing input and holding registers
In a Rosemount Tank Gauging system, measurement data is continuously stored in Input
registers of devices such as the Rosemount 2410 Tank Hub, Rosemount 5900S Radar Level
Gauge, and other devices. By viewing the input registers of a device, you can verify that the
device is working properly.
Holding registers store various device parameters used to control measurement
performance.
Procedure

1. In the WinSetup Workspace, select the device icon.

2. Click the right mouse button, or open the Service → Devices menu, and choose the
View Input Registers or View Holding Registers option.

3. Registers Type:
• Choose Predefined if you would like to see a commonly used selection of

database registers.
• For advanced service the All option allows you to view a specific range of

registers. Specify a start value in the Start Register input field, and the total
number of registers to be displayed in the Number of Registers field (1-500).
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4. The Registers Scope drop-down list has three options:
Scope Description Access level
Basic Standard setting that

includes the most commonly
used registers

View only

Service Includes a wider range of
registers for advanced service
and troubleshooting

Supervisor

Developer For advanced users only Administrator

5. In the Show Values in pane, choose the appropriate register format Decimal or
Hexadecimal.

6. Click the Read button to upload the contents of the device database registers.
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5.5  To edit holding registers
Most Holding registers can be edited simply by typing a new value in the appropriate Value
input field. Some holding registers (marked grey in the Value column) can be edited in a
separate window. Then you can choose from a list of options or you can edit separate data
bits.
Procedure

1. In the WinSetup Workspace, select the device icon.

2. Click the right mouse button, or open the Service → Devices menu, and choose the
View Holding Registers option.
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3. To change the contents of input fields with white background color in the Value
column, put the cursor in the field and type a new value.
To change input fields with grey background color, double click the field to open a
new window for editing. Depending on the type of Holding register, an Expanded
Enumerated or an Expanded Bitfield window is opened. Select from the list of
options (Expanded Enumerated) or change the appropriate data bit (Expanded
Bitfield).
Example
Expanded Enumerated.

Example
Expanded Bitfield.

4. Click the Apply button to store the register data, or click the Close button to store
and close the window.
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5.6  Viewing diagnostic registers
The View Diagnostic Registers window shows a predefined set of diagnostic Input and
Holding registers. Each device has a standard set of diagnostic registers which can be
changed in the Configure Diagnostic Registers window.
Procedure

1. Select the device icon (for example a Rosemount 2410 or Rosemount 5900) in the
TankMaster WinSetup workspace.

2. Click the right mouse button and choose View Diagnostic Registers.

Register values in this window are of read only type. They are loaded from the
device as the window is opened.
Table cells with grey background color in the Value column represent registers of
either Bitfield or ENUM type. An expanded Bitfield/ENUM window can be opened
for these register types. Double-click a cell to open the Expanded Bitfield/ENUM
window.
Registers of Bitfield and ENUM type can be presented in hexadecimal format by
selecting the Show in Hex check box.
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It is possible to view diagnostic registers for devices of the same type without
closing the window and opening it again for a new device. Press  or 
buttons to step to the next or previous device. Alternatively, another device can be
selected from the drop down menu on the left-hand side of the View Diagnostic
Registers window.
The Configure button lets you specify a default setting of diagnostic registers.
The Log Setup button provides easy access to the Register Log Scheduling window,
which allows you to setup a log schedule for automatic start and stop of register
logging.
The Print button lets you print the current register information.

Related information
Configure
Logging measurement data

5.6.1  Configure
The Configure button in the View Diagnostic Registers window opens the Configure
Diagnostic Registers window which allows you to change the default selection of
diagnostic registers. You can use this option to setup the View Diagnostic Registers
window for the selected device type.

Procedure
1. In the Registers Type pull down menu, choose Holding or Input registers. Input

Registers are displayed in blue, Holding Registers in black.
2. The Group Prefix drop down menu lets you filter the list in the left pane.

Note
The Group Prefix feature is not supported for all device types.

3. A standard selection appears automatically in the Selected Registers pane on the
right-hand side of the Configure Diagnostic Registers window. To add a register to
the list, select it in the left pane and press the  button.
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To remove a register from the right pane, select it and press the  button.
4. The order in which registers are displayed in the View Diagnostic Registers window

can be configured. Select a register in the right pane and press  to move it
upwards, or  to move it downwards in the list.

5. Press OK to store the current configuration.

5.6.2  Restore to default setting
In case you wish to restore the View Diagnostic Registers window to the default setup,
you need to remove the file that contains the current configuration data for the View
Diagnostic Registers window.
Procedure

1. In Windows Explorer open the following folder:
C:\Rosemount\TankMaster\Setup\Data, where C:\ is the drive letter associated with
the hard disk on which TankMaster is installed.

2. Locate the configuration file for the device whose diagnostic register setup you wish
to restore:
Device Configuration file
2410 Tank Hub R2410_diag.ini
5900S Radar Level Gauge R5900_diag.ini
2240 Multi-Input Temperature Transmitter
and Auxiliary Tank Devices (ATD)

R22XX_diag.ini

3. Remove the *.ini file, or rename it in case you wish to store the file for future use (for
example R2410.old).

4. Start TankMaster WinSetup and open the View Diagnostic Registers window to
verify that the View Diagnostic Registers window shows the default setting of
diagnostic registers.
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5.7  Logging measurement data
Logging of diagnostic registers can be a useful tool for verifying that a gauge works
properly. The logging function can be accessed by using the TankMaster WinSetup
program.
Procedure

1. Start the TankMaster WinSetup program.
2. Select the device icon in the WinSetup workspace.
3. Click the right mouse button and choose Logging.

4. The Manual mode lets you start logging at any time. In Automatic mode you have to
specify a Start and Stop time.

5. The resulting log file(s) will not exceed the size specified by the Max File Size
parameter.
• In Automatic mode logging will proceed until the Stop Date and Time is reached.
• In Manual mode logging will proceed until the Stop button is pressed.
• Logging will stop automatically when the number of log files is equal to the

number given by the Max Log Files parameter.
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6. The log file is stored as a plain text file and can be viewed in any word processing
program. It is stored in the following folder: C:\Rosemount\Tankmaster\Log, where
C is the disk drive where the TankMaster software is installed. The log file contains
the same input registers as the View Diagnostic Registers window. You can change
which input registers to be included in the log file by configuring the View
Diagnostic Registers window, see “Viewing diagnostic registers” on page 65 for
more information.

Related information
Viewing diagnostic registers
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5.8  Saving and loading database registers
Input Registers and Holding Registers of the Rosemount 5900 and the Rosemount 2410
can be stored on disk. This can be useful for backup purposes and troubleshooting. Input
and Holding registers can be saved for a single device or several devices simultaneously.

5.8.1  To save device registers for a single device
Procedure

1. Start the TankMaster WinSetup program.
2. In the TankMaster WinSetup workspace window, click the right mouse button on the

device icon.
3. Choose the Save Database to File option, or from the Service menu choose Devices 

→ Save Database to File.

4. Select Holding/Input registers (the Holding Register options is shown in the
example above for demonstration).

5. Choose the Predefined Registers or the User-Defined option.
• The Predefined option stores the most frequently used registers.
• The User-defined option stores a specified range of Holding registers and should

only be used for advanced service.

6. For the Predefined Registers option you may choose the desired Scope; All
Registers or Basic Registers. Basic is a limited number of registers mostly related
to configuration parameters for the device.

7. Optional: The Save Modified Values Only check box lets you save only those
registers that have been modified. It will be shown if the function is supported for
the device type, but may remain disabled if the device version is not supported.

8. Click the Browse button, select a folder and type a file name.
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9. Click the Save button to start saving the configuration database to file.

5.8.2  To save device registers for multiple devices
Procedure

1. In the TankMaster WinSetup workspace, select the Devices folder.
2. Click the right mouse button and choose the Save Database of All to Files option, or

from the Service menu choose Devices → Save Database of All to Files.

3. Select a device from the Available Devices pane and click the Add button in order
to move it to the Selected Devices pane. Repeat for all devices you would like to
include.

4. Select register type: Holding or Input registers.
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5. Choose the Predefined Registers or the User-Defined option.
• The Predefined option stores the most frequently used registers.
• The User-defined option stores a specified range of Holding registers and should

only be used for advanced service.

6. Click the Browse button, select a folder and type a file name.
7. Click the Start button to save the database backup.

5.8.3  To recover a device database
TankMaster WinSetup offers the option to replace the current holding register database
with a backup database stored on disk. This can be useful, for example, when recovering
configuration data.
Procedure

1. Select the device icon in the WinSetup workspace.
2. Click the right mouse button and choose the Upload Database option, or from

theService menu choose Devices → Upload Database.

3. Type a file path and file name, or click the Browse button and choose a backup
database file to be uploaded.

4. Click the Upload button to start uploading the recovery database.
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5.9  Upgrading device firmware
TankMaster WinSetup supports firmware upgrade for Rosemount Tank Gauging level
gauges and temperature transmitters.
Note
In case the current program version is significantly older than the new one, it is
recommended that you load the default configuration database once the device is
reprogrammed. Contact Emerson if you need further advice.

Procedure
1. Make sure the devices are properly prepared for reprogramming (normal operation

and no warnings or errors).
2. In the WinSetup Workspace, select the Devices folder. (For a single device, select the

device in the Devices folder).
3. Click the right mouse button and choose the Program All option, or from the Service

menu, choose Devices → Program All.
(For a single device, choose the Program option, or from the Service menu, choose
the Devices → Program option).

4. Select the device to be programmed from the Available Devices pane and click the
Move button. Repeat for each device of the same type to be programmed. Note that
if a single device was selected in the Workspace window, it will appear automatically
in the Program These Devices pane.
Use the Remove button if you would like to change the list of devices to be
programmed.

5. Click the Browse button to locate the appropriate software file.
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6. Click the Start Programming button to open the Start Device Programming window.

7. Click the Start Programming button to activate device programming.
Related information
Rosemount 5900S Reference Manual
Rosemount 2410 Reference Manual

Service functions Reference Manual
November 2023 00809-0100-5110

84 Emerson.com/Rosemount

https://www.emerson.com/documents/automation/81142.pdf
https://www.emerson.com/documents/automation/104484.pdf


5.10  Tank Scan
The Tank Scan window allows you to view tank echoes. Then you may setup the most
important parameters to enable separating surface echoes from disturbing echoes and
noise.
Procedure

1. In the WinSetup workspace, select the gauge icon.

2. Click the right mouse button and choose the Properties option.
3. Select the Advanced Configuration tab and click the Tank Scan button.
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4. The Tank Scan window contains the Graph Area, Legend/Options area, File Storage
buttons, and various action buttons.
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5.10.1  Graph area
When the Tank Scan window opens, WinSetup reads tank data from the gauge. The
process is indicated by a progress bar in the lower right corner of the Tank Scan window.

Once the reading process is finished, a tank scan graph is displayed that shows a peak
referring to the product surface. The Tank Scan graph may also contain other peaks. In
addition to the surface echo, there might be echoes from agitators or other obstacles in
the tank.
The Tank Scan function includes tools that allows you to configure the level gauge to
distinguish between the surface peak and peaks from disturbing objects. See the following
chapters for details.
The Tank Scan graph can be refreshed at any time with the Reread From Gauge button.
The new echo curve will appear as a black line and the previous curve as a grey line. The
graph may show up to two old echo curves. An old echo peak will be marked by a small
cross symbol. This can be used to compare the existing tank signal with previous signals.
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5.10.2  Legend/Options
The following items can be shown in the graph area (check the appropriate box for each
Legend/Option to show):
Tank Echo
The black line shows the latest Tank Echo curve, and the grey lines show previous Tank
Echo curves (maximum two).

General Threshold
The General Amplitude Threshold is shown in blue. Echoes with an amplitude below the
General Amplitude Threshold will be filtered out by the level gauge.

False Echo Areas
The False Echo function is used to improve the performance of the gauge when the surface
is close to a horizontal surface of a stationary object in the tank. The object causes an echo
when it is above the surface. Added False Echo Areas are shown in grey.
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ATP (Amplitude Threshold Points)
A weak disturbing echo can be filtered out by creating a curve of Amplitude Threshold
Points.

Holdoff Distance
The Holdoff Distance defines how close to the Gauge Reference Point a level value is
accepted. The Holdoff Distance is shown in red.

Gauge Ref. Point (Gauge Reference Point)
The Gauge Reference Point is shown as a dashed (olive colored) line.

Zero Reference
The Zero Reference (zero level; dipping datum point) close to the bottom of the tank, is
defined by the Tank Reference Height (R). It is shown as a dashed (sand colored) line.

Tank Bottom
The Tank Bottom is shown in red.
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Echo Peaks
Echo Peaks are shown in black for the Surface Echo and in green for unknown echoes.

Peak Labels
Peak Labels are shown for the Surface Echo and for unknown echoes.

Previous Peaks
Previous Peaks are shown for the Surface Echo and for unknown echoes.
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5.10.3  Tank Scan file storage
The Tank Scan window supports saving on disk the tank scan data that is displayed in the
graph area.
Procedure

1. In the Tank Scan window click the Save button.

2. Enter a name to identify the tank scan data. You may also type a comment in the
Comment field (not required). This can for example be used to describe any special
circumstances under which the Tank scan data was obtained.

3. Press the OK button.
Note
The default data storage file is named StrTankScanII.dat. The file is stored in the
following folder: C:\Rosemount\TankMaster\Lib\Data.

Export tank scan data to an external file
Tank scan data can be saved to file for viewing with the Tank Echo Viewer (Tools>Tank
Echo Viewer).
Procedure

1. In the Tank Scan window click the Save button to open the Save Tank Scan Data
window.

2. Enter a name to identify the tank scan data. You may also type a comment to
describe any special circumstances when the Tank scan data was obtained.

3. Press the Advanced button.

4. Select the Export tank scan data to external file check box.
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5. Press the Browse button.

6. Browse to a destination folder and type a name in the File name input field.
7. Press the Open button.

8. Press Yes to create the file.

9. Press OK.
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10. Press OK to export tank scan data to the file.

To load tank scan data from file
Procedure

1. In the Tank Scan window press the Stored Echoes button.
2. Select the file to be loaded.

3. Press the Load button.

To delete a saved file
Procedure

1. In the Tank Scan window press the Stored Echoes button.
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2. Select the file you want to delete.

3. Press the Delete button.

5.10.4  Action buttons
The following buttons can be found in the Tank Scan window.
Save Lets you save current tank scan data.
Stored
Echoes

Lets you load stored tank scan data that was stored with the Save command.

Reread
From Gauge

At any time, you can refresh tank echo and echo peaks with the Reread
From Gauge button. The Tank Scan will display the new echo curve as a
black line, and up to two previous echo curves in grey color. The previous
echo peaks will appear with small crosses.

Print Opens the print dialogue and prints the Tank Scan window.
Apply When changing a parameter that affects echo peak detection (e.g. General

Amplitude Threshold), you will have to press the Apply button to write these
settings to the internal memory of gauge. It takes a few seconds for the
gauge to update the echo peak data (up to 30 seconds due to the echo peak
filtering function in the gauge). Finally, press the Reread from Gauge button
to update the echo peak information in the graph area.

OK Applies changes and closes the window.
Cancel Cancels all changes.
Help Opens the online help for the current window.

Related information
Tank Scan file storage
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5.10.5  Tank Scan editing
All the elements having handles can be edited. Each handle may be moved by using the
mouse pointer

Figure 5-1: Editing the Tank Scan window

A. Handles for moving or right-click editing
B. Properties window

Clicking the right mouse button on a handle opens a dialog window. The Properties option
allows you to review or change parameter values. The following parameters can be edited
via moving or right-clicking a handle:
• General Amplitude Threshold
• Amplitude Threshold Point
• False Echo Area
• Hold Off Distance
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To add a False Echo Area or an Amplitude Threshold Point
Procedure

1. Click the right mouse button in the graph area where you would like to add a False
Echo Area or an Amplitude Threshold Point:

2. Select a menu item in the popup menu. In the example above, the New False Echo
Area option was chosen:

3. Enter the new data and click the OK button.

To delete a False Echo Area or Amplitude Threshold Point
Procedure

1. Right-click the handle of the False Echo Area or Amplitude Threshold Point to be
deleted:

2. Select the Delete False Echo Area (or Delete Amplitude Threshold Point) option.
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5.11  Viewing tank data
TankMaster WinSetup offers the option to view data from a single tank or a group of tanks.
Various parameters such as Level, Level Rate, and Average Temperature can be displayed.
The Setup Tank View window lets you specify the desired set of parameters.
Related information
Tank view layout

5.11.1  Viewing data for all tanks
Procedure

1. In the WinSetup workspace, select the Tanks folder.
2. Click the right mouse button and choose Summary Tank View, or from the Service

menu choose Tanks/Summary Tank View.

3. Select the All Tanks tab for a complete list of all tanks, or select a view that includes
a bar graph for one tank at a time by selecting the appropriate tab.
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5.11.2  Viewing data for a single tank
Procedure

1. In the WinSetup workspace, select the desired tank icon.

2. Click the right mouse button and choose the Open Tank View option, or from the
Service menu choose Tanks/Open Tank View.
Measurement data for the selected tank is displayed in the Tank View window.
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5.12  Viewing alarm status
TankMaster WinSetup lets you view alarm status for all tanks, a certain tank group, or a
single tank.

5.12.1  Alarm status for all tanks
Procedure

1. In the WinSetup workspace, select the TankMaster workstation (or the Tanks folder)
where the tanks are installed.

2. From the View menu, choose Alarms. The Alarm Status window presents a list of
alarms for all the tanks connected to the selected TankMaster workstation.
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5.12.2  Alarm status for a single tank
Procedure

1. Open the Tanks folder and select the desired tank.

2. From the View menu choose Alarms. The Alarm Status window presents the current
alarms for the selected tank.
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5.13  Protocol handling

5.13.1  Logging the channel communication
WinSetup allows you to log communication on the various communication protocol
channels. You can log specific devices, as well as filter out certain function codes and error
types.
Procedure

1. In the WinSetup workspace, select the protocol channel icon.
2. Click the right mouse button and choose the View Log option, or from the Service

menu, choose Channels/View Log.

3. Specify a log profile. You can filter out certain function codes and devices as well as
error types as shown in Table 5-1.

Note
This window lets you setup a profile for realtime logging. However, each time
the Realtime Log Settings window is opened, it is configured as specified in the
Properties/File log window which lets you setup a profile for saving the log to file.
Table 5-1: Realtime log settings
Filter setting Description
Function Code A Function Code defines a specific action or type of data. You can log

all function codes or a specific code.
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Table 5-1: Realtime log settings (continued)
Filter setting Description
Device Address You can log all devices or a device with a certain address by your own

choice.
Note
The device address is automatically copied from the current settings
in the File Log Settings window. You can change this address to any
other address that you want to log.

Enable Filtering Mark this check box to enable filtering by function codes and
addresses.

Errors Select the check box for the type of error you like to record: Time-out
Errors, Check Sum Errors, or Other Errors. You can select one or
more check boxes.

Number of messages Specify the number of messages that will be added each time the
Communication Log window is updated. If the log is updated too
quickly, you may increase the number of messages value to reduce
the update speed.

4. Click the OK button to open the Communication Log window.
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5. By clicking the right mouse button in the Channel Communication Log window you
will get access to a number of useful options:
The Save As option lets you save the current log to file.
Choose the Log Setup option if you want to change the filtering settings.

Related information
Saving the communication log to file
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5.13.2  Saving the communication log to file
Procedure

1. Select the protocol channel icon.

2. Click the right mouse button and choose Properties, or from the Service menu
choose Channels/Properties.

3. Select the File Log tab.
4. Type a name of the log file in the File Name field and set the Maximum File Size to

limit the amount of disk space required for storing log files.
The Maximum File Size option can be used in combination with the Multiple Log
Files option in order to store the log files on a number of floppy disks.
The log file will be stored in the following folder:
PC Operating System Log file folder
MS Windows 7 and higher
versions

C:\Rosemount\TankMaster\Log

Note
If the maximum number of files is reached, TankMaster will replace existing log files.

5. The Multiple Log Files section allows you to optimize file size for storing on floppy
disk. Choose the One File option if you prefer the log to be stored in a single file.
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By choosing the Several Files radio button, logging continues by creating new files
whenever the size of the current log file reaches the Maximum File Size value. When
using the Several Files option, also set the Max Log Files parameter to define the
maximum number of log files to be created.

6. Set the Log Schedule.
Manual Select Manual and click the Start button to start logging. The logging

will stop when the Stop button is pressed, or the Maximum File Size
is reached.

Automatic
Stop

Set the Date and Time at which you want the logging to stop. Press
the Start button to start the logging. The logging will stop when the
set Date and Time is reached, the Stop button is pressed, or the
Maximum File Size is reached.

7. Click the Advanced button if you would like to specify filtering options.

8. To restrict logging to a certain function code and/or a certain device address, select
the Enable Filtering by Function Codes and Addresses check box.

9. Choose the Selected Function Code option if you would like to log a specific
function.
FC2 Read Inputs
FC3 Read Holding Registers
FC4 Read Input Registers
FC6 Write Single Register
FC8 Diagnostics
FC13 Program
FC14 Poll program complete
FC16 Write Multiple Registers
FC17 Report Slave ID
FC65 Change address

10. Choose one of the device address options; Any Address or Selected Address.
Choose Selected Address if you want to log communication to a certain device.

11. Specify what type of errors to be logged by selecting the appropriate check boxes.
You can choose one or more error types to be logged simultaneously.
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12. Click the OK button.
Related information
Logging the channel communication

5.13.3  Searching for connected devices
Procedure

1. In the WinSetup workspace, open the Protocols folder and the appropriate protocol
sub folder.

2. Select the desired protocol channel.
3. Click the right mouse button and choose the Find Devices option, or from the

Service menu choose Channels/Find Devices.

4. Type the desired values in the First and Last address input fields in order to restrict
the search to a certain range of addresses (maximum range is 1-255).

5. Click the Start button. Now the fieldbus is scanned for devices within the specified
address range.
The search result is a list of name, type, address, unit id and application software
version of each device that was found.

Service functions Reference Manual
November 2023 00809-0100-5110

106 Emerson.com/Rosemount



Related information
Communication protocol setup

5.13.4  Channel statistics
The Protocol Statistics function is a tool which can be used to check the quality of
communication between the TankMaster workstation and the connected field devices.
Procedure

1. In the WinSetup workspace, open the Protocols folder and the appropriate protocol
sub folder.

2. Select the desired channel.
3. Click the right mouse button and choose the Statistics option, or from the Service

menu choose Channels → Statistics.

A. Channel
B. Protocols folder
C. Protocols subfolder
D. Statistics

4. The Channel Statistics window lets you view a summary of messages and various
error types.
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5.14  TankMaster Administrator
The TankMaster Administrator program lets you select which TankMaster programs that
will start automatically when the PC is turned on. It also allows you to check which
TankMaster processes that are currently running.
By using the backup option, copies of the current WinOpi, WinSetup and Tank Server
configurations can be stored. In the event of a PC operating system crash, resulting in
corrupt TankMaster files, these backup files can be used to restore the TankMaster settings
and the registry of the Windows operating system.
To open the TankMaster Administrator, click the icon on the right-hand side of the MS
Windows taskbar:

Figure 5-2: TankMaster Administrator icon in the Windows taskbar.

5.14.1  Log on
The Log on function allows you to make changes in the TankMaster Administrator window.
Procedure

1. Open the TankMaster Administrator window by clicking the Administrator icon on
the right-hand side of the MS Windows Taskbar.
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2. Select the Log on button.

3. Enter the password and select OK.
Note
The default password is admin.

5.14.2  Changing the Administrator program password
Procedure

1. Open the TankMaster Administrator window by clicking the Administrator icon on
the right-hand side of the MS Windows taskbar.

2. Log on to TankMaster Administrator.
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3. Click the Change Password button.

4. Enter the old and new passwords. Confirm the new password and select OK.

5.14.3  Autostart
The Autostart function lets you specify programs to start automatically when the
TankMaster computer is started.
Procedure

1. Open the TankMaster Administrator window by clicking the Administrator icon on
the right-hand side of the MS Windows taskbar.

2. Select the Auto Start Config button to open the Auto Start Configuration window.
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3. Select check boxes for the programs you want to start automatically. Then select the
OK button.

4. The Autostart function will be activated next time the TankMaster PC is started.

5.14.4  Backup
The Backup function can be used to save configuration data for devices and tanks as well
as workspace settings for WinSetup and WinOpi.
Procedure

1. Open the TankMaster Administrator window by clicking the Administrator icon on
the right-hand side of the MS Windows Taskbar.
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2. Select the Backup/Restore button.
The Backup window contains the following:
• Information on when the Last Backup and Last Auto Backup were performed
• Backup data files to create
• File path to destination folder for the backup files
• Auto Backup settings

3. Select which backup data files to create in the Backup data files pane.
• The TankServer option lets you backup tank and device configurations (the Tank

server must be running).
• The Batch Server option lets you backup the batch database files (the Batch

server must be running). Note that the Batch server automatically removes a
batch from the database after a certain number of days, see the TankMaster
Batch Handling Reference Manual for more information.

• The Historical Data option lets you backup any previously created Historical
Data, see the WinOpi User´s Guide for more information.

• The WinOpi and WinSetup options allows you to save the workspace
configuration such as groups, colors, network settings etc.

• The Registry keys for TankMaster option lets you save the TankMaster settings
of the MS Windows registry.

4. In the Backup window, select the desired destination folder by pressing the Browse
button.
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5. In the Browse For Folder window, select the desired file destination. TankMaster
automatically creates subdirectories for WinOpi, WinSetup, and Tankserver files.

6. Select the OK button to close the Browse for Folder window and return to the
Backup window.

7. In the Auto Backup pane, select the Enable check box to enable automatic backup.
Also set Start time and Interval (1-30 days). This will automatically backup the
selected backup data files at the specified start time and interval.

8. Select the Save Configuration button to save the current Backup window settings.
9. Select the Backup Now button if you like to make a manual backup of the selected

items in the Backup data files pane.
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10. Select the Close button.

5.14.5  Restore
If the PC operating system has crashed resulting in corrupt TankMaster files, the
TankMaster settings can be restored by using backup files. The Restore Backup Wizard lets
you restore tank and device configuration, BatchServer data, and Historical data. You may
also restore WinOpi and WinSetup configurations such as groups, color, network settings
etc.
Procedure

1. Check that WinSetup and WinOpi are closed. You may click the Processes button
in the TM Administrator program to check if any TankMaster programs are
running. Note that the TankMaster Administrator program itself also appears in
the Processes window. You may also open the Windows Task Manager to make sure
that TankMaster servers, such as TankServer.exe, are closed.

2. Open the TankMaster Administrator window.
3. Select the Backup/Restore button. The Backup window appears.

4. In the Backup window, click the Restore button to start the Restore Backup Wizard.
5. Click the Next button and follow the instructions. You will be guided through a

step-by-step instruction that lets you specify a folder to store backup files and data
to be restored. You may also create a backup of the current configuration.
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Note
The additional option Create a backup of the current configuration should not be
used if the restore function is used to replace corrupt configuration files.

Note
The additional option Delete old configuration files clears all configuration files
which are not replaced by the Restore function. If this option will be used, it may
be a good idea to backup the current configuration files first, in case you need to
recover the current TankMaster configuration at a later point of time.

Related information
Processes

5.14.6  File version information
The File Details option allows you to view a list of all the files included in the TankMaster
software package. The list presents file versions and brief descriptions.
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Figure 5-3: List of files in TankMaster package

Saving the list of files
The list can be stored by using the Save to File button. The file is stored in text format
which can be opened by any word processing program.

Figure 5-4: List of TankMaster files stored in text file

Note
When entering the filename in the Save to File dialogue, also enter file type txt, e.g. enter
File_Version.txt.
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Verify hash
The Verify hash button lets you check the integrity of the TankMaster files.

Figure 5-5: Example of hash verification

5.14.7  Processes
To view the running TankMaster programs, click the Processes button in the TankMaster
Administrator window:

Figure 5-6: List of running TankMaster processes

The Shutdown TM button lets you close all TankMaster programs except the TankMaster
Administrator. In case a TankMaster client requests data, the TankServer starts up again.
By using the Shutdown TM and Staydown button, the TankServer stays down regardless of
any requests.
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If the Also shutdown administrator check box is selected, the TMAdministrator program is
shut down as well.
Click the Update button to update the contents of the Processes window.
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5.15  Proof test
TankMaster WinSetup has built-in functionality to support proof testing of high level
alarms. You may combine continuous product level monitoring with proof testing at
regular intervals. A step by step proof test guide helps you through selected tests, and
summarizes the result in a test report.
Full high level alarm proof tests using a reference reflector as well as partial proof test such
as analog output/relay output is supported. Depending on tank gauging system different
options are available.

Figure 5-7: Proof Test Menu option in WinSetup

Depending on the particular model code option that is ordered, the Proof Test window may
look different as shown in Figure 5-8.

Figure 5-8: Proof Test windows
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5.15.1  Proof test functions
The Proof Test window lets you perform a number of different tests:
• high level alarm verification using a reference reflector
• high level alarm verification with simulated reference reflector
• One-point level verification by hand dipping to verify automatic level measurements
• analog output verification
• relay output verification
Multiple tests can be performed in a sequence by selecting serveral check boxes in the
Proof Test window. You may for example do a High Level Alarm test with a reference
reflector, followed by a test of the analog outputs of a connected tank hub.
Related information
Rosemount 5900 and 2410 Safety Manual SIL 2
Rosemount 5900 Proof Test Reference Manual
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