Field Tools 3.5 Quick Start Guide
Application Safety Considerations

Protecting Operating Processes
A failure of this application – for whatever reason -- may leave an operating process without appropriate protection and could result in possible damage to property or injury to persons. To protect against this, you should review the need for additional backup equipment or provide alternate means of protection (such as alarm devices, output limiting, fail-safe valves, relief valves, emergency shutoffs, emergency switches, etc.)

System Training
A well-trained workforce is critical to the success of your operation. Knowing how to correctly install, configure, program, calibrate, and trouble-shoot your Emerson equipment provides your engineers and technicians with the skills and confidence to optimize your investment. Remote Automation Solutions offers a variety of ways for your personnel to acquire essential system expertise. Our full-time professional instructors can conduct classroom training at several of our corporate offices, at your site, or even at your regional Emerson office. You can also receive the same quality training via our live, interactive Emerson Virtual Classroom and save on travel costs. For our complete schedule and further information, contact the Remote Automation Solutions Training Department at 800-338-8158 or email us at education@emerson.com.
# Table of Contents

## Section 1: Introduction .......................................................... 5

1.1 What is Emerson Field Tools? .......................................................... 5

## Section 2: Installation ................................................................ 7

2.1 Minimum System Requirements .......................................................... 7
  2.1.1 Notes on USB to Serial Converters ............................................. 7

2.2 Before You Begin ......................................................................... 7
  2.2.1 Disabling User Account Control (UAC) in Windows ..................... 8
  2.2.2 Special Notes for BSI_Config/TechView Users .............................. 9
  2.2.3 Special Notes for OpenBSI users .................................................. 9
  2.2.4 Special Notes for ROCLINK Users ............................................. 10

2.3 Installing Field Tools .................................................................. 10
  2.3.1 Custom Install without User Prompts ........................................... 15

## Section 3: Communication Setup .............................................. 17

3.1 Using Field Tools to Establish a Connection ................................. 17
3.2 Before You Begin ..................................................................... 17
3.3 Starting Field Tools and Logging In ............................................ 18
  3.3.1 Changing the Password .............................................................. 19
  3.3.2 Defining Users ........................................................................ 20
  3.3.3 Adding a User ........................................................................ 20
  3.3.4 Setting a Minimum Password Length ........................................ 21
  3.3.5 Deleting a User ...................................................................... 22
  3.3.6 Assigning RTU Login Credentials ............................................. 22

3.4 Connections List ....................................................................... 23
3.5 Starting an Existing Connection .................................................. 25
3.6 Creating a New Connection to a Device (Controller/Flow Computer) .. 25
3.7 Making a Direct Connection ....................................................... 34
3.8 Active Connection pane ............................................................. 35
3.9 Saving Connections / Importing Connections ............................... 36
3.10 Settings ................................................................................ 37
3.11 Offline Configurations/Solutions Menu ...................................... 38
Section 4: FBxNet

4.1 What is FBxNet? ................................................................. 39
4.2 Licensing FBxNet ........................................................................... 39
4.3 Starting FBxNet ........................................................................... 39
4.4 Synchronizing CSV Files ............................................................... 40
4.5 Switching Between Monitor and Configuration Mode ....................... 40
4.6 How do I configure FBxNet? ............................................................. 40
4.7 Creating a Site................................................................................ 40
  4.7.1 Editing a Site ........................................................................ 40
  4.7.2 Deleting a Site .................................................................... 40
4.8 Creating a Subscriber Directly in FBxNet ........................................... 40
  4.8.1 Editing a Subscriber ............................................................. 40
  4.8.2 Deleting a Subscriber ........................................................... 40
4.9 Adding a Publisher ....................................................................... 40
  4.9.1 Editing a Publisher ............................................................... 40
  4.9.2 Deleting a Publisher ............................................................... 40
4.10 Adding a New Parameter ................................................................. 40
  4.10.1 Editing Existing Publisher Parameters .................................... 40
  4.10.2 Deleting a Parameter ............................................................. 40
4.11 Manually Creating the Subscriber CSV File ..................................... 40
  4.11.1 Subscriber File Format .......................................................... 40
  4.11.2 Subscriber File Example – Created in Excel .............................. 40
  4.11.3 Subscriber File Example – Created in a text editor .................... 40
  4.11.4 CSV File Validation ............................................................... 40
4.12 FBxNet Authentication .................................................................. 40
4.13 Downloading CSV Files ................................................................. 40
  4.13.1 Downloading CSV Files for a Single Site .................................. 40
4.14 Restoring the Backup of Previous CSV Files at the PC ....................... 40
4.15 Making Changes to Your CSV Files ............................................... 40
4.16 Viewing Status of the Subscriber Device ....................................... 40
4.17 Viewing Status of the Publisher Devices ....................................... 40
4.18 Viewing Details on a Single Publisher ............................................. 40
4.19 Modifying FBxNet Configuration Parameters ................................... 40
4.20 Enabling/Disabling Fault Processing .............................................. 40
Introduction

Appendix A – Troubleshooting Tips.................................77

Appendix B - Field Tools Uninstallation Procedure...............85

Index .............................................................................91
Section 1: Introduction

**CAUTION**

When implementing control using this product, observe best industry practices as suggested by applicable and appropriate environmental, health, and safety organizations. While this product can be used as a safety component in a system, it is **not** intended or designed to be the **only** safety mechanism in that system.

This manual provides a brief introduction to Emerson Field Tools and covers software installation and initial communications setup.

For full details on using the Field Tools software, please refer to the online help included in each component application.

1.1 **What is Emerson Field Tools?**

Emerson Field Tools provides a single integrated package for connecting to and configuring ROC, FloBoss™, ControlWave™ flow computers and RTUs, FB1000/FB2000 Series Flow Computers, and FB3000 RTUs.

Field Tools supports either a direct serial connection or an IP connection to a controller or flow computer. You can also connect wirelessly with FB1000/FB2000 Series Flow Computers. In all these cases, you establish communications with the controller using Field Tools’ Connection wizard.

In addition, if you install configuration tools for the controller (ROCLINK, TechView, and/or FBxConnect) Field Tools automatically launches the appropriate tool when you open a connection to a ROC, FloBoss, ControlWave device, an FB1000/FB2000 Series Flow Computer, or an FB3000 RTU.
Section 2: Installation

This chapter covers installation of Field Tools software.

2.1 Minimum System Requirements

For optimal performance, we recommend that your laptop PC meet the following minimum requirements:

- Intel® Core™2 Duo T7100 or similar specification Intel CPU (minimum)
- 2.5 GB available hard disk space to install the full software package
- 8 GB RAM
- 1366 x 768 or better resolution display (OS compatible)
- Windows 7 Professional for either 32-bit or 64-bit (Service Pack 1) or Windows 10 Professional
- Network port can be either:
  - RS-232 Serial port or USB to RS-232 converter (See Section 2.1.1)
  - Ethernet port

Important
Not all components of Field Tools run on all three operating systems.

For details on compatibility of Field Tools with particular hardware, software, and firmware, please refer to the Field Tools Product Data Sheet (D301735X012).

2.1.1 Notes on USB to Serial Converters

USB to RS-232 serial converters vary widely in quality and performance. Users report good results with the following converters:

- BlackBox IC199A
- IOGear® GUC232A
- CHIPI-X10

If you experience problems with your converter, see Appendix A – Troubleshooting Tips.

2.2 Before You Begin

Before you install Field Tools, there are several things you need to know:
Important

- Field Tools cannot reside on a computer running any components of OpenEnterprise 2.x, OpenEnterprise 3.x, OpenEnterprise Client/Server software, or ObjectServer.
- Field Tools 3.5 includes components of BSI_Config (such as TechView) which are from OpenBSI version 5.9 Service Pack 3.
- Field Tools can co-exist on a computer running OpenBSI Network Edition 5.9 Service Pack 2 (or newer). It cannot be installed on a computer running OpenBSI versions older than 5.9 Service Pack 2.
- You must have administrative privileges to install Field Tools.
- If installing TechView, close all other programs down before you begin installation. In particular Office 365 components must be closed because they can interfere with the Field Tools installer.
- If you are using an Enterprise version of the Windows operating system and your administrative privileges do not include read/write access to |ProgramData|Emerson and its sub-folders, these privileges must be set manually by your system administrator.
- You must disable User Account Control (UAC) prior to the installation (you can re-enable it after a successful installation). See Section 2.2.1.
- If you are using an Enterprise version of a Windows operating system with an application blocker, set any EXE files in |Program Files|Emerson to “trusted source.”
- As part of the installation, Eltima device software is installed automatically. Depending upon your permissions, Windows may require you to confirm this installation before the installation can proceed.
- For best results on a PC or laptop, set your Windows Control Panel display settings for smaller fonts (100% default). Larger fonts may cause some screen items to overlap or be cut off.
- For best results on a tablet, set your Windows Control Panel display settings for either smaller fonts (100%) or medium fonts (125% default). DPI should be 100.

2.2.1 Disabling User Account Control (UAC) in Windows

You must disable UAC prior to installing Field Tools. You can re-enable it after successful installation.

1. Click Start > Control Panel to open the Windows Control Panel.
2. Click Action Center.
3. Click Change User Account Control settings.
4. Drag the sliding control down to Never notify and click OK.
2.2.2 Special Notes for BSI_Config/TechView Users

If you have BSI_Config 5.9 (which includes TechView) installed prior to installing Field Tools 3.5 and it is a version older than 5.9 Patch A, the Field Tools installer automatically updates BSI_Config components on your PC to version 5.9 Service Pack 3 (which includes Patch A). If you subsequently reinstall BSI_Config 5.9, you’ll need to manually copy the Field Tools installer version of TechView.exe to the proper installation path on your PC. If you used the default installation paths, you can use the following examples, assuming your PC hard disk is the C drive:

For 64-bit OpenBSI Users:
Copy C:\program files (x86)\emerson\openenterprise\bin\TechView.exe to C:\program files (x86)\bristol\openbsi\n
For 32-bit OpenBSI Users:
Copy C:\program files\emerson\openenterprise\bin\TechView.exe to C:\program files\bristol\openbsi\n
2.2.3 Special Notes for OpenBSI users

Field Tools 3.5 includes components of OpenBSI’s BSI_Config Version 5.9 Service Pack 3. OpenBSI Network edition version 5.9 Service Pack 2 (or newer) can co-exist with Field Tools 3.5. The Field Tools installer does not affect OpenBSI Network Edition. The two programs, however, are not linked together; you cannot for example, launch NetView from Field Tools.
2.2.4 Special Notes for ROCLINK Users

If you have a version of ROCLINK already installed that is older than the version included in the Field Tools installer, Field Tools upgrades it to the version included with the installer. If you have a newer version of ROCLINK already installed when you install Field Tools, Field Tools leaves that as is.

To preserve your existing files, always backup the device directory (which includes the ROC_USER.MDB file) before you install ROCLINK, and then copy it back after the installation completes. The device directory is the folder \Program Files\ROCLINK800.

You can only have three simultaneous ROCLINK connections to devices through Field Tools.

2.3 Installing Field Tools

Field Tools is available as a free download for registered SupportNet users. The installer file follows the format FieldToolsbuildnum.exe where buildnum is the software version build number.

Important

If you are not a registered SupportNet user, activating a new SupportNet account to obtain Field Tools software may take up to 24 hours to process.

If you are installing the Field Tools executable from a network drive, there may be a long delay while the installer extracts and uncompressed files onto the local PC.

1. Right-click on the Field Tools (.EXE) installation file and choose Run as administrator from the pop-up menu.

2. The installation process starts and checks whether certain necessary software components exist on the laptop, and if they are not present, the installation process prompts you to install them. Click Install. This process may take several minutes, and the installer may require you to reboot your PC.
Once installation of the required components finishes, the Field Tools installation wizard starts:

3. Click **Next**.
3. To proceed with the installation, click I accept the terms of the license agreement and then click Next.

4. Select the optional configuration packages you want to install then click Next.
Figure 2-6. Optional Package Selection

Note
You must purchase a license to use FBxDesigner; see the FBxDesigner Quick Start Guide (D301860X012) for instructions on licensing that product.

FB3000 users can purchase various features and applications. You can license these from within FBxConnect, or through the Emerson Customer Portal. See the FBxConnect online help and the Emerson Customer Portal Quick Start Guide (D301878X012) for details.

You can access licensing tools through the Help > Licensing menu item in Field Tools.

Note
If you are installing over an existing version of Field Tools, you have the option to preserve any saved connections by checking Retain Previous Connections, and to preserve the password for Field Tools software by checking Retain Administrator Password.

5. The installation proceeds. The installer program periodically reports which components are being installed. This may take several minutes:
6. The software prompts you whether you want the installer to create a Field Tools desktop icon; click **Yes** if you want to start Field Tools from the desktop.

7. Click **Finish** to exit the installer.
2.3.1 Custom Install without User Prompts

Some companies require software installations to be handled by their Information Technology (IT) departments without user intervention.

To do this with Field Tools, you must create a custom setup file in a temporary folder that specifies which packages the installer should load.

The setup file must be named `setup.iss`, and you must store it in your `c:\temp` folder:

The setup file follows the format below:

```
[{A336A33B-40A8-4032-BAD6-58A04D514F12}-Options-0]
Designer=installFBxDesigner
ROCLink=installROCLINK
TechTools=installTechView
FBx=installFBxConnect
Connections=preserveConnections
Password=preservePassword

[{A336A33B-40A8-4032-BAD6-58A04D514F12}-AskYesNo-icon]
Result=disableprompts
```

Where:

<table>
<thead>
<tr>
<th>Option</th>
<th>Set to:</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>installFBxDesigner</code></td>
<td>0 = Do not install FBxDesigner</td>
</tr>
<tr>
<td></td>
<td>1 = Install FBxDesigner</td>
</tr>
<tr>
<td><code>installROCLINK</code></td>
<td>0 = Do not install ROCLINK</td>
</tr>
<tr>
<td></td>
<td>1 = Install ROCLINK</td>
</tr>
<tr>
<td><code>installTechView</code></td>
<td>0 = Do not install TechView</td>
</tr>
<tr>
<td></td>
<td>1 = Install TechView</td>
</tr>
<tr>
<td><code>installFBxConnect</code></td>
<td>0 = Do not install FBxConnect</td>
</tr>
<tr>
<td></td>
<td>1 = Install FBxConnect</td>
</tr>
<tr>
<td><code>preserveConnections</code></td>
<td>0 = Delete any existing connections</td>
</tr>
<tr>
<td></td>
<td>1 = Preserve existing connections from previous installation</td>
</tr>
<tr>
<td><code>preservePassword</code></td>
<td>0 = Delete any existing Field Tools password</td>
</tr>
</tbody>
</table>
Here is a sample setup.ISS file that will silently install ROCLINK, TechView, and FBxConnect, and preserve connections and the Field Tools password, and will create a desktop icon for Field Tools.

```plaintext
[{A336A33B-40A8-4032-BAD6-58A04D514F12}-Options-0]
Designer=0
ROCLink=1
TechTools=1
FBx=1
Connections=1
Password=1
[{A336A33B-40A8-4032-BAD6-58A04D514F12}-AskYesNo-1]
Result=1
```

Once you create the file, store it in a temporary folder, and launch the installer from the command line as follows:

```
fieldtoolsxxxx /s /f c:\temp\setup.iss
```

where `xxxx` is the installer number
Section 3: Communication Setup

This chapter covers initial communication setup with Field Tools.

3.1 Using Field Tools to Establish a Connection

Field Tools can communicate with a controller or flow computer using either a direct serial connection or through an IP network. FB1000/FB2000 Series Flow Computers also support wireless connections through FBxConnect.

**CAUTION**

When making multiple FBxConnect connections to the same device (as with a remote and a local connection), be aware that the changes one connection makes to the device may not be immediately visible to other connections, and may even require the other connections to restart FBxConnect before changes become visible. For example, simple changes (such as changes to setpoints) may be immediately visible to all connections, but changing the number of meters, configuring I/O, adding/deleting menu items, or other major configuration changes may require re-establishing the connection using FBxConnect.

3.2 Before You Begin

- For serial connections, you would typically connect a serial cable between the laptop computer and a serial port on the controller or flow computer. Other options for serial connections could include a radio or modem.
- For IP connections, connect the laptop to the same IP network which includes the controller or flow computer.
- If you have an FBx-series device with the FBxWifi option, you can use a wireless IP connection. This option requires you know the connection key for the wireless network.
- For details on cabling/wiring, consult the hardware manual for your controller or flow computer.

**Important**

When using Field Tools for serial communication, you must plug into the Local Port. For ControlWave-series units, this is a port for which you’ve set the _Pn_LOCAL_PORT system variable TRUE in the ControlWave project running in the unit. Local ports answer to requests sent to a BSAP local address of 1 which is what Field Tools requests. For Network 3000, this is a BSAP slave or...
pseudo-slave port. For a ROC or FloBoss, the Local Port is a specific port (the LOI port) which answers to the address of 240 and a group number of 240.

- For ControlWave/Network 3000 devices only, you need to know which TechView session (*.TVS) file is appropriate for your device so you can specify it when you establish your connection. If you installed TechView, a set of default TVS files resides on your hard disk in your \openbsi installation path. The Connection wizard opens that folder first when you specify your TVS file. For example, there is a CWaveEFM.TVS file to support the ControlWave EFM, a CWaveGFC.TVS file to support the ControlWave GFC, and so on. If you have a customized application with a customized TVS file, you should place it in that folder.

3.3 Starting Field Tools and Logging In

1. Start Field Tools either from the desktop icon or click: Start > Programs > Emerson Field Tools > Field Tools.
2. In the Log In dialog box, enter your User name and Password and click Log in.

Figure 3-1. Log In dialog

Important

The very first time you log in, use admin for the User name and leave the Password field blank. Once you’ve logged in with these defaults, Field Tools prompts you to change your password.

3. The Field Tools main screen opens. Use it to establish a connection with the controller / flow computer.
3.3.1 Changing the Password

You can change the password for the currently logged on user at any time.

1. Click **Security > Change password** from the menu bar. The Change Password dialog box opens.

**Note**

The very first time you start Field Tools, the default password for the ADMIN account is blank, and Field Tools forces you to define a new password; click **OK** to open the Change Password dialog box. Passwords are case sensitive.
2. In the Change Password dialog box, enter the current password in the Old password field, then enter the new password in both the New password and Confirmation fields, then click OK. Your password is now changed.

3.3.2 Defining Users

The User Management dialog box lets you define Field Tools users, and also configure RTU login credentials for them.

To define the Field Tools users on this PC click Security > User management from the menu bar. This opens the User Management dialog box.

**Figure 3-4. User Management Dialog**

3.3.3 Adding a User

1. If the User Management dialog box is not already open, click Security > User management to open it.
2. Click Add User. Optionally choose a Role for the user. (Particular roles can have particular privileges associated with them.)
3. Enter a User name for the user.

**Notes**

- Usernames are case-insensitive and are stored in the database as lowercase.
- Do not create a user named Operator. This word is reserved for use internally by Field Tools.

4. Enter a password in the Password and Confirm Password fields.
5. Click OK.
3.3.4 Setting a Minimum Password Length

You can enforce a minimum password length to increase the level of protection of your Field Tools passwords. Passwords can range from 1 to 32 characters. The longer the password length, the harder it is for an intruder to gain access to your system.

1. Click **Security > Security configuration** to open the Security configuration dialog box.

2. Enter the minimum number of characters required for a valid password and click **OK**. From this point on, all users you define must have a password of this length or longer. Existing users created previously with passwords shorter than this number are unaffected.
3.3.5 Deleting a User

1. If the User Management dialog box is not already open, click **Security > User management** to open it.
2. Click the name of the user you want to delete.
3. Click **Delete User**.
4. Click **Yes** when prompted to confirm the deletion.

3.3.6 Assigning RTU Login Credentials

1. If the User Management dialog box is not already open, click **Security > User management** to open it.
2. Click the name of the user for which you want to define RTU login credentials then click **Credentials mapping**. The Credentials mapping dialog box opens.

![Figure 3-7. Device credentials Dialog](image)

3. Enter a **Username** and **Password** for accessing the particular RTU type(s).

**Note**
For the ROC/FloBoss, usernames for RTU access **cannot** exceed 3 characters.

4. Click **OK**.
3.4 Connections List

The left pane of the Field Tools main screen displays the Connections list tree. This shows connections you’ve previously saved or used, and also lets you create new connections.

Figure 3-8. Connections List

Table 3-1. Connections List Pane and Context Menus Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Identifies a previously configured connection to an FB1100 Flow Computer. The name of the device appears next to the icon. Double-click the icon to re-start the connection.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Identifies a previously configured connection to an FB1200 Flow Computer. The name of the device appears next to the icon. Double-click the icon to re-start the connection.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Identifies a previously configured connection to an FB2100 Flow Computer. The name of the device appears next to the icon. Double-click the icon to re-start the connection.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Identifies a previously configured connection to an FB2200 Flow Computer. The name of the device appears next to the icon. Double-click the icon to re-start the connection.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Identifies a previously configured connection to an FB3000 RTU. The name of the device appears next to the icon. Double-click the icon to re-start the connection.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Identifies a previously configured connection to a ROC, DL8000, or FloBoss. The name of the device appears next to the icon. Double-click the icon to re-start the connection.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Identifies a previously configured connection to a ControlWave or Network 3000 (33xx)</td>
</tr>
</tbody>
</table>
controller. The name of the device appears next to the icon. Double-click the icon to re-start the connection.

- Shows on top of a controller/flow computer icon when its connection is active. Beginning with Field Tools 2.0, you can have multiple simultaneous active connections.

- Site - A site is just a name underneath which you can group one or more connections. It could represent a geographical area, a department, or any other logical grouping you need. The Connections list comes with a default site name called “All Connections” which you can rename and/or add additional sites underneath. Although you can rename it, you cannot delete the “All Connections” site; you can delete other sites if they have no devices underneath.

- Add Connection. Click to launch the Connection wizard. You can find this icon in the Connections list toolbar and in the context menu when you right click on a site.

- Edit Connection. Click to change the connection parameters for the selected connection. You cannot edit an active connection.

  **Note:** If you change the connection name, when you save, Field Tools prompts you to decide whether you want to save the connection as a new connection under the new name (**Add new connection**), or to just rename the existing connection (**Replace connection**).

- Connect. Click to activate the selected connection.

- Delete. Click to delete the selected connection or site.

- Add Site. Click this context menu item to add a site underneath the currently selected site.

- Rename Site. Click this context menu item to call up the Modify Site dialog box and rename the currently selected site.

- Expand branch. Click to expand this branch of the Connections tree.

- Hide branch. Click to hide the portion of the Connections tree underneath.

- Apply Pin. Click to display only the portion of the tree below the current position of the cursor. This is useful if you have a large Connections list tree with many items and you only want to see a portion of it.
3.5 Starting an Existing Connection

1. If you have previously established connections from this laptop, Field Tools displays them in the Connections list pane (see Figure 3-8).

2. To activate a connection, double-click on its icon and Field Tools activates that connection and automatically launches the appropriate configuration tool (ROCLINK, TechView, or FBxConnect).

3.6 Creating a New Connection to a Device (Controller/Flow Computer)

1. If the connection for the controller/flow computer you want to communicate with already exists in the Connections list just double-click on it – you’re done. If no previous connection exists to this device, go to the next step.

2. If you want to associate the device with a particular site, first click the site name in the Connections list. (If you don’t want to choose a site at this time, you can skip that – the connection will automatically belong to the All Connections site.)

3. Click the Add connection icon in the Connections pane toolbar. If the icon is not visible (because no site is selected) click Connections > Add connection from the menu bar. Either way, the Connection wizard opens.
4. Select the type of device to which you want to connect in the **Device platform** field. The choices are: **FloBoss/ROC/DL8000, ControlWave/33xx**, or **FBx** (for the FB1000/FB2000 Series Flow Computers or FB3000 RTU).

**Note**

“33xx” refers to Network 3000 devices.

5. Enter the name of the field device in the **Specify name** field. For FBx devices, click the **Get name from device** button and Field Tools obtains the device name from the device (if it exists). If no name exists in the device, Field Tools uses the name “Default.”
Note
Make connection names alpha-numeric; you can also include dashes, underscores, or spaces. Connection names cannot include special characters such as single or double quotation marks, commas, slashes, periods, colons, or asterisks. There is no pre-set maximum length for connection names.

6. For a ROC/FloBoss or ControlWave, if you want to define a default username/password combination for this device click Device credentials in the Connection page to open the Device credentials dialog box, enter a valid Username and Password combination for access to this controller/flow computer, and re-enter the password in the Verify Password field; this username/password combination will be used for this controller/flow computer throughout this Field Tools session. If you want to use this username/password combination as the default for this RTU for all subsequent connection sessions check the Save as default box. Click OK to finish and close the dialog box.

Figure 3-10. Device Credentials dialog box

Note
For FB1000/FB2000 Series Flow Computers or the FB3000 RTU, Field Tools uses the Field Tools Username and Password by default. If that username/password combination is not correct for the device, you can enter the correct ones, when prompted, and Field Tools then stores them with the connection details for that device. For that reason, there is no Device Credentials option for these devices.

7. Choose a Connection type. Choices include either Serial, IP, or WiFi (if you have an FB1000/FB2000 Flow Computer). Proceed to Step 8 for serial communication; skip to Step 9 for IP communication; skip to Step 10 for Wi-Fi communication.

8. For serial communication:
Select the PC communication port in the **Comm port** drop down menu, otherwise leave it at the **Auto** default which causes the Connection wizard to cycle through the various ports until it finds the correct one. You can refresh the port selections by clicking the refresh (↻) button.

The Wizard hides certain parameters to simplify configuration using default values; while this is useful in some situations, we recommend you enter the **Baud rate** and **Address** if you know them, rather than letting Field Tools attempt to auto-discover them. Most other parameters may be left at default values. Click **Show more parameters** to specify additional parameters as follows.

If you know the baud rate for communicating with the field device, you can specify it in the **Baud rate** drop-down field. Otherwise use the **Auto** default which causes the Connection Wizard to cycle through the supported baud rates (9600, 19200, 38400, 57600, and 115200) until it finds the correct one.
- Optionally specify the **Link Timeout** for this connection. That value defines the period of time (in milliseconds) Field Tools waits for a response from the RTU or flow computer before declaring a communication failure. If you enter 0, Field Tools uses a default of 200 milliseconds. Optionally, you can change the **Retries** parameter, which sets the total number of attempts to send a communication message before declaring an error.

- Specify the **Address** and the **Group** according to the following table:

<table>
<thead>
<tr>
<th>Device Type</th>
<th>Address</th>
<th>Group</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FB1000/FB2000 Series Flow Computers, FB3000 RTU</td>
<td>Default: 1 Range: 0-254</td>
<td>Not applicable</td>
<td>If you don’t know the address, check the <strong>Discover address of device</strong> box.</td>
</tr>
<tr>
<td>ROC/FloBoss</td>
<td>Default: 240 Range: 0-255</td>
<td>Default: 240 Range: 0-255</td>
<td>Normally you should leave both of these at the default of 240 for local connections on the LOI port.</td>
</tr>
<tr>
<td>ControlWave</td>
<td>Default: Auto-detect Range: 1-127</td>
<td>Not applicable</td>
<td>If you are not connected to the local port or BSAP slave port (as specified in the ControlWave project or ACCOL load, respectively) but you know the BSAP local address for the field device, you can specify it in the Address drop-down field. Otherwise leave it at the Auto default which causes the Connection wizard to try each address in the range (1 to 127) until it finds the correct one.</td>
</tr>
</tbody>
</table>

- **For ROC/FloBoss only:** Under Extra Parameters use the [...] button to specify the ROC/FloBoss **.800 Configuration file** to associate it with this connection when ROCLINK launches. The .800 file must reside on this laptop PC.

- **For ControlWave/Network 3000 units only:** Under Extra Parameters use the [...] button to specify the **TechView session file** you want to use with this connection when TechView launches. The TechView session file must reside on this laptop PC.
Figure 3-15. Specifying the TechView Session File

**Tip**

The *Auto* options are useful if you do not know the communication port, baud rate, or (for ControlWave/33xx only) the local address. If you leave all of these fields at *Auto*, however, it could take considerable time to establish the connection since the system must successively try each port, each of the five supported baud rates, and for ControlWave/33xx each of 127 possible local addresses.

The maximum number of connection attempts if all fields are left at *Auto* for a ROC/FloBoss is (# of serial ports) * 5.

The maximum number of connection attempts if all fields are left at *Auto* for a ControlWave/33xx is (# of serial ports) * 635.

When you’ve completed this step, go to Step11.

9. For IP communication:

Figure 3-16. IP Connection Settings – FB1000/FB2000 Series Flow Computers & FB3000 RTUs
Notes
If you make an invalid entry in one of the Connection wizard fields, a warning icon blinks, and you must correct the invalid entry.

To view/modify hidden parameters, click Show more parameters.

- Specify the IP address of the RTU or flow computer. Position your cursor in the left-most digit position of the IP address field, enter the value for that position and use the tab key to move to the next position and so on until you enter the complete IP address. If you want to highlight the entire address to type over it, click the icon.

- Specify the port (IP socket number) used by this connection. The following table shows the default ports:

<table>
<thead>
<tr>
<th>Device Type</th>
<th>Default Port (socket)</th>
</tr>
</thead>
<tbody>
<tr>
<td>ROC/FloBoss</td>
<td>4000</td>
</tr>
<tr>
<td>FBx</td>
<td>20000</td>
</tr>
<tr>
<td>ControlWave</td>
<td>1234</td>
</tr>
</tbody>
</table>

Note
Field Tools only supports a single active IP connection to one ControlWave device at a time on a given default port. If more than one ControlWave device shares the same default port, only one of
those ControlWave devices can have an active IP connection at any one time. If you attempt to start a second connection, Field Tools posts the message "An IP connection to a Bristol device already exists. Only one such connection is allowed." To make the new connection you must manually close down the existing active connection and then you can start the new connection.

- Optionally specify the Link Timeout for this connection. That is the period of time (in milliseconds) Field Tools waits for a response from the RTU or flow computer before declaring a communication failure. If you enter 0 Field Tools uses a default of 5000 milliseconds.
- Specify the Address and Group according to the following table:

<table>
<thead>
<tr>
<th>Device Type</th>
<th>Address</th>
<th>Group</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FBx</td>
<td>Default: 1 Range: 0-254</td>
<td>Default: 0 Range: 0 to 254</td>
<td>If you don’t know the address, select the Discover address of device option.</td>
</tr>
<tr>
<td>ROC/FloBoss</td>
<td>Default: 240 Range: 0-255</td>
<td>Default: 240 Range: 0-255</td>
<td>Normally you should leave both of these at the default of 240 for local connections on the LOI port.</td>
</tr>
<tr>
<td>ControlWave</td>
<td>Not applicable</td>
<td>Not applicable</td>
<td></td>
</tr>
</tbody>
</table>

- If the connection is through a terminal server, select the Terminal Server checkbox and set the IP address and Port (socket) to be the IP address and port of the terminal server.
- For ROC/FloBoss only: Under Extra parameters use the [...] button to specify the ROC/FloBoss .800 Configuration file in order to associate it with this connection when ROCLINK launches. The .800 file must reside on this laptop PC.

**Figure 3-19. Specifying the ROC Configuration File**

![Extra parameters](C:\\..
ROCLINK800\\ROC364 Default.800)

- For ControlWave/Network 3000 units only: Under Extra parameters use the [...] button to specify the TechView session file you want to use with this connection. The TechView session file must reside on this laptop PC.

**Figure 3-20. Specifying the TechView Session File**

![Techview session](C:\\\Bristol\\OpenBSI\\CWaveEFM.tvx)
When finished, skip to Step 11.

10. For Wi-Fi communication (FB1000/FB2000 Flow Computers only):

**Figure 3-21. Wi-Fi Connection Parameters**

- Wi-Fi networks that your laptop detects are shown onscreen. For this type of connection to work, the laptop must first detect the **WiFi Network** to which the device belongs. The default WiFi Network follows the format FBxxxx_serialnumber.
- Specify the **IP address** of the RTU or flow computer. Position your cursor in the left-most digit position of the IP address field, enter the value for that position and use the tab key to move to the next position and so on until you enter the complete IP address. If you want to highlight the entire address to type over it, click the icon. The default IP address for FB1000/FB2000 Flow Computers when they ship from the factory is **192.168.1.10**.
- Specify the **Port** (IP socket number) of the RTU or flow computer. The default port is 20000.
- Enter the **Security Key** for the wireless network. To see it as you type it, click the eyeball icon. The default security key for FB1000/FB2000 Flow Computers when they ship from the factory is **EmersonFBXX00**. Be sure to change it to something only your organization knows when you place the device in service.
- If the connection is through a terminal server, select the **Terminal Server** checkbox and set the **IP address** and **Port** (socket) to be the IP address and port of the terminal server.
- Specify the **Address** as described in Table 3-4. If you don’t know the address, check the **Discover address of device** box.

11. If you don’t want to activate the connection right now, but just want to save your configuration entries, you can click **Save**; this saves your entries in the Connection list, and exits the wizard. If you want to connect right now, click **Connect** and the wizard attempts to establish the connection.

12. Field Tools reports details of the connection progress in the Connection progress pane.
13. If the connection is successful, the Active connection pane of the Field Tools main screen shows an icon for the newly connected device and its toolbar populates with icons appropriate to the device type.

14. In addition, Field Tools automatically launches the configuration tool (ROCLINK, TechView, or FBxConnect) appropriate for the device platform.

3.7 Making a Direct Connection

The term *direct connection* refers to a direct *serial* connection to a device.

Click **Connections > Direct Connect** and select the type of device from the options presented. Field Tools attempts to establish a local serial connection by sequentially trying each serial port using the default settings for that device type.
3.8 Active Connection pane

The Active Connection pane shows details for the currently active connection and allows you to launch certain other tools for use with the device(s).

The Active Connection pane includes a separate tab for each active connection. Click on the tab to see details about a particular connection.

To see information about a device (RTU, flow computer), move the cursor over that device and a small status box opens that shows details based on the type of device. This could include its address, or certain status information.

To disconnect an active connection, right-click on the icon for the device and choose Disconnect. To disconnect all connections, click Connections > Close all connections.

Table 3-5. Icons Used in Active Connection Pane

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Identifies a previously configured connection to an FB1100 Flow Computer. The name of the device appears next to the icon. Double-click the icon to re-start the connection.</td>
</tr>
</tbody>
</table>
Identifies a previously configured connection to an FB1200 Flow Computer. The name of the device appears next to the icon. Double-click the icon to re-start the connection.

Identifies a previously configured connection to an FB2100 Flow Computer. The name of the device appears next to the icon. Double-click the icon to re-start the connection.

Identifies a previously configured connection to an FB2200 Flow Computer. The name of the device appears next to the icon. Double-click the icon to re-start the connection.

Identifies a previously configured connection to an FB3000 RTU. The name of the device appears next to the icon. Double-click the icon to re-start the connection.

ROC or FloBoss controller connection.

ControlWave or Network 3000 controller connection.

Device icon(s).

Note: The devices’ device descriptor (DD) files provide the device icons. Consequently, depending upon the type of HART or WirelessHART device, you may see different device icons.

Expand branch. Click this to expand the branch of the tree.

Hide branch. Click this to hide the portion of the tree underneath.

Apply Pin. Click to display only the portion of the tree below the cursor’s current position. This is useful if you have a large tree with many items and you want to see only a portion of the tree.

Remove Pin. Click to turn off the Apply Pin option and display the entire tree.

Failure. Indicates some sort of failure associated with this device.

Terminate Connection. Click to shut down the active connection in this device tab. Field Tools prompts you to confirm this action.

### 3.9 Saving Connections / Importing Connections

If you have configured a group of connections, you can save the connection configuration details in an XML file. You can then transfer that XML file to another PC/laptop running Field Tools, so that you don’t need to re-create the connections on that PC, you can just click on them to start the connection.

**Exporting Connections**

1. Click Connections > Export > Export to file.
2. Specify a filename for the XML file.

**Importing Connections**

1. Click Connections > Import > Import from file.
2. Navigate to the XML file that contains the connection information and click Open. If a duplicate connection exists, Field Tools prompts you to confirm the update.
Importing ROCLINK Connections

If you had previously created connections within ROCLINK without Field Tools, you can import those connections into Field Tools.

1. Click **Connections > Import > Connections from ROCLINK**. The Import ROCLINK connections dialog box opens.

   ![Figure 3-26. Import ROCLINK connections Dialog](image)

   - **Site name**: All Connections and Sites
   - **Overwrite Existing Connections Data**

2. In the Import ROCLINK Connections dialog box, choose the site name which contains the ROCLINK connections you want to import.

3. If you want to overwrite existing ROCLINK connections, select the **Overwrite Existing Connections Data** option.

4. Click **Start** to import the connections.

### 3.10 Settings

Click **Settings** in the menu bar to open the Settings dialog box. The Settings dialog box lets you pre-configure certain items for FBxConnect.

![Figure 3-27. Settings Dialog Box](image)
If you want the system to prompt operators whether to override the time zone of an FBx device when a time synchronization message comes in, select the Show **Override device time zone** dialog box before synchronizing time of an FBx device.

Select **Zero pad decimal places on floating point values** if you want floating point values shown on FBxConnect displays to be padded with zeros to fill the specified field size. For example, in a field specified to show 5 decimal places, a floating point value of 6.25 will be padded to show 6.25000. This does **not** show greater precision for the value, it only shows zeros to allow numbers to line up properly on the display.

Click OK to save your changes to the settings.

### 3.11 Offline Configurations/Solutions Menu

The Configurations menu bar item lets you create or view configuration files for FB1000/FB2000 Flow Computers and ROC/FloBoss/DL8000 devices. You can also create a solution file (*.ZSL) for the FB3000 RTU.

For an FB1000/FB2000 Series Flow Computer or FB3000 RTU, see the FBxConnect online help for more information.

For a ROC or FloBoss device, see the ROCLINK online help for more information.

---

**Figure 3-28. Offline Configurations**
Section 4: FBxNet

You launch FBxNet from within Field Tools.

4.1 What is FBxNet?

FBxNet is a peer-to-peer communication network for exchanging data between Emerson RTUs and flow computers over Ethernet connections.

A subscriber device in the network must be an Emerson FB3000 RTU with a firmware revision that supports FBxNet.

Publisher devices in the network can be any mixture of Emerson FB3000 RTUs, Emerson FB1200 Flow Computers, or Emerson FB2200 Flow Computers with firmware revisions which support FBxNet.

FBxNet transfers data between the subscriber and its publishers according to parameter definitions. Each parameter definition specifies a correspondence between a tag in the publisher and a tag in the subscriber. These two tags exchange data using FBxNet.

The graphic, below, shows a peer-to-peer network with a single subscriber (A) and three publishers (B, C, and D).

Figure 4-1. FBxNet – Subscriber and Publisher Devices

4.2 Licensing FBxNet

If you start Field Tools and do not see the FBxNet menu bar item, it means FBxNet is not currently licensed on your PC. When you purchased FBxNet, you should have received a License Id and Password to access the licensing website and license FBxNet on your PC.
Note:

If you install Field Tools on a server, you should purchase a Multi-User Server license so multiple users can log in from remote PCs and use FBxNet.

1. Within Field Tools, click Help > Licensing > License FBx Products

![Figure 4-2. Calling up the License Manager](image)

2. When the License Manager opens, click Create LRF.
3. The License Manager prompts you to save the LRF file. (Make sure you make note of where you save it, before you click Save because you will need it later.)
4. Now click **Get Key** in the License Manager.

5. On the registration page, enter your **License Id** and **Password** and click **Sign-On**.

6. When you sign on successfully, click the **Register** link.
7. Now enter your contact information, email, and other details in the upper part of the page and use the scroll bar to reach the lower fields. Then click **Browse** to select the license request file (LRF) you saved in Step 2 and click **Next**.

**Figure 4-6. Entering Contact Details and Selecting the LRF File**

8. From the Unlock Software Licenses page, click **Unlock** for the item you want to unlock, then click **Submit License Request**.
Figure 4-7. Unlock Software Licenses and Submit License Request

9. A page opens with a **Key file** link from which you can download your key file. The website also sends a copy of the key file to the email address you specified with your contact information.

Figure 4-8. Download the Key File

**Important**

- If you use Microsoft® Internet Explorer 9, it automatically saves your key file with a .TXT extension. License Manager handles the .TXT extension; do not change the extension or the file may become unusable.
- If you right-click on the Key File link and select the **Save Target as** context menu item, the key file is saved with an .XML extension.
- The e-mailed key file has an extension of .KEY.
  - License Manager handles .KEY, .TXT, and .XML extensions.

10. To apply the license, click **Include Key** in the License Manager (see Figure 4-3). Browse to the location of your key file and click **Open** to apply the key file. FBxNet is now licensed. You’re done!
4.3 Starting FBxNet

**Note:** Unless you manually create them ahead of time, the first time you start FBxNet it notifies you that it cannot find subscriber CSV files. You can create them directly in FBxNet or create them manually in Excel or a text editor.

1. Launch Field Tools.
2. From the Field Tools menu bar, click **FBxNet**.

**Figure 4-9. Starting FBxNet**

---

**Important**

If the FBxNet item is not visible in the menu bar of Field Tools, it means you have not licensed FBxNet on this PC. See [Licensing FBxNet](#).

3. FBxNet opens and reads the subscriber CSV file(s) and based on them, creates a list of the subscribers, and generates a graphical network tree for the selected subscriber and its associated publishers. FBxNet displays the lines connecting the publishers in colors to differentiate between the communication ports used.
4.4 Synchronizing CSV Files

When you make changes to CSV files in FBxNet, FBxNet reminds you to download the changes by showing a Download Pending message on the screen. You should then download the CSV files.

When you first create a site and specify a designated device to hold CSV files, FBxNet prompts you to synchronize files and if you agree, checks to see if CSV files on the designated device are newer, older, or the same as those on your PC. FBxNet also prompts you for this check when you click on a site name for the first time or expand the tree for a site the first time.
If you answer Yes FBxNet connects to the designated device and checks the CSV file versions and notifies you whether the CSV files on the designated device are newer, older or the same as CSV files on your PC. You can then choose whether or not you want to proceed with the upload. Typically, you would want to answer Yes to upload if the files on the designated device are newer than the ones on your PC.

4.5 Switching Between Monitor and Configuration Mode

FBxNet displays the current mode in the Mode Indicator at the lower left of the screen. (See Item 5 in Figure 4-10.) You can also see the currently active mode by clicking Mode in the menu bar; FBxNet shows a check next to the current mode of operation.

The two FBxNet modes are:

- Monitor Mode lets you view data and parameters for each subscriber and publisher. You can also change FBxNet subscriber configuration parameters. To open Monitor Mode, click Mode > Monitor.
- Configuration Mode lets you edit/change publisher and subscriber tag names for a particular subscriber. To open Configuration Mode, click Mode > Configuration.
4.6 How do I configure FBxNet?

FBxNet configuration is a multi-step process:

1. In FBxConnect, click **Configure > FBxNet** and use the FBxNet display to configure one or more Ethernet ports on your FB3000 Subscriber device to use FBxNet. (See the FBxConnect online help for details). If you do not see the FBxNet option, it means FBxNet is not licensed for that device. (See **Licensing FBxNet**.)

2. In FBxConnect, click **Services > User Management** and create a user with FBxNet privileges. Each device in your FBxNet network must have an identical user with the same login credentials. (See the FBxConnect online help for details.)

3. Launch Field Tools and start FBxNet. (See **Starting FBxNet**.)

4. Create one or more sites and specify an RTU to hold CSV files for the site. (Sites are just a way to organize subscribers.) (See **Creating a Site**.)

5. Specify one or more subscribers for each site. The subscriber is an FB3000. (See **Creating a Subscriber Directly in FBxNet**.)

6. Specify one or more publishers for each subscriber. A publisher is an FB1200, FB2200, or FB3000. (See **Adding a Publisher**.)

7. Specify parameters which define which data should be transferred between the publisher(s) and the subscriber. (See **Adding a New Parameter**.)

8. Download the CSV file to the subscriber device. (See **Downloading CSV Files**.)
4.7 Creating a Site

A site is a name under which you can group one or more subscribers. It could represent a geographical area, a department, or any other logical grouping you need.

1. In Configure Mode, click the Add Site icon.

Figure 4-11. Adding a Site

2. Now enter the name of the site in Site Name. The Setup designated device section defines a device where FBxNet stores CSV files for the subscribers associated with this site. This provides other PCs a place to locate FBxNet configuration details for the site. Check the Specify a designated device... box, and enter the Designated device's IP Address.
3. Click **Save**. The Subscriber List pane updates to show the newly defined **Site Name**.
4. FBxNet then prompts you to decide whether it should upload CSV files from the device to your PC.

![FBxNet notification dialog](image)

5. If you answer **Yes** FBxNet connects with the designated device and then notifies you if the version of CSV files on the designated device is newer, older, or the same as those on your PC. You can decide what you want to do. Typically you would want to upload if the CSV files on the designated device are **newer** than the CSV files on your PC.

### 4.7.1 Editing a Site

After entering Configure Mode, click on the site in the Subscriber List pane and click ![edit site](image) and you can edit the site. Click **Save** to save your edits and update the CSV file or **Cancel Edit** to discard your edits.

![Editing a Site](image)
4.7.2 Deleting a Site

You can only delete a site if it has no subscribers; once a site has subscribers you cannot delete it unless you first delete its subscribers.

In Configure Mode, click on the site name in the Subscriber List pane, then click the delete icon.

4.8 Creating a Subscriber Directly in FBxNet

Subscriber information is stored in CSV file(s). Each subscriber has its own CSV file that lists the name and IP address of the subscriber device as well as the names and IP addresses of all its publisher devices. The file also includes details on each publisher's parameters. The parameters define the source and destination tags for data to be exchanged between the publisher and subscriber over FBxNet.

You can create a subscriber's CSV file directly in FBxNet as described, below. Alternatively, you can create a CSV file manually in a text editor or Microsoft® Excel (See *Manually Creating the Subscriber CSV File.*)

1. In Configure Mode, click in the Subscriber List pane on the site in which you want to add a subscriber, then click the Add Subscriber + icon.
2. Specify the Subscriber Name, its IP Address, and IP Port.
3. You can add publishers for this subscriber. (See Adding a Publisher.)
4. You can add publisher parameters and specify associated subscriber parameters for data exchange through FBxNet. (See Adding a New Parameter.)
5. Click Save To File to save your edits to the subscriber CSV file and FBxNet adds the name to the subscriber list.

Alternatively, you could click Cancel Edit to cancel the operation.

4.8.1 Editing a Subscriber

After entering Configure Mode, select the subscriber, and click and you can edit the subscriber fields. Click Save To File when you finish to update the CSV file.
4.8.2 Deleting a Subscriber

Once you delete a subscriber, you delete its associated CSV file. You cannot undo this deletion.

In Configure Mode, click on the subscriber in the Subscriber List pane, then click the delete icon. You will be prompted to confirm the deletion.

![Deleting a Subscriber](image)

4.9 Adding a Publisher

After entering Configure Mode, selecting a subscriber, and clicking you can add another publisher device for this subscriber:

1. In the Publisher’s Configuration pane, click Add Publisher to add a new line to the grid.

2. Enter the Name of the publisher, its device Type (FB3000, FB1200, or FB2200), its IP Address, IP Port (default is 20000), Subscriber Comm Port (5 or 6), and check Polling Enabled to allow communication to occur.

3. When you finish with all your edits on this page, click Save To File to update the CSV file.

4.9.1 Editing a Publisher

After entering Configure Mode, select a site and click on the subscriber, and click and you can edit the publishers under that subscriber. Click Save To File when you finish to update the CSV file.

![Editing a Publisher](image)
4.9.2 Deleting a Publisher

**Important**

Exercise caution because once you delete a publisher, you cannot undo it. Deletion removes the publisher, its parameters, and all its tags from the CSV file.

After entering Configure Mode, selecting a subscriber, and clicking you can delete a publisher device from this subscriber:

1. In the Publisher’s Configuration pane, use the scroll bar (if necessary) to locate the publisher you want to delete, and click on the line for it.
2. Click **Delete Publisher**. This deletes the publisher from the grid and from the CSV file.

4.10 Adding a New Parameter

After entering Configure Mode, selecting a site and subscriber, and clicking you can add a new parameter.

1. In the Publisher’s Configuration pane, use the scroll bar (if necessary) to select the publisher for which you want to edit parameters, and click on its line.
2. In the Publisher Parameters Configuration pane you can see the existing parameters for this publisher. Use the scroll bar (if necessary) to locate the line below where you want to add the parameter and click on that line.
3. Click **Add Parameter** to add an empty line into which you can define the new parameter.
4. Launch the Tag Browser. For more information on using the Tag Browser, see *Working with the Tag Browser*.
5. Select the attribute whose tag you want as a **Subscriber Tag**, then click **Copy Tag**.
6. Go to the **Subscriber Tag** field in the empty line in the Publisher Parameters Configuration pane, right-click and choose **Paste** to paste in the tag. Repeat steps 5 and 6 to specify the **Publisher Tag**.

7. In the **Operation** field, choose **READ** or **WRITE**.

8. When you finish with all your edits on this page, click **Save To File** to update the CSV file.

**Note:**
Instead of Copy Tag in Step 5, and Paste in Step 6, you can drag the attribute from the Tag Browser attribute pane into the desired Subscriber Tag or Publisher Tag field.

**4.10.1 Editing Existing Publisher Parameters**

After entering Configure Mode, selecting a subscriber, and clicking ✪ you can edit publisher parameters:

1. In the Publisher’s Configuration pane, use the scroll bar (if necessary) to select the publisher for which you want to edit parameters, and click on its line.

2. In the Publisher Parameters Configuration pane, you can:
   a. Click on the Publisher or Subscriber tag you want to edit, and proceed to edit the names as desired; press the [Enter] key when you’re satisfied with your change.
b. Copy a tag name by clicking once on a tag and right clicking and selecting **Copy**; then you can click on a different field, right click and choose **Paste**.

c. Drag or paste in a tag name from the FBx Tag Browser. See *Working with the Tag Browser* for details.

3. Repeat for any other parameters you want to edit.

4. When you finish with all your edits on this page, click **Save To File** to update the CSV file.

**Note:**

If you make a mistake in your edits, you can undo them by clicking **Cancel Edits**. Once you have saved the file, however, you cannot undo your changes.

### 4.10.2 Deleting a Parameter

**Important**

Exercise caution because once you delete a parameter, you cannot undo it.

After entering Configure Mode, selecting a subscriber, and clicking 🚧 you can delete a parameter from this subscriber:

1. In the Publishers Configuration pane, use the scroll bar (if necessary) to locate the parameter you want to delete, and click on the line for it.

2. Click **Delete Parameter**. This deletes that line from the grid and from the CSV file.

**Note:**

If you make a mistake in your edits, you can undo them by clicking **Cancel Edits**. Once you have saved the file, however, you cannot undo your changes.

### 4.11 Manually Creating the Subscriber CSV File

Subscriber information is stored in CSV file(s). Subscriber CSV files list the names and IP addresses of the subscriber device and all its publisher devices, as well as each publisher’s parameters. The parameters define the source and destination tags for data to be exchanged between the publisher and subscriber over FBxNet.

Create one or more subscribers for each site. You can create subscribers directly in FBxNet as described in *Creating a Subscriber Directly in FBxNet*. 
Alternatively, you can create a CSV file manually in a text editor or Microsoft® Excel. If you have multiple subscriber devices, you must create a separate CSV file for each one. For example, if you have three subscribers, you must create three CSV files—one for each subscriber.

If you have many subscribers or many publishers, you may want to create your first subscriber or publisher directly in FBxNet, and then manually edit the resulting CSV file to add additional publishers, or copy the CSV file and use it as a basis for defining another subscriber and set of associated publishers.

### 4.11.1 Subscriber File Format

In the subscriber file, bolded entries must appear exactly as shown. Italicized entries must be modified to reflect details on the subscriber and publishers and associated tags.

The first line, which is bolded, provides a guide to the meaning of entries on the second line. The second line entries define the subscriber device.

The third line and fourth line (both bolded) provide a guide to the meaning of entries for the subscriber devices, defined on subsequent lines.

From line five to the end of the file are definitions of individual publisher devices, and their associated parameters. Lines that describe the actual tags begin with a comma “,”.

<table>
<thead>
<tr>
<th>SubscriberName, SubscriberIPAddress, SubscriberIPPort</th>
<th>PublisherName, PublisherType, PublisherIPAddress, PublisherIPPort, SubscriberCommPort, Enabled, SubscriberTag, Operation, PublisherTag, FaultMode, FixedFaultValue, FBxNDataInstance</th>
</tr>
</thead>
<tbody>
<tr>
<td>SubscriberDeviceName, SubscriberIPAddress, SubscriberIPPort</td>
<td>PublishName, PublisherDeviceName1, PublisherType1, PublisherIPAddress1, PublisherIPPort1, CommPortNumber1, EnableFlag1, SubscriberTag1, Operation1, PublisherTag1, FaultMode1, FixedFaultValue1, FBxNDataInstance1</td>
</tr>
<tr>
<td>PublisherName: PublisherDeviceName, PublisherType, PublisherIPAddress, PublisherIPPort, SubscriberCommPort, Enabled, SubscriberTag, Operation, PublisherTag, FaultMode, FixedFaultValue, FBxNDataInstance</td>
<td>PublisherName: PublisherDeviceName2, PublisherType2, PublisherIPAddress2, PublisherIPPort2, CommPortNumber2, EnableFlag2, SubscriberTag1, Operation1, PublisherTag1, FaultMode1, FixedFaultValue1, FBxNDataInstance1</td>
</tr>
<tr>
<td>PublisherName: PublisherDeviceName, PublisherType, PublisherIPAddress, PublisherIPPort, SubscriberCommPort, Enabled, SubscriberTag, Operation, PublisherTag, FaultMode, FixedFaultValue, FBxNDataInstance</td>
<td>PublisherName: PublisherDeviceName3, PublisherType3, PublisherIPAddress3, PublisherIPPort3, CommPortNumber3, EnableFlag3, SubscriberTag1, Operation1, PublisherTag1, FaultMode1, FixedFaultValue1, FBxNDataInstance1</td>
</tr>
</tbody>
</table>
Where:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SubscriberDeviceName</td>
<td>Is the name of the subscriber (client) device. Although not required, we recommend you use the name of the FB3000 as defined in Field Tools.</td>
</tr>
<tr>
<td>SubscriberIPAddress</td>
<td>Is the IP address of the subscriber device. This is the IP address used by Field Tools to connect to the subscriber.</td>
</tr>
<tr>
<td>SubscriberIPPort</td>
<td>Is the TCP/IP port number of the subscriber device. If not specified, FBxNet uses a default of 20000. <strong>Note:</strong> Do not enter 9009 for this number; it is reserved by FBxNet.</td>
</tr>
<tr>
<td>PublisherName:PublisherDeviceName</td>
<td>Marks the beginning of a publisher (server) device definition. The keyword <strong>PublisherName:</strong> is required followed by the name of the publisher. Publisher names must be unique within the file; FBxNet ignores any duplicate publisher names.</td>
</tr>
<tr>
<td>PublisherType</td>
<td>Specifies the type of device. Valid values are FB1200, FB2200, and FB3000. If not specified, FBxNet assumes a default of FB3000.</td>
</tr>
<tr>
<td>PublisherIPAddress</td>
<td>Is the IP address of this publisher device.</td>
</tr>
<tr>
<td>PublisherIPPort</td>
<td>Is the TCP/IP port number of this publisher device. If not specified, FBxNet assumes a default of 20000. (RESERVED FOR FUTURE USE)</td>
</tr>
<tr>
<td>CommPortNumber</td>
<td>Is the subscriber communication port number. This is either 5 or 6.</td>
</tr>
<tr>
<td>EnableFlag</td>
<td>Is set <strong>TRUE</strong> to turn on polling for this publisher device, or <strong>FALSE</strong> to turn off polling for this publisher device.</td>
</tr>
<tr>
<td>,SubscriberTag</td>
<td>Specifies the name of a database parameter in the subscriber device for which you want to transfer its value via peer-to-peer communication.</td>
</tr>
<tr>
<td>Operation</td>
<td>Is set to <strong>READ</strong> if the subscriber should read from this publisher or <strong>WRITE</strong> if the subscriber should write to this publisher.</td>
</tr>
<tr>
<td>PublisherTag</td>
<td>Specifies the name of a database parameter in the publisher device whose value the subscriber wants to read from or write to.</td>
</tr>
<tr>
<td>FaultMode</td>
<td>(This field is Optional, but if you include it you must also include the related <strong>FixedFaultValue</strong> and <strong>FBxNDataInstance</strong> fields) – Specify how FBxNet handles a communication failure or other error from this publisher. Choices are: <strong>LIVE</strong> Disables fault handling.</td>
</tr>
</tbody>
</table>
FixedFaultValue

(This field is Optional, but if you include it you must also include the related FaultMode and FBxNDDataInstance fields) When Fault Mode is set to FAULT, specifies an override value to be used when a communication error or other fault occurs.

FBxNDDataInstance

(This field is Optional, but if you include it you must also include the related FaultMode and FixedFaultValue fields) This field specifies the name of a fault handling database object and registers it in the FB3000 database. You can specify any unused FBxNDDataInstance object number; they follow the format:

FBXNDData_x

Where x is any integer between 1 and 10000. Once registered in the FB3000 database to belong to a particular publisher tag, this object instance stores any data quality or parameter “health” code received about a fault. This data can then be logged and may be viewed in the FBxConnect diagnostic report.

4.11.2 Subscriber File Example – Created in Excel

Below is an example subscriber file created in Microsoft® Excel. Typically, a subscriber file could refer to dozens of devices. The figure, below, shows a subscriber named NORTH_STREET with two publishers named ELM_STREET and SEASIDE_DRIVE. ELM_STREET has three data points to be transferred, and SEASIDE_DRIVE has four data points to be transferred. Both publishers use the default IP port of 20000, so the PublisherIPPort field may be left blank.

Figure 4-18. Subscriber CSV File in Excel
Although not required, the base name of the file should be the name of the subscriber device and when you save the file, you must save it as type CSV (Comma delimited) (*.csv) so that the required commas are included in the file.

### 4.11.3 Subscriber File Example – Created in a text editor

Below is a simple example subscriber file created in a text editor. Although not required, the base name of the file should be the name of the subscriber device and the extension must be CSV. Typically, a subscriber file could refer to dozens of devices, but the simple example below, shows a subscriber named MYFB3000 with three publishers named MyPublisher1, MyPublisher2, and MyPublisher3. Each of the publishers have three data points to be transferred, and they all use the default IP port of 20000, so that field can be left blank, delimited by commas.

<table>
<thead>
<tr>
<th>SubscriberName, SubscriberIPAddress, SubscriberIPPort</th>
</tr>
</thead>
<tbody>
<tr>
<td>MyFB3000, 10.208.15.82, 20000</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>PublisherName, PublisherType, PublisherIPAddress, PublisherIPPort, SubscriberCommPort, Enabled, SubscriberTag, Operation, PublisherTag</th>
</tr>
</thead>
<tbody>
<tr>
<td>MyPublisher1, FB1200, 10.208.15.83, 5, TRUE, User Data_5.FLOAT_1, READ, User Data_5.FLOAT_1</td>
</tr>
<tr>
<td>, User Data_2.LONG_7, WRITE, User User Data_1.LONG_1</td>
</tr>
<tr>
<td>, User Data_1.SHORT_1, READ, User Data_1.SHORT_1</td>
</tr>
<tr>
<td>MyPublisher2, FB1200, 10.208.15.84, 5, TRUE, User Data_5.FLOAT_1, READ, User Data_5.FLOAT_1</td>
</tr>
<tr>
<td>, User Data_2.LONG_7, WRITE, User User Data_1.LONG_1</td>
</tr>
<tr>
<td>, User Data_1.SHORT_1, READ, User Data_1.SHORT_1</td>
</tr>
<tr>
<td>MyPublisher3, FB2200, 10.208.15.85, 5, FALSE, User Data_5.FLOAT_1, READ, User Data_5.FLOAT_1</td>
</tr>
<tr>
<td>, User Data_2.LONG_7, WRITE, User User Data_1.LONG_1</td>
</tr>
<tr>
<td>, User Data_1.SHORT_1, READ, User Data_1.SHORT_1</td>
</tr>
</tbody>
</table>

Other than the CSV extension (which is required), the name of the subscriber file is irrelevant but for good practices it should be the name of the subscriber device (for example MyFB3000.csv).
4.11.4 CSV File Validation

Field Tools performs a complete validation of the format and data of CSV files you create:

- If there are errors in subscriber data, FBxNet ignores that subscriber file.
- If there are errors in publisher data, FBxNet ignores that publisher section.
- If there are errors in the peer-to-peer data for a parameter, FBxNet ignores that parameter.
- If FBxNet can apply a default in order to continue it will. For example, if the file specifies an invalid operation, FBxNet applies a default of READ.

If FBxNet detects errors as it loads CSV files, it creates a log file of those errors and reports this message:

![Log File Message]

You should open the log file and try to correct the errors, and then re-download the files and restart FBxNet so it loads the corrected files.

4.12 FBxNet Authentication

Every FB1200, FB2200, or FB3000 device that exists in an FBxNet network must have an identical FBxNet user configured. Each such user in the network must share identical login credentials. In FBxConnect, go to Services > Users Management to configure the FBxNet user.

4.13 Downloading CSV Files

FBxNet first reads the subscriber CSV files to generate the network tree. FBxNet also processes the files and generates publisher-specific files for the connections and parameter mapping (map file) for each publisher device. You must download the CSV files for the FBxNet network to function.

1. In Monitor Mode, click File > Download files.
2. The Download files to subscribers screen shows a list of subscriber devices, showing the Site, Device name and IP Address of each FB3000 subscriber device.

**Note**

You will only see FB3000 devices in the list because only an FB3000 can serve as a subscriber.
3. By default, the screen shows subscribers for all sites. To only download the subscribers for a specific site, select the desired site from the Site selection box.

4. To download CSV files for all subscribers, select the Download check box. If you only want to download CSV files to certain subscribers, de-select the Download check box, and then check the boxes for only those subscribers to which you want to download CSV files.

5. To start polling all subscribers automatically after the download completes, select the Start Poll Cycle checkbox. If you do not want polling for all subscribers to occur, de-select that and only check those devices for which you want polling to occur.

6. Click the Download button. FBxNet downloads CSV files to the selected subscriber(s) and starts polling for any that have Start Poll Cycle selected. The Status field shows any error messages that occur during the download for particular subscribers.
4.13.1 Downloading CSV Files for a Single Site

If you only want to download files for a single site, in Monitor Mode right click on the site name in the Subscriber List pane and choose Download files.

This opens the Download files to subscribers dialog box for that subscriber only. Click Download to proceed.

4.14 Restoring the Backup of Previous CSV Files at the PC

If you upload files from a site's designated device to the PC, FBxNet first creates a separate backup file for the existing subscriber CSV files on the PC for that site (FBxNetFilesBackup.ZIP).

If, for some reason, you accidentally overwrite the CSV file for a site, you can restore the previous version from that site's FBxNetFilesBackup.ZIP file.

1. Close FBxNet.
2. Ensure that you have a FBxNetFilesBackup.ZIP file in the folder:
   \Users\Public\Public Documents\Emerson\FieldTools\FBx\FBxNet\sitefolder\FBxNetBackupFolder
   where sitefolder is the name of the site.
3. Delete the existing CSV files in the folder:
   \Users\Public\Public Documents\Emerson\FieldTools\FBx\FBxNet\sitefolder\FBxNetFilesBackup.ZIP
4. Unzip the FBxNetFilesBackup.ZIP file, then copy the unzipped CSV files to:
   \Users\Public\Public Documents\Emerson\FieldTools\FBx\FBxNet\sitefolder\FBxNetFilesBackup.ZIP
5. Restart FBxNet.

4.15 Making Changes to Your CSV Files

If you need to change your CSV file(s) after you download them, you can edit them directly in Configure Mode, or you can edit the CSV files manually in Microsoft Excel® or a text editor.

Making Edits Manually in Microsoft Excel® or a Text Editor

To edit CSV files manually click File > FBxNet folder and double-click on the folder for the site that contains the CSV file you want to edit. Use Excel or a text editor to modify the file, then save it. Make sure you save it with an extension of CSV. You must reload files modified by this method. To do this, click File > Reload Subscriber CSV files.
As part of the reload process:

- Previous connections are shut down.
- FBxNet clears previous CSV files from its memory.
- FBxNet validates the new CSV files and loads them into memory.
- FBxNet connects to the first subscriber in the list.

**Making Edits Directly in FBxNet**

To edit CSV files in Configure Mode, click **Mode > Configuration** and click on the name of the subscriber you want to edit, then click the edit icon. Make your changes and click **Save To File**.

**Downloading the Modified CSV Files to Subscribers**

No matter which way you make your edits, once you finish you must re-download the CSV files by clicking **File > Download files**. See **Downloading the CSV Files** for more information.

### 4.16 Viewing Status of the Subscriber Device

1. In Monitor Mode, select the subscriber device you want to see in the Subscriber List.
2. In the Network pane, click on the subscriber device (the top node in the tree) to open the Subscriber Status tab.

![FBxNet – Subscriber Status tab visible](image)
The Status pane displays the following information:

**Subscriber**  The name of the subscriber device.

**IP Address**  The IP address of the subscriber device.

**Status**  The status of the connection between FBxNet and the subscriber device.

**Last time values were refreshed**  The timestamp showing when status fields were last updated.

**Parameter**  This column shows the name of the database tag(s) in the subscriber device that provide status information.

**Description**  This column provides a textual description of the parameter to provide greater detail than the parameter name.

**Value**  This column shows the value of the database tag.

**Units**  This column shows engineering units for the value, if appropriate.

**Available Data Points**  Shows a list of the communication ports connected to this subscriber, and the number of data points on each port that FBxNet could potentially collect.

### 4.17 Viewing Status of the Publisher Devices

In Monitor Mode, click the Publisher Status tab.

#### Figure 4-21. FBxNet – Publisher Status tab visible

<table>
<thead>
<tr>
<th>Publisher Device</th>
<th>IP Address</th>
<th>Comm Port</th>
<th>Rows Loaded</th>
<th>Connection Status</th>
<th>Parse Status</th>
<th>Error Count</th>
</tr>
</thead>
<tbody>
<tr>
<td>ELMSTREET</td>
<td>10.211.74.103</td>
<td>5</td>
<td>1</td>
<td>Connection Timeout</td>
<td>No Error</td>
<td>0</td>
</tr>
<tr>
<td>MAINSTREET</td>
<td>10.211.74.104</td>
<td>5</td>
<td>0</td>
<td>Not Started</td>
<td>Not Configured</td>
<td>0</td>
</tr>
<tr>
<td>WATERSIDELANE</td>
<td>10.211.74.105</td>
<td>5</td>
<td>0</td>
<td>Not Started</td>
<td>Not Configured</td>
<td>0</td>
</tr>
</tbody>
</table>

**Subscriber, IP Address,**  See Section 4.16.
Status, Last time values were refreshed

Publisher Device
This column shows names of the publisher (server) devices.

IP Address
This column shows IP addresses of the publisher devices.

Comm Port
This column shows the communication port numbers used by the publisher devices. This is either 5 or 6.

Rows Loaded
This column shows the number of parameter mapping file rows that were successfully parsed from the publisher device. For example, if you have 5 parameters you are transferring between a publisher and the subscriber, this number should be 5. If Rows Loaded is less than the number of parameters you are transferring, this indicates FBxNet could not parse one or more of the parameter lines in your CSV file, and you should check the file for errors.

Connection Status
This column shows the current connection status of the publisher device. Possible status messages include:

<table>
<thead>
<tr>
<th>Message</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Not started</td>
<td>No parameter mapping file for the publisher.</td>
</tr>
<tr>
<td>Connecting</td>
<td>Subscriber attempting to connect to the publisher.</td>
</tr>
<tr>
<td>Resolving</td>
<td>Resolving the mapped parameters on the publisher device.</td>
</tr>
<tr>
<td>Online</td>
<td>Publisher is online and ready to be polled.</td>
</tr>
<tr>
<td>Offline</td>
<td>Publisher is disabled in the device connection file.</td>
</tr>
<tr>
<td>Invalid</td>
<td>Publisher’s parameter mapping file is invalid, or the response received from the publisher is invalid.</td>
</tr>
<tr>
<td>Connection Timeout</td>
<td>Subscriber could not connect to the publisher.</td>
</tr>
<tr>
<td>Transmit Error</td>
<td>Subscriber could not send message to the publisher.</td>
</tr>
<tr>
<td>Response Timeout</td>
<td>Subscriber timed out waiting for response from the publisher.</td>
</tr>
<tr>
<td>Resolving Failure</td>
<td>Error occurred while resolving the parameter map.</td>
</tr>
<tr>
<td>Read Failure</td>
<td>Error occurred while reading the parameters from the</td>
</tr>
</tbody>
</table>
No Account Found
The publisher must have a user account configured with FBxNet privileges. User accounts are configured in FBxConnect under Services > User Management.

Parse Status
This column shows the current parsing status of the publisher device’s parameter mapping file. Possible status messages include:

<table>
<thead>
<tr>
<th>Message</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>No Error</td>
<td>Parse was successful.</td>
</tr>
<tr>
<td>File Open Fail</td>
<td>Could not find or open the publisher map file.</td>
</tr>
<tr>
<td>Column Mismatch</td>
<td>Column of the map file is invalid.</td>
</tr>
<tr>
<td>Missing Required Column</td>
<td>Missing required column header in the map file.</td>
</tr>
<tr>
<td>Exceeded Max Data Points</td>
<td>Map file number parameters exceed the maximum allowed.</td>
</tr>
</tbody>
</table>

Error Count
This shows the total number of errors for connections to each publisher. You can zero-out this number by clicking Reset Error Count.

4.18 Viewing Details on a Single Publisher

In Monitor Mode In the network pane, click the icon for the publisher you want to view and the status pane updates with details on that publisher.
**Figure 4-22. Details on Single Publisher**

<table>
<thead>
<tr>
<th>Publisher</th>
<th>This shows the name of the selected publisher device.</th>
</tr>
</thead>
<tbody>
<tr>
<td>IP Address</td>
<td>This shows the IP address of the publisher device.</td>
</tr>
<tr>
<td>Comm Port</td>
<td>This column shows the communication port number used by the publisher device. This is either 5 or 6.</td>
</tr>
<tr>
<td>Status</td>
<td>Shows the status of the connection to this publisher.</td>
</tr>
<tr>
<td>Last time values were refreshed</td>
<td>Shows the last time the values were updated in the Status pane. Click Refresh to force an update.</td>
</tr>
<tr>
<td>Subscriber Tag</td>
<td>This column shows the names of database parameters in the subscriber device for which you want to transfer values using peer-to-peer communication. The heading for the column shows the subscriber device name.</td>
</tr>
<tr>
<td>Subscriber Value</td>
<td>This column shows the value of the subscriber parameter.</td>
</tr>
<tr>
<td>Subscriber Status</td>
<td>In this column, if FBxNet could not collect the value, it shows an error code. The most typical error is “Tag name is not valid. Error code:1307” which occurs when a parameter does not exist.</td>
</tr>
<tr>
<td>Operation</td>
<td>This column shows READ if the subscriber should read from this publisher or WRITE if the subscriber should write to this publisher.</td>
</tr>
<tr>
<td>Publisher Tag</td>
<td>This column specifies the names of database parameters in the publisher whose values the subscriber wants to read from or write to. The heading for the column shows the publisher’s device name.</td>
</tr>
</tbody>
</table>

Click Refresh to update the Status pane with the latest values from the publisher.
4.19 Modifying FBxNet Configuration Parameters

In Monitor Mode, click the **Subscriber Configuration** tab.

Figure 4-23. Configuration Tab

The Subscriber Configuration tab updates to show configuration parameters for each port on the subscriber device. The **Parameter** names begin with the name FBxNConfig_x where x is the port number. The **Description** field provides a textual description for the parameter and the **Value** field shows the current value of the parameter. The **Limits** field shows the range of valid values for that parameter.

See **Section 4.16** for details on the read-only fields.

You can select a **Parameter** and then enter its new value in the **New Value** field. The **Units** field shows the engineering units (if applicable). To finish and write the new value(s) to the subscriber, click **Save**.

The configuration parameters are:

- **TCP_CONN_TIMEOUT**  
  The number of seconds the subscriber waits for a response from a connection request before a timeout occurs.

- **RX_TIMEOUT**  
  The number of seconds the subscriber waits for a response from the publisher after the connection has been established.

- **RETRIES_NUM**  
  The number of retry attempts when a timeout occurs.

- **SCAN_RATE**  
  The frequency at which the subscriber polls its publishers.

- **POLL_CYCLE**  
  Enables/disables polling for this port.
4.20 Enabling/Disabling Fault Processing

Optionally, you can specify a database object to process a fault in FBxNet communications. For example, you can specify that if communications fail during transmission of a particular parameter, you could use its last good value, or a pre-configured fixed fault value. Fault processing also captures any error code generated from the fault, allowing it to be logged in the FBxConnect Diagnostic Report.

To enable fault processing, in Configure mode click **Fault Processing Enabled**.

**Important**

For I/O points, built-in hardware fault handling and user-configured fault handling in FBxConnect supersedes FBxNet fault processing because the hardware/firmware fault handling is more feature-rich.

Once enabled, FBxNet adds three additional columns to the Publisher Parameters Configuration screen. You must configure all three for fault processing to work.

**Figure 4-25. Fault Handling Columns**

<table>
<thead>
<tr>
<th>Fault Mode</th>
<th>FixedFaultValue</th>
<th>FBxNData Instance</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIVE</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>LIVE</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>FAULT</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>LAST_GOOD</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

**Note**

If after you configure the fault handling columns you de-select Enable Fault Handling, FBxNet deletes those columns and the entries you made from the configuration and your CSV file.

**FaultMode**

Use the selection box to specify how FBxNet handles a communication failure or other error from this publisher. Choices are:

- **LIVE**: Disables fault handling.
- **FAULT**: Switch to a pre-defined value, as specified in the FixedFaultValue field.
LAST_GOOD    Show the last good value received.

**FixedFaultValue**    When Fault Mode is set to FAULT, specifies an override value to be used when a communication error or other fault occurs.

**FBxNDDataInstance**    This field specifies the name of a fault handling database object and registers it in the FB3000 database. You can specify any unused FBxNDDataInstance object number; they follow the format: FBXNDData\_x

Where x is any integer between 1 and 10000. Once registered in the FB3000 database to belong to a particular publisher tag, this object instance stores any data quality or parameter “health” code received about a fault. This data can then be logged and may be viewed in the FBxConnect diagnostic report.

### 4.21 FBxNet Settings

Click **Settings** to open the FBxNet Options dialog box. You can decide whether you want FBxNet to display a dashed line on the screen for one or both communication line connections to publishers. Check the desired box(es) and click **OK**.

**Figure 4-26 FBxNet Options dialog box**

---

**Figure 4-27 Effect on Network Diagram**

---
4.22 Troubleshooting Tips

- Do your devices have firmware that supports FBxNet? If not, FBxNet will not work.
- Did you put your CSV files in the correct folder? They must be in \Users\Public\Public Documents\Emerson\FieldTools\FBx\FBxNet\.
- If you edited your CSV file(s) in Excel, did you remember to save them in the CSV format? They must be CSV files, not XLS files.
- Check the Rows Loaded, Connection Status, and Parse Status entries on the Publisher Status tab. This can help you identify where problems might exist.

4.23 Working with the Tag Browser.

The Tag Browser lets you examine all the database objects and their associated attributes for a selected FB3000 RTU.

1. Either click Open Tag Browser in the FBxNet menu bar, or click Tag Browser from the link in Publisher Parameters Configuration pane; either one opens the Tag Browser.

2. In the Tag Browser, select the Device name of the RTU or flow computer from which you want to view tags; once you make your selection, the Tag Browser populates the Target Object pane. (does this work only with FB3000 or other devices???)

Each database object shown in the Target Object pane corresponds to a particular feature or component that you configure in FBxConnect. For example, if you install a mixed I/O module in the device, there will be a database object for each type of input or output you configure in FBxConnect.

So for an I/O module that has two (2) digital outputs, there will be two instances (or copies) of the digital output (DO) object – one for each DO.
3. Select the desired **Target Object** instance. Once you click on it, the rightmost pane updates with the attributes for that object instance.

Each object typically also has one or more attributes. For example, for an analog input (AI), you could choose the raw value from the I/O point, the live value scaled for the applied engineering units, the tag name, or many other things.
4. Click the attribute of interest. Tag Browser updates the Tag, Data Type, Value, and 1131 Data Type (if applicable) for the selected tag.

5. You can click Copy Tag to store the tag name associated with that attribute in the clipboard, and then right click and Paste it into any field that accepts a publisher or subscriber tag.

Or you can drag the name of the attribute from the attribute pane, and release your cursor in the field where you want it; FBxNet pastes in the associated tag name.
Appendix A – Troubleshooting Tips

Following are some common problems that may occur and procedures for resolving them.

**Message: Failed to connect to Comm Manager**

You may see this message if something disrupts a communications connection. (Because they share some common code, Field Tools makes use of an OpenEnterprise session to communicate.) Stop and re-start the OpenEnterprise session using these steps:

1. In Windows Control Panel, double-click **Administrative Tools**.
2. Double-click **Services**.
3. Right-click on the OpenEnterprise Session and choose **Stop** from the menu.
4. Right-click on it again and choose **Start** from the menu.
5. Communication Problem Causing Truncated Messages

If you use RTS/CTS with radios and encounter a problem where Field Tools can transmit but RTUs are unable to respond, it could be related to PC port configuration in Windows which results in messages being truncated.

If this problem occurs, follow these steps:

1. Open the Windows Control Panel.
2. Click **Device Manager**. The Device Manager dialog opens.
3. Expand the Ports (COM & LPT) selection to display a list of ports.

4. Right-click once on the port used for Field Tools communications and choose **Properties** from the pop-up menu. The Communications Port (COM1) Properties dialog box opens.
5. Select the **Port Settings** tab, then click **Advanced** to display the Advanced Port Settings dialog box.
6. In the Advanced Port Settings dialog box, drag the Receive Buffer and Transmit Buffer slide bars to the low end of their ranges, and click **OK**.

7. Choose **OK** in the Communication Port Properties dialog box, and exit the Device Manager and Control Panel to save the settings.

8. Reboot your PC for the new settings to take effect.

9. **USB to RS-232 Serial Connection Problems**

USB to RS-232 serial converters vary widely in quality and performance. Other customers have reported good results with the following converters:

- BlackBox IC199A
- IOGear® GUC232A
- FDI's CHIPI-X10

If you experience problems with a particular USB to serial converter, there are a few things you can try:

- Make sure you installed the correct up-to-date software driver for your USB to serial converter. Sometimes a driver update can solve the problem.
- If the connection failure occurs after you unplug and plug back in, close the connections and unplug the USB from the PC. Then reconnect the USB and restart the connection.
- Some problems can occur from truncated messages. In Windows Device Manager, set FIFO transmit and receive buffers for the port to low as described above in **Communication Problem Causing Truncated Messages**. This may improve the USB connection.

**Eltima Message: ** **FAILURE: Access is denied**

You may see this message during installation if Eltima software had already been installed. You can ignore this message and click **OK** to allow the installation to continue.
VPN Causes Certain Features to Fail

When connecting to a virtual private network (VPN) certain features in Field Tools may fail to operate correctly.

Connecting to a VPN shuts down certain Windows services that Field Tools uses. (Because they share some common code, Field Tools makes use of an OpenEnterprise service.) While some services can reconnect automatically, others may require you to restart the OpenEnterprise service. If you need to do this, follow these steps:

1. Launch Windows Task Manager.
2. Select the Services tab.
3. Right-click on the OpenEnterprise service and choose Start Service.

The OpenEnterprise service restarts; features should now operate correctly.

Overlapping or Truncated Screen Items

If display settings in Windows Control Panel are set for larger fonts, you may see certain text items truncated (cut off) on the screen, or there may be overlapping between text items.

To solve this, set display settings in Windows Control Panel to use smaller text sizes.

Cannot Communicate with Device After Configuration Download or Cold/Warm Start

In some cases, after you download a configuration or perform a cold/warm start, FBxConnect cannot communicate with the device because the device reboot takes longer than expected, resulting in a communications timeout. If these timeouts occur, you can increase the amount of time FBxConnect waits for communications to be established with the device following a reboot.

To do this, you need to edit the values for the BootTimeAfterConfigApply and BootTimeAfterColdWarmStart parameters. These parameters specify the amount of time (in minutes) FBxConnect waits after a device reboot before declaring a communications timeout failure.
These parameters are located in the FieldToolsContainer.config file located in the folder:
\ProgramData\Emerson\OpenEnterprise\Application Data\n
In the example shown below, FBxConnect waits 5 minutes after a configuration download and waits 6 minutes after a cold or warm start before declaring a communication timeout.

```
<appSettings>
  <clear />  
  <add key="BootTimeAfterConfigApply" value="5" />  
  <add key="BootTimeAfterColdWarmStart" value="6" />  
</appSettings>
```

**Incorrect Timestamp in FBxConnect Logs**

Once you install Field Tools software, the software begins using the configured time zone in Windows when generating time stamps for historical data/logs. If you subsequently change the Windows time zone, you must re-boot your PC workstation for Field Tools to recognize the time zone change so it can be reflected in logs and historical data.

**Wi-Fi connections Incompatible with FIPS**

The encryption algorithm used for Wi-Fi passwords in Field Tools and FB1000/FB2000 Series Flow Computers is newer than the Federal Information Processing Standard (FIPS) standard and so is incompatible with it.

To prevent errors associated with this, you must disable (de-select) the System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing option for the Local Security Policy of your laptop/PC workstation.

**FBxConnect USB Driver Installation Issues**

Sometime the USB CDC driver does not install correctly. If that happens, follow these steps:

1. Launch the Windows Control Panel.
2. Click Device Manager.
3. Select Ports. Locate the CDC Serial Driver and right click on it, and choose Update Driver

   → Browse my computer for driver software
   Locate and install driver software manually.

5. From the next screen, choose Let me pick from a list of available drivers on my computer.

   → Let me pick from a list of available drivers on my computer
   This list will show available drivers compatible with the device, and all drivers in the same category as the device.

6. From the list presented, choose Remote Automation Solutions as the Manufacturer and QNX Serial Converter as the Model, then click Next and Windows reinstalls the driver.
Number of Supported ROCLINK Connections

Even though ROC devices support 6 active IP/TCP connections, launching ROCLINK from Field Tools limits the connections to 3. This is because one connection is made by Field Tools (to locally connect to the device and start ROCLINK) and the other connection is made by the ROCLINK application.

Message: *Comm Manager Connection Lost*

If the Connection Progress field on the Properties page for the connection reports this message, it may indicate a conflict between Field Tools and other software for the same TCP sockets. Edit the file `c:\Users\Public\Documents\Emerson\FieldTools\Application Data\CommManager.Config`

```xml
<appSettings>
    <!-- Clear all current settings -->
    <clear />
    <add key="CCLListenPort" value="40000" />  <!-- Change to 50000 -->
    <add key="DriverBaseListenPort" value="40010" />  <!-- Change to 50010 -->
    <add key="VPCLListenPort" value="40001" />  <!-- Change to 50001 -->
    <add key="AmsGatewayListenPort" value="40004" />  <!-- Change to 50004 -->
    <add key="HartIdListenPort" value="40005" />  <!-- Change to 50005 -->
    <add key="AmsComListenPort" value="20001" />  <!-- Change to 20001 -->
    <add key="RasAdminTaskListenPort" value="40002" />  <!-- Change to 40002 -->
    <add key="DBBuildServer" value="40006" />  <!-- Change to 40006 -->
</appSettings>
```

Change the `CCLListenPort` value to 50000, the `DriverBaseListenPort` value to 50010, the `VPCLListenPort` value to 50001, the `RasAdminTaskListenPort` value to 50002, and the `DBBuildServer` value to 50006.

To make the changes take effect, stop the OpenEnterprise Session, then re-start the OpenEnterprise Session. For information on how to do this, see the first troubleshooting tip in this appendix. **Note**: If you subsequently reinstall Field Tools you must redo these changes.
Appendix B - Field Tools Uninstallation Procedure

Normally, you can uninstall Field Tools like any other Windows application and just reboot your PC. Under certain circumstances such as a failed installation or some sort of file corruption, it may be necessary to take additional steps such as cleaning the installation folders and editing the Windows Registry.

Uninstalling from the Windows Control Panel

1. Navigate to Control Panel > All Control Panel Items > Programs and Features.
2. Right click on Field Tools from the Uninstall or Change a program list.
3. Choose Uninstall to start the installation wizard.

4. Choose Remove and click Next. Wait for the uninstall process to complete (this may take a few minutes), then click Finish, and reboot your PC.
Cleaning up and Deleting Installation Folders

1. Navigate to the C:\Program Files (x86)\Emerson folder.
2. Delete the Emerson folder.

*Note:* If Windows prevents you from doing this, go to Task Manager and stop the OpenEnterprise and Emerson.RuntimeDataService services and under Details, end the OEOPCDAServer.exe task.

3. Navigate to the C:\ProgramData\Emerson folder.

*Note:* If the ProgramData\Emerson folder is not visible, go to Windows Control Panel, choose File Explorer Options and from the View tab, make sure “Show hidden files, folders, and drives” is selected.
1. Delete the Emerson folder.
2. Navigate to the Users\Public\Public Documents folder.
3. Delete the Emerson folder.
4. Navigate to the Users\current user\Documents folder.
5. Delete the Emerson, MultiGrid and OpenEnterprise folders.
6. Navigate to the C:\ProgramData\Microsoft\Windows\Start Menu\Programs folder.
7. Delete the Emerson Field Tools folder.
8. Reboot the PC.

Cleaning the Registry

1. Click Start > Run and type RegEdit to launch the Windows Registry Editor.
2. Navigate to Computer \ HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node and delete the Emerson folder as shown below:
3. Exit the Registry Editor and reboot the PC.

Deep Cleaning the Registry (Usually Not Needed)

1. In RegEdit, navigate to Computer \ HKEY_CLASSES_ROOT\  
2. Delete all EMERSON keys that are followed by the text “.OE,” “.OpenEnterprise,” or “.Tools.Shared”.
3. Navigate to:
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\SessionManager\Environment
4. Double click on the Path string and then delete the C:\Program Files (x86)\Emerson\OpenEnterprise\Bin; path from the Edit String dialog box as shown below:

5. Click OK to close the dialog box.

6. Click Edit >Find. In the Find dialog box, make sure selections are made to look at Keys.

7. Type OpenEnterprise in the Find what edit field and click Find Next.

8. Delete each OpenEnterprise key and continue (use F3 key to continue the search) until no OpenEnterprise keys can be found.

9. Exit the Registry Editor, and reboot the PC.
Index

A
Active Connection Pane 37
Adding RTU login credentials for a user 24

C
Connection 24
before you establish a 19
closing 37
creating a new connection 27
direct 36
exporting 38
importing 38
importing from ROCLINK 38
Connections list 24

D
Deleting a Field Tools user 23
Direct connection 36
Disabling UAC 9

F
Field Tools 5
logging in 20

I
Installation 8
before you begin 8
procedure 7
requirements 7
silent 15

L
login credentials 27

P
Passwords 21
changing 21
setting the minimum length for 23

R
RTU login credentials 27

S
Security 23
adding a user 22
changing the password 21
logging into Field Tools 20
setting the minimum length for 23
System requirements 7
minimum 7

T
TechView 10
special notes about 10
Troubleshooting
FBxNet 75

U
User Account Control (UAC) 9
disabling 9
Users 22
adding 22
defining a Field Tools user 22
deleting a Field Tools user 53
For customer service and technical support, visit www.Emerson.com/SupportNet

Global Headquarters,
North America, and Latin America:
Emerson Automation Solutions
Remote Automation Solutions
6005 Rogerdale Road
Houston, TX 77072 U.S.A.
T +1 281 879 2699 | F +1 281 988 4445
www.Emerson.com/RemoteAutomation

Europe:
Emerson Automation Solutions
Remote Automation Solutions
Unit 1, Waterfront Business Park
Dudley Road, Brierley Hill
Dudley DY5 1LX UK
T +44 1384 487200 | F +44 1384 487258

Middle East/Africa:
Emerson Automation Solutions
Remote Automation Solutions
Emerson FZE
P.O. Box 17033
Jebel Ali Free Zone – South 2
Dubai U.A.E.
T +971 4 8118100 | F +971 4 8865465

Asia-Pacific:
Emerson Automation Solutions
Remote Automation Solutions
1 Pandan Crescent
Singapore 128461
T +65 6777 8211 | F +65 6777 0947

© 2017-2020 Remote Automation Solutions, a business unit of Emerson Automation Solutions. All rights reserved.

This publication is for informational purposes only. While every effort has been made to ensure accuracy, this publication shall not be read to include any warranty or guarantee, express or implied, including as regards the products or services described or their use or applicability. Remote Automation Solutions (RAS) reserves the right to modify or improve the designs or specifications of its products at any time without notice. All sales are governed by RAS terms and conditions which are available upon request. RAS accepts no responsibility for proper selection, use or maintenance of any product, which remains solely with the purchaser and/or end-user.